03 2.1 x type, auto sedan no spark evident

(John Czaban) #1

Have had the car for about 12 months now, bought it as a project,
Had it delivered and drove it off the truck after jump starting it, it was sluggish to start, but when It did after a few minutes it ran and started fine. I then decided to clean up a few things an d I judiciously changed the plugs and coils and tried to start it - nix. Narrowed down to a spark problem, plenty of fuel pump noise and pressure in the fuel rail, Changed the crank angle sensor and 1 cam sensor , all tested OK with DMM. Spoke to one of my local mechanix and he came with his scan tool and told me that the computer was shot. I proceeded to have it cloned and replaced it with full confidence but to no avail, still no spark. Have replaced fuel and air filters on the way
Proceeded to aquire IDS/SDD 131.03 and got it working
The only fault evident is a U1900 Can bus fault,
Have reprogrammed keys, reset ecu many times.
On WDS the modules come up with a green tick next to them and according to the program
they should be communicating, Still no spark.
Is there a way I can test for a faulty module which may be mucking up the can bus?
The frustration grows so I keep looking for answers
Another forum suggested that because the engine symbol on the dash disappears after 3 seconds of turning the key the immobilizer is active, Is that true?
I have run the immobilization program successfully on IDS with no result
As you can see, my dilemma is a challenging one
Any input would be most welcome
Regards
John