1986 XJ6 starts normally but stops after a couple seconds

1986 XJ6 starts normally but stops after running a couple seconds. A second try sometimes also starts and runs for what I think is a briefer time.

It seemed to make perfect sense that for some reason the AVM was not turning on the fuel pump, but I was wrong: with ignition “on” the fuel pump indeed DOES run when I open the “vane” in the AVM.

Right now I am stumped. Thanks for listening!

1 Like

Did this car run nicely for you for a long time and then just started acting up recently? Or did this car sit for a long time and you are trying to get a new to you car running again?
BTW, welcome to Jag-Lovers.


Thank you, Paul. No - car has been reliable and in light constant use. One strange event which I can’t see as related: a few days ago, driving down a city street, it just died. I pulled off (no power steering!) and soon restarted normally. Not certain, but I think all the lights on the dashboard went off for a bit. I had over the winter loosed a battery cable, and I assumed it had briefly jiggled “no contact.” But, no, this seems like a sudden thing.

If the fuel pump is operating like it should, is there any potentially messed up sensory input to the ECU which would cause it to shut the fuel injectors way way down?

Or, I suppose, even way way high? Maybe if they flooded the cylinders might that be why I have to wait awhile to get it to briefly run again, for the gas to drain away?

1 Like

You just described the classic symptoms of a failing ignition switch. If I were you the first thing I would do is remove and replace your ignition switch, Jaguar part number DAC1607. It is quite likely this is the cause of your problems. If not, then you will have eliminated the ignition switch as a culprit.
If you search the Jag-Lovers archives for “ignition switch” you will find dozens of posts describing similar symptoms as yours with seemingly unexplainable random engine shutdowns. Some of them will be from me back in 2000 or so when this happened to me. A new ignition switch will very likely fix your problem.


First, Henry, try selecting the other tank; it may be a fuel delivery problem - like an empty tank/blockage. A second try ‘sometimes’; explain ‘sometimes’ - after several tries…??

Referring to Paul’s post; jumpwire battery ‘+’ to coil ‘+’. This will principally bypass the ign switch to power the white circuit. An intermittent ign switch failure may sometimes work in ‘on’ - and sometimes not. Which may make the AFM ‘open flap’ test misleading…

If no change; also remove fuel relay and add jumpwiring relay socket white to socket white/green to bypass relay. You can add supervision of pump power by connecting a test lamp between socket white/green and ground…

As the engine starts and runs briefly; the ign is not prone to failure this way. But if the fuel pump does not run in ‘on’ the engine may run briefly on ‘crank’ fuelling - and stop quickly as fuel pressure drops. Which will happen quickly if the non-return valve fails to hold pressure - and run for some time otherwise…if ign is maintained, which is cut if white power fails…etc, etc…

If ‘several tries’ is required for starting mentioned in your post; connect a spare spark plug, triple gapped, to any plug lead to verify sparking in ‘crank’ and ‘run’. It will not prevent starting or running if ign works…

If both jumpwires fail to restore engine running; you may have more ‘exotic’ fault(s) - to be addressed…

xj6 85 Sov Europe (UK/NZ)

Anignition switch or wire isssue.
The coil gets 12 v on crank, but not in run.

Try juming 12v direct to coil = and try agsain. if the engine continues to run, you have onfirmed that fault.

Teh repair may entail droping the scuttle nd removing the ignetion switch t probe for voltd.


Gosh Paul, has it been that log???


Thanks, all.

(1) jumping +V to spark coil - problem is the same; therefore does not seem to be ignition switch fault.

(2) bypassing fuel pump relay - also problem same; also I do find white/green has +V; fuel pump getting voltage (and I assume it stays operating, but I haven’t actually confirmed that).

What next? I’ll try to find a spare spark plug and check to see if spark continues after that initial couple seconds.

Also, to be more specific about trying to start it: first try it runs for a second or so; second try same; third and subsequent tries no start. Until I try considerably later, with the same results.

Any reactions to my thought that for some reason the ECU decides to shut down the injecting? How might I look for that? Any likely sensor input culprits?

Again, thanks!! It is wonderful for people to try to help.


Injection is triggered from the wire at coil ‘-’, Henry, so it is important to verify ignition (strong blue spark) - and the spare spark plug is the least invasive method…

If you have a small test lamp (injector test lamp); connect it between coil ‘-’ and ground. With ign ‘on’, the lamp should be fully lit - while cranking/running, the lamp should dim and flicker. This test weakens the sparks somewhat, but does not interfere with injection…

Other sensors; the AFM and the coolant temp sensor - the latter easily tested with an ohmmeter. With a cold engine and a shorted CTS the mixture will be too weak to run the engine. The engine may briefly start on petrol from the cold start injector - then stop.

However, the thermotime needs some time, minutes, to reset between cranking attempts before operating again. Ie, rapid repeats won’t do, but if you wait 5 minutes between cranking - which may explain the variable reactions with cranking attempts…?

The injectors are best tested by listening (stethoscope/long screwdriver to the ear) - the injectors should click as long as the engine is turning with ign ‘on’. As should of course plug sparking.

An aside; plain voltage reading is inadequate; you need a test lamp - there might be voltage without any power!! You need proof there is actaul power - like a running pump and plug sparking…

Keep at it; it’s an elusive problem - but when found out, the cause will be blindingly obvious…:slight_smile:

xj6 85 Sov Europe (UK/NZ)

Keep at it indeed Henry. I have been fighting and debugging my no start situation on my 86 for months… anger, denial, depression… All the usual steps of grieving😂

I am headed over to do battle with mine for the day!!


Are you receiving the appropriate skilled help for your condition, as I am?

Yes, it has been that long!
In the fall of 2000 I drove my new to me 1984 XJ6 Vanden Plas from our home in San Diego to Los Angeles for my first family outing in my new Jaguar. The drive up was smooth and comfortable and everything worked as it should until I pulled into the parking spot at the hotel when the car died completely and wouldn’t restart. The instant that happened everything shut off, the warning lights and gauges stopped along with the engine. The engine would not restart so I locked the car manually, we went into the hotel to check in, and we attended our event.
The next day I tried to start the car but I was unsuccessful. The car had had alternating “Fails to Crank” and “Cranks but doesn’t start” symptoms. I had the car towed back to my house where I could trouble shoot the problem and discovered the failed/melted ignition switch and the rats nest of spliced wiring behind it in the dash for the aftermarket mobile phone and aftermarket security system that the prior owners had installed. I removed all the aftermarket components, repaired some damaged wiring, and installed a new ignition switch. The car started up right away, and I haven’t had that kind of random complete car shutdown since in any of my Series III XJ6s or my XJ12. I sold that car in 2020 before leaving California for South Carolina.


it was about that time that I got my XJ!. I did not know of JL at teh time, either. And, sbpout when mine conked out circa Stockton, CA.

i learned of J-L from a defense attorney that i worked with. he had a raggedy XJS V12.

My car is still with me.

And, Aye, it had some weird electrics for a time. Solved when I got a NOs ignition seitch via David Boger. The instllation was fiddly, but not that hard. i found a pO had disconnected the buzzer. i connected it.

And mie had a somplistic alarm system. A real crude dud. i removed it and any splices /

When i did the lump job, I soldered a lot of wires.

well, one joint failed a cuple of months ago. Resulted i a crank and no strt.

witht he help of my tlnted son, we trcked it down and foixed it.

he is against soldered joints and prefers crimed splices. I like soder…


Hello Paul, Frank, Carl, others?

New clues below!

First, review: engine starts normally but stops after a second or two. Second try might also run a second or two - or might not. Successive tries do not get it to start at all. After a while (quite possibly the time for the thermotime switch to cool down) when I try the above, same thing all over again.

Previous findings: (1) not ignition switch. (2) not the fuel pump (or it’s relay) which stays operating. (3) not the AVM, or at least opening the AVM vane does turn fuel pump on.

New: (1) Coolant temperature switch: resistance 0.89 k ohms at ambient roughly 80 degrees F. This is somewhat low, corresponding to a temperature of about 140 degrees F.
Would this matter?

New: (2) Thermotime switch: it does start out closed (1.0 ohm), then when turned on, it soon goes high (280 ohms). After some number of minutes it returns to closed 1.0 ohm.
This seems right, doesn’t it?

New: (3) This is big! If I disconnect the thermotimer and manually short its switch connection to ground (thus apparently keeping the cold start injector active), the engine will start AND KEEP RUNNING IF I KEEP THE IGNITION SWITCH IN CRANK POSITION!

(3A) Shorting the thermotime switch but not keeping ignition in “crank” I get the familiar start-and-run-a-second-or-two, but I can do that as many times as I want - not just twice; I think you were correct about the delay being the thermotime switch coming back to temp
Seems very close to solving the problem!!

So where are we?
Might we be operating with the cold-start injector alone? What else operates only while cranking and not in “ignition on” switch position?

I feel a bit of excitement.

Thank you,


Not qite!

It runs as you have the swth n crank and that feeds vols to the coil.

Back to basics.

Jump 12 to the col +. I suspect it will crank, fire and continue to run.

Bad wire from Ignition witch to coil+/


wouldn’t you test the switch first and not assume it’s faulty & just replace it because it might be???

Ie, Henry; there is no change when you jumpwire bat ‘+’ to coil ‘+’?

Yes, but probably not to the extent of causing the symptoms described. It’s just wrong, and may even be more wrong at other temps. The CTS is rather important for mixture control, and is either very precise - or defective.

However, where and how did you measure the actual engine/coolant temp - the engine may not be at ambient temp? Check the resistance at other temps in a water bath - using an infrared thermometer. If 'imperfect; replace…

No - but retest with correct procedure. Disconnect plug from CSI and connect a test lamp between the plug’s wires. Turn ign to ‘crank’ (in gear - actual cranking is not required). The lamp should light up briefly, time is engine temp dependent - some 1,5 seconds at your 80F.

The TT is a thermal switch; when cold it grounds the CSI (0 ohms). A heating coil warms a bimetallic spring (in ‘crank’ - which also powers the CSI) and breaks ground after a specific time - depending on engine temps. At freezing point (0C/32F) the spray last 4,5 seconds. Exact measuring requires a precise temp reading and a stopwatch…:slight_smile:

After the spray time, the CSI/TT plays no further part - if working correctly…

Two factors. Grounded, the CSI will continue to spray in ‘crank’ - in addition to normal fuelling. The engine should grossly overfuel, but the XK can stand a lot of fuel and still run. However, that the engine stops when returning to ‘on’ implies lack of fuel in ‘on’.

Secondly; it ign is lost in ‘on’ the engine will also stop. The critical indicator is that with ign to ‘off’ the ign instantly cuts, but engine still turns…so…?

Certainly the CSI may run the engine without injected fuel - fuelling rich and wrong. Your symptoms fit, sort of, a situation where the pump stops in ‘on’.

Back to the AFM flap. Turn ign ‘on’ and gradually push in the flap - checking how far the flap must move for the pump to start. You can compare that with actual flap position with the engine running…

The point is that it is the air flow that moves the flap to operate the reed switch - and the opening may be insufficient to start the pump. You may further try starting the engine with the flap moved a bit past this position?

The reed switch is somewhat frail, and while there is no particular reason why it should suddenly fail - nor does it require a reason…:slight_smile:

It’s just more steps to further eliminate possible causes - then we’ll proceed…:slight_smile:

xj6 85 Sov Europe (UK/NZ)

First, it is NOT the ignition switch, as connecting the coil + with battery + does not change the problem.

Second, the AVM SEEMS OK, because with ignition on, the fuel pump turns on when I open the flap a 1/4 - 1/2 inch.

Third, Frank, if I disconnect the CSI and put a test light on the connector terminals, the light turns on when I crank, then goes out after a few seconds. From that I believe the thermotime switch DOES properly turn on the CSI for its few seconds then stops. Also, with the CSI not connected, I DO NOT get the familiar “runs for a few seconds” behavior, i.e., it doesn’t run at all.

I infer from that that the engine runs as long as CSI is active but DOES NOT RUN thereafter. Seems clear that for some reason the six injectors either are not firing or are being told by the ECU to send either way too little - or possibly even too much? - fuel.

And the cause of that is NOT the fuel pump, which seems to run as it should (though I have not checked its pressure, I have seen it squirt quite impressively).

Looking for something which could disable the six injectors, I felt quite excited when I saw that the Inertia Switch could easily do that!! But I was wrong: it is about 0 ohms until I pull its button, when it is more like 300 ohms. Seems totally normal.

So, what might make those injectors not do their job?

I appreciate any thoughts!

             Henry (USA, Maine)

The injectors are triggered by a white/black wire from coil ‘-’. The wire goes to the ECU through a bullet connector about midway on the bundle on the right side of the head. This bullet connector occasionally causes problems and should be checked. Search ‘bullet connector’ in the archives.

Basically, as the ECU powers up; the injectors should click once as ign is turned ‘on’ - and if the bullet connector is reconnected after disconnection while the ignition is ‘on’. Easily tested…:slight_smile:

Otherwise, the ECU ‘computes’ the time the injectors should stay open (crudely varying in the 50 mS range) based on the CTS(!) and air temp sensor inputs - and the AFM flap movement. Faults will of course give faulty mixture. The ECU is thus ‘programmed’ to enrich fuelling in the cold/warm-up phase…

It does indeed seem that ‘insufficient’ injection is the problem. And the connection between the coil ‘-’ and ECU via the bullet connector (and resistor pack) should be checked as the next step…

xj6 85 Sov Europe (UK/NZ)