1987 XJ6 no start

Hello All,

So I’m totally stumped. My XJ6 was running beautifully until the other day I was driving home and it just died. Somehow got it to run a bit got it home and now it just won’t start.

I have a strong starter and spark so I moved on to fuel system. I did the jumper test at the fuel pump relay and I get power to the fuel pump but no fuel coming to the fuel rail. I tested the AFM flap and can hear the relay click. I went to the rear of the car and directly powered the fuel pump- still no fuel. Then I bypassed the changeover valve directly from one of the tanks- no fuel. This was a brand new fuel pump.

I changed this fuel pump pre-emptively because the other one was too loud. I kept it anyway and tried to hook it up to see if that pump would work. I get nothing pulling through. Could I have two bad fuel pumps that were working but miraculously now don’t? Something doesn’t smell right:)

Can anyone help? Thanks!

Have you removed the fuel filter to see if it is plugged?


Yes- that’s also brand new. However just to be sure I bypassed the filter still nothing. I worked my way backward from there. I then hooked up the fuel pump directly to a tank and into a bottle- No fuel coming out with direct power to fuel pump. Pumps hum but no pressure.

Ok plot thickens-
I must have had my jumper on wrong. When I test the fuel pump I have fuel in the rail and can hear it hissing. This is what I have done so far.

  1. Checked for spark when cranking- I have spark at Cylinder 1
  2. Fuel Inertia cutoff- check
  3. Jumpered Fuel Relay- Check- fuel flows to rail
  4. AFM flap activates relay
  5. Directly powered fuel pump- Fuel pump works.
  6. I have 12v at the Fuel injectors

Car still will not start.

Update: Resolved- Sort of…
No pulse at injectors.
Pulled the Air flow meter plug and it started- ran rough then stalled.

Guess its the Air flow meter. Now how can I find one- every source is out!

That’s no way of identifying a failed AFM, Jeffry - the engine may run with the AFM plug disconnected. But no injector action at all with the AFM connected would be odd…

On the AFM; check resistance over pin #8 and #9 (3rd and 4rth for rear) - should read 220 ohm. Likewise; check between pin#6 and #7 (5th and 2nd from rear) - some 400 ohms. The latter varies with flap deflection - but in conjunction they act as voltage dividers, regulating injector pulse width. With the plug disconnected; the ECU reads infinite resistances, which may trigger some ECU reaction…

There is a possibility that wear in the resistor board’s flap’s crank/idle position is causing a problem - which may further examination. But repeat your test with plug disconnected - then, with the engine running, reseat the plug…?

Have you checked voltage at the injector plugs - should read 12V on both wires. If ‘yes’; the ECU is not getting triggering signals from the ign amp. If ‘no’; the ECU is not powered. As ign is turned ‘on’; the injectors should click once, each time - indicating ECU is powering up.

xj6 85 Sov Europe (UK/NZ)

Actually really good points. I will check pin connectors today. Regarding injectors I do have 12 volts at the injector tabs.

David Boger at everydayxj. good guy. Great service. reasonable prices.


Hi Frank,
Thanks for the info- so here’s an update
My friend had an extra working AFM and you’re right- AFM checks out as not the problem as measurements are on.
Confirmed there there is no pulse at injector after putting noid light on. I have power at the main relay, power at going to the resistor pack and power at the injectors. Just no pulse.

Could it be a failed ignition amp?

From left field

What triggers the injectors. A signal from the amp ?

The amp creates a pulse. An on/off thing. Much like old points did, Do you have spark when cranking? if so, the amp works…

I have spark and I have power at the injectors- just no pulse.

Not if you have ignition, Jeffrey - the ign is more sensitive to ign amp failure than the injection…

However; connect the noid between coil ‘-’ and ground. With ign ‘on’ the lamp should be fully lit - while cranking; the light should dim and flicker as ign amp ‘makes’ and ‘breaks’ coil’s ground connection. Firing the coil/plugs and trigger the injection…

I suspect the connection to the ECU (white/black on coil ‘-’) has failed. Find the bullet connector in the wiring along top of the engine and check for connection/conductivity. It doesn’t quite gel with the fact that injection occurred with the AFM disconnected (engine ran) - but it may be a different mechanism operating the injectors then…

If nothing is found; jump the the bullet connector’s ECU end directly to coil ‘-’, and try starting. The wire between the coil and bullet sometimes breaks/shorts - check.

Short of a failed ECU; no connection between coil ‘-’ and ECU may explain matters…

xj6 85 Sov Europe (UK/NZ)

Just on general principles…

Look at the rear of the water rail and you’ll see a bundle of ground wires…about half a dozen. The entire fuel injection system is grounded here. Make sure all the wires are clean and tight.

However, my money is on the white/black wire at the coil, as Frank mentioned.


Thanks- this is so helpful- So the wire at the coil is good. With the ignition on, I can plug the bullet connector in and out and I hear the electrical “tick”. Also I jumped the wire from the bullet to the “-” and I hear that tick the same way.
The only thing I haven’t done is the noid light to negative. Sorry can you tell me how that works? Also- can you confirm what triggers the Fuel injection Module again? Is it the “-” on the coil?

So just to recap:
Fuel pressure in rail
Good fuel pump
12v at Injector Resistor with key on
12v at both injector pins with key on
Negative grounds cleaned and tight
B/ack/white wire good
Just no pulse.

I have a new amplifier (I know now this is not related)

Are we talking thinking ECU? Power to ecu?

does the system have a crankshaft sensor? no signal, no pulse??

That ‘tick’ is supposed to be the injectors clicking, Jeffrey - listen at the injectors to confirm!

As ign is turned on; the ECU and coil is powered up and the injectors click once - not to be confused with the clicking of the main relay. Dis-/reconnecting the bullet only imitate the trigger pulse from coil ‘-’, power from coil neg activates the ECU

It’s very important that the clicking you hear are indeed the injectors clicking - it basically conforms that the connection from coil ‘-’ to ECU is intact. The ECU is independently powered from the main relay, confirmed by voltage at the injector plugs…

With engine turning, the ign amp alternately ‘makes’ and ‘breaks’ the coil’s ‘-’ connection to ground; with engine not turning the amp is in ‘break’. In ‘make’; current is flowing through the coil - charging it. As ign amp breaks ground connection; the coil discharges - sparking the plug(s).

Ignition ‘on’; the noid, using jump wires, (or any test lamp) between coil ‘-’ and ground lights up as battery voltage is applied through the coil - and the amp is ‘break’; lamp fully lit. When the engine turns; coil ‘-’ rapidly alternates between +12 and ground - causing the noid to dim and flicker…

The injectors are powered from the main relay by one wire through the resistor pack - the ECU just grounds the injector briefly, using the other wire. Using the noid as an injector test lamp; it is connected over the injector plug. With ign ‘on’ the noid is unlit as it is not grounded - but you read ‘parasitic’ 12V on the ECU wire, and 12V from the main relay. Cranking; the noid flickers as ECU switches ground on and off…

If you have all the right signals and the injectors ares still not operating; something funny is going on…

xj6 85 Sov Europe (UK/NZ)

Hi Frank,
Thank you. I can definitely confirm that the click is the injectors and NOT the main relay. Just tested the “-” to ground and I get constant light and flickering when starting.
So to recap:
Confirmed 12v Power going into resistor
Confirmed 12v power. at injectors
Confirmed solid ground for injectors
**No Noid activation at injectors
Confirmed Test “-” on coil to ground checks out
Confirmed Fuel in Rail
Confirmed working fuel pump
Confirmed working main relay
Jumpered Main relay confirms fuel pump activation

Am I down to ECU? Im going to need to be committed if I can’t figure this out lol. :face_with_symbols_over_mouth:

The injectors are grounded by/in the ECU, Jeffrey - every third ignition pulse…

So there is no flickering of the noid when connected to an injector plug - and cranking? But the injectors definitely click when dis-/reconnecting the bullet connector?

If so; this is highly bewildering - it cannot happen. Try the bullet again; with ign ‘on’ - injectors should click at every third reconnection, indicating that the ECU is responding correctly. That injectors then do not respond while cranking while all other cranking inputs seem to work is, as said; ‘unusual’. Never had such a combination before - it may be an unusual ECU fault, or something we are overlooking…

Connect a proper test lamp, not the noid, between ground and one of the wires on an injector plug ign ‘on’. One wire will have 12V main relay power, and the lamp will be fully lit - the other wire has no power and will not light the lamp. With the lamp fully lit; crank the engine wile observing the lamp - it may dim slightly, but should remain lit. The theory; power to the injectors is lost in ‘crank’ - weak, but we are running out of options…

Byt do also re-verify that you have ignition; connect a spark plug, triple gapped (2,5 mm or so) and connect to any plug lead (ensure good ground connection of the plug body). Crank the engine - you should have regular strong, blue sparks. Theory; while ign was tested, and the engine did start (possibly by fuel from the CSI, engine cold) - faults may have developed further. The noid/coil test is not decisive - though ign amp should actually operate the injectors even if ign fails…

The ECU is a remote suspect - but not impossible…

xj6 85 Sov Europe (UK/NZ)

Hi Frank,
Thats correct. I just tried noid again- no flicker. However when I disconnect the bullet connector I get the click EVERY time- not just every 3rd time.

I will perform the other tests in a bit.

Doesn’t that mean the circuit is shorted to ground somewhere? Perhaps inside the ECU?

1 Like