1995.25 XJS 4.0L won't start, already replaced CPS

Hi All,

New to this forum & these cars. I have a 1995.25 MY XJS 4.0L with about 150k miles. The engine has run great since I had it, and now won’t start. Of course I was working on something when it happened, so I suspect I caused the problem. I put lots of details below, would appreciate any advice or questions if more info is needed.

Best Regards,


  • Engine has been running fine, car driven a couple days a week
  • A few weeks ago the lights on the speed/gauge section of the dash stopped working.
  • One day I decided to look into that problem. I won’t divert to that story, but at one point I had the speedo cluster out and decided I should check the voltage on some connector pins with the engine running.
  • The engine didn’t start, and hasn’t started since. So it seems a lot like I did something wrong (knocked a connector loose, etc), but maybe the timing is a coincidence.


  • Engine turns over fine
  • Tach shows 1000 rpm when cranking, which seems wrong to me
  • Doesn’t catch and run
  • Seems like classic no-fuel or no-spark case

Diagnosis so far

  • Fuel
    ** Disconnected feed hose at rail, put in a bottle, filled the bottle in a couple of seconds of cranking. So seems to have volume.
    ** Don’t have a pressure gauge, so reconnected feed hose and disconnected return hose at regulator. A couple of seconds of cranking produced a few of spurts of fuel out of the regulator, so it seems to have pressure (assuming the regulator is good).
  • Spark
    ** OK, this car has no spark plugs, well there’s the problem…
    ** Found them, and about 2-3" of oil in the wells
    ** Tightened the cam cover screws to a couple of ft-lbs, they were completely loose
    ** Cleaned the wells & the coil boots, replace the spark plugs, set gap to 0.035"
    ** Checked the front plug for spark, it is making a spark but doesn’t feel like a regular rhythm. I realize that’s subjective.
  • CPS
    ** Did some searching/reading, found out about the tendency of CPS to fail.
    ** Replaced CPS, but no change in behavior.

If you have fuel coming out of the regulator, then the inertia cutoff switch at the passenger door hinge hasn’t been triggered.

The tach at 1000rpm is high. I wonder if the crankshaft position sensor isn’t dying/dead.

I wonder if one, or more of the coils haven’t died? That’s always a possibility. Have you checked that each of them are firing at startup?

Lastly, the cylinders might be full of oil, not helping you either.

If you think you have spark and fuel try cranking the engine with your foot hard to the floor on the accelerator pedal, it might be that somehow the engine is flooded. If it is flooded it takes quite a while to clear so don’t give up too early.

Thanks for all of the feedback. I realized that I’ve been cranking the engine a lot with no joy, checked the battery voltage and it is now 11.8V. So I’m going to charge the battery today, then will try the suggestions tonight/tomorrow and report back.

Thanks again for all of the help. BLUF: got it to start, but won’t idle. Details:

  • Crankshaft position sensor has been replaced
  • Charged battery fully
  • 24 hrs since last start attempt, tried to start, didn’t work
  • Held down throttle while starting, it started!
  • Able to start with just a little throttle, but dies if I let it idle on its own
  • Clamped throttle at just a little open, running at ~600 rpm
  • No codes on OBD, but it’s running rough
    ** Does this car have an OBD output for misses? I’m not seeing it.
  • Checked all coils, they are all making spark, can’t say how reliable
  • Calling the front-most coil #1 and the rear-most #6 (not sure of Jaguar numbering)
  • Disconnecting any one of #1 - #4 makes it run a little rougher, but not much
  • Disconnecting #5 or #6 makes it run a lot rougher
  • All coils are Lucas from 2004, off-car primary resistances 2 - 6 ohms
    ** I haven’t found a primary resistance spec
    ** But the coils are certainly old
    ** At a guess, maybe #1 - #4 are intermittent

This sounds like it could be a fueling problem. Just want to cross off sensors first.

Do you have the capability to read the OBD2? Id like to see what the TPS is reporting.

Thanks for the suggestion, I can read the OBD2. I’ll get the TPS reading & report back, may take a couple of days.

No need to turn the engine over to run this test. Just turn the car on, without the engine running and you should be able to pull up the TPS percentage at idle.

Glad to hear the WOT (wide open throttle) worked to get the car started, it does sound to me that the coils could be on the way out.

1 Like

On a related note, what should be a min. acceptable voltage at the battery? My radio bluetooth device that is plugged into the cig lighter (to play music from my smartphone) has this feature where, when the engine is started up, it shows briefly the car battery voltage. Mine usually reads about 13.4 volts. Is that about where it should be? :confused:

One possibility is the Starter relay. I had intermittent probs and checked the tranny neutral switch- all ok.

Turned out it was the starter relay and although it clicked when energised no current was getting from terminal 30 to 87. When it previously would it was just one of those things that happens with any sort of electrical contact points.
Try a new good relay ang good luck


Thanks to all for the ideas. Some results:

Veekay - I read the TPS with car on, engine not running, it reports 10.59%. I clamped the throttle open a little reading went to 18.81%, let it snap back and it returned to 10.59%. So it seems like the sensor is responsive, but I don’t know if 10.59% is the correct idle position.

Robin_O_Connor - agree coils are likely at least part of the problem, have a couple of Eurospares on order for testing.

AttyDallas - Not sure how the question is related, but 13.4V sounds fine to me (nominal lead-acid chemistry is 2.2V/cell so 13.2V overall). Others on the forum may know more.

paithre2 - The engine cranks fine, so I think that means the starter relay is OK.

TPS should be 12.9% at idle.

I wonder if the ECU is reading the 10.59 as out of range? This also leads me to ask whether the butterfly is fully closed, or whether it as the 0.002" clearance? You would need a feeler gauge to check this, but it is fairly straighforward and can be done without removing the throttle body from the engine.

If the ECU reads the TPS as out of range, it would stall out your car, or in this case, maybe prevent it from starting.

There is a set screw to adjust the butterfly, while I don’t recommend changing it, I think you might be able to test it, but I think you’ll need to modify a 3.5mm allen wrench. You’ll have to shorten it to fit. By extending the set screw you may be able to get the idle back to a more recognizable limit. You would probably open up the butterfly so your idle RPM will be high, but it should start.

Thanks again for all of the help. One note re: throttle is that I think maybe the 1995.25 MY on may have a different design, but certainly some things seem the same. I took the following measuremnts:

  • Butterfly is fully closed
  • Moved it to get a 0.002" feeler in place, TPS reads 11.37%
  • With 0.003" inserted, TPS reads 11.76%
  • With 0.004" inserted, TPS reads 12.55%

I don’t have a 3.5mm allen key, and I was unable to source one locally. So instead I added layers of tape to the tab that would contact the set screw. The results of that experiment were:

  • 5 layers of tape = TPS 14.9%, gives ~980 rpm
  • 4 layers of tape = TPS 14.12%, gives ~840 rpm
  • 3 layers of tape = TPS 12.94%, gives ~560 rpm, very rough

In all cases the RPM is hunting. I’m wondering whether something is wrong with the IACV, even though it is not throwing codes for that?

Other notes are that it still seems to be missing esp. at lower RPM (haven’t replaced coils yet), and that the MAF seems to always report 0.01 lb/min regardless of RPM. That seems wrong, but since I’ve never seen it read anything else it could be that my scan tool isn’t understanding that PID properly.

That last paragraph is your problem! Try replacing that MAF. Maybe get a can of MAF cleaner from the parts store first?

If it’s not moving with RPM, then it’s dead. You can test it by tapping into the wires and using a multimeter, but if the ECU isn’t seeing a change, that’s likely your issue.

More throttle = more RPM = higher MAF reading.

1 Like

Thanks for the info, and apologies for the slow reply (been diverted on other projects). I’ll measure the MAF voltages & clean if necessary, will report back on findings.

I’ve measured the MAF voltage output under a couple of conditions:

  • cold engine, about 65F ambient
    ** 500 RPM gives ~1.35V
    ** 600 RPM gives ~1.45V
    ** 800 RPM gives ~1.65V
  • hot engine, intake air likely 80F (running in garage)
    ** 800 RPM gives ~1.37V
    ** 1300 RPM gives ~1.62V
    ** 1600 RPM gives ~1.70V
    ** 2000 RPM gives ~1.96V

I don’t know if those are normal, but they do at least change in the right direction with airflow. I suspect either the OBD II system or my scan tool has a problem with the MAF reading output.

I am suspicious of the IACV, since it seems like it’s job is to handle the airflow when the butterfly is closed. I’d like to remove/clean it, but feels like I’ll break the tiny screws that hold it to the throttle body. Assuming IACV is a reasonable course of action, is there any trick to removing that, or is it best to removing the throttle body to have better access?

You’re probably in the right neighborhood. The electrical chart says that the MAF should report:
700rpm - 1.3V
1500rpm - 1.7V
3000rpm - 2.3V

I believe heating up the screws before you try to loosen them is the way to go. If they break, you may have to helicoil them….if you want to prepare for the worst, you may want to have them on hand before you start?

I have used cheap eBay IACV models without any problems! I’ll see if I can remember what sizes helicoils I used.


I just did something like that. i have not been doing much driving. Stuff happens,

I excercise my jaguar fom time to time, fire it up, back it out of the garage and let it odle tiol temp is up, i hear the Efans come on. put it back.

well, a time or so, no crank. low battery. charge it with the smart charger and all is well.

So, i mused. Alternator out?
it is probably 30 years young!!!

hooked up my VoM to the cigar utlet. engone off. 12+ volts. Fire it up. 13+ volts. Great. Alternator is alive.

But, in this perid of inactivity, it takes a few more cranks to fire>?
Fuel pressure has leaked down?

Tried a jag |trick". Sifter in D. Turn on key. This activates the fuel pump, but the engne does nt crankk. It works. Almost immediate fire up with shift back to P. A preprim measure.

gott bad connection to fix. One of thse days.

New electronics, oh smoe old to resolve.

New HP laptop, wow Windows 11 to learn.

Refurb Dell to register. issues there not resolved.

New land line phone for the hearing impaired. Me. Touch screen + key pad. i get caprions and more!!
first issue. where does it go? space fpor where it goes, it is big!

Smart [hoe nt yet mastered.

ugh. messed up access to Email on my ancient Dell Lap[ top.

ugh, messed up cnverter hook up for TV.

Ugh, way behond on yard work.



I found an old helicoil kit that I believe I used to replace the 5.5mm bolts holding down the IACV.

It was EZ LOK SK40420

Basically an M4-0.7 thread kit. 8mm length (or depth?).

There is a way to check the IACV:

Run the engine until it reaches normal operating temperature (more than 85C)

Switch ignition off

Switch ignition on, wait 5 seconds then disconnect the IACV connector.

Switch ignition off.

Wait 15 seconds then reconnect IACV connector.

Repeat the above twice, on the last occasion do not reconnect the IACV.

Start the engine. If the base idle speed it between 550-600rpm, the IACV is fine and move along.

For the AJ16 engine, the idle will only be resolved temporarily. Once you turn the car off, any idle problems you are having will be restored. It is only a test of the IACV. I do not know if the AJ6 behaves the same way or not, but the test, at the very least, should work? It might resolve idle issues for an AJ6 engine, who knows?