'86 XJ6 VDP extremely rough running and cutting out

Hi Frank,
There was no “voltage divider” in my '84 XJ6 Series III. It definitely had a conventional electronic potentiometer setup. I should know as decades ago I used to be an electronics engineer. Worked for Dept of Defence for 42 years. In my '84 AFM (could be different in your '85) there were two carbon or similar material tracks upon which two contact arms wiped as the vane rotated. Just like an old fashioned volume control in transistor radios, the tracks get dirty or just plain wear out and will give intermittent or variable outputs when the wiper is moved, resulting in loud crackles in the radio loudspeaker.
The solution as reported in my 1995 post was;
“The wiper now moves over a new unworn part of the
variable resistance.
I measured the resistance of pin 7 wrt pin 6 as the vane was moved
but found that even though it had less wild fluctuations it was
still not as smooth as I would have liked hence the next step. (#8)
Solder a 100uF 35Volt electrolytic capacitor with positive to pin 7
and negative to pin 6. This acts as a low pass filter and removes
noise from the signal fed to the ECM. It is sufficiently responsive
to not affect rapid acceleration.”
Hope that helps someone.
I did love my Jaguars as daily drivers until they got to the stage that you need a spare car for each one, as there was always something wrong. Now they are fabulous classic collector cars and I wish I had kept the convertible. I have a friend whom I help occasionally with his Series II. I advised bypassing all the electrical bullet connectors because they were usually the source of all my problems. The Lucas bullet connections seem to corrode over time and do not make good contact. Using a dielectric silicon grease helped enormously and I eventually greased every connector in my three Jags rather than wait until they played up and the grease them then after the problem.
Brian in South Australia
M-B '04 S500L, '08 C220 cdi
Once upon a time I owned a '84 XJ6 Series III, '84 XJS, and a '92 XJS Conv. (The '84 XJS was the nicest car out of that lot but doesn’t come close to my S-Class. The German engineering is first class with no connector issues ever. The sound insulation and the air suspension produces a ride as good as my friend’s Rolls.)

Indeed, Brian - this was a factory modification to counter fuelling errors during warm-up. If one was in place, the second was not needed…

xj6 85 Sov Europe (UK/NZ)

I will fix the cylinder before I do any other adjustments, but I had something interesting come up
I did unkink the AAV air hose and reinstalled my air filter, and confirmed that plug #1 itself was definitely getting spark, leaving the fuel. My father installed a fuel pressure gauge while I was away, and today we realised that fuel pressure would only stay at just over 20psi while running, then slowly die down to 0. The gauge would only measure 25psi when priming, much lower than the 45psi measured before the trip to the Jaguar specialists. We did some investigation and tested the vacuum hose connecting to the fuel pressure regulator to be satisfactory, before checking the fuel pump itself. It gets power and works when cranking, but doesn’t stay on while the motor runs, resulting in a new quick fuel starvation. When ~11 volts was applied to the fuel pump, the motor continued to run until the 11 volts was removed. The pump gets a familiar 10 volts from (I’m guessing) the negative side of the coil. But I have faith the pump itself is working, as it still pumps when primed, just not with the motor running. I’ll consult my wiring diagrams soon, just want to update on the new developments
I suspect a wiring fault, I’ll start chasing things down when my wiring pdf loads
Thank you all for the continued assistance

Welcome to the club!

1 Like

Two different problems, Graham; too low fuel pressure - and pump not running continuously.

First; connect the fuel pressure gauge to the hose at the fuel rail inlet - measuring ‘raw’ pump pressure. Run the pump; a good pump should read 100+ psi, some 70 psi is ‘fair’. Below that; the pump is either defective (replace pump), or there is inadequate fuel supply to the pump (investigate).

The pump should be tested using either tank in turn. Also; the pressure should be tested without the engine running - running only the pump. Correct ‘raw’ pressure is then is as stated above. ‘Regulated’ pressure, gauge connected to the CSI hose, is 36 psi - give or take a tad.

To run only the pump; remove fuel relay and, on the socket, jumpwire white to white/green wires - the pump should then run whenever the ign is ‘on’. You can also run only the pump by putting gear lever in ‘D’ - the pump should run in ‘crank’, without cranking. Whatever is more convenient…

The second problem, pump not running continuously; indicates that the pump is not getting power with the engine running. Either a fault in the ign key - which will show up, with fuel relay jumped as described above; pump will run in ‘crank’ but not with ign ‘on’. Address ign key…

Then, if OK, reinstall relay, remove air filter, set ign ‘on’ - and push in the AFM flap. The pump should start when the flap is pushed in some 1/4 to 1/2". If not; either the reed switch in the AFM has failed, or the diode pack has failed.
Remove the (red) diode pack and check (preferably with a test lamp) that there is power on the white/pink wire on the socket when AFM flap is pushed in. If ‘yes’ - the diode pack is at fault…

To wit; in ‘crank’ the fuel relay is activated by the white/yellow cranking circuit. With the engine running; the flap opens and the fuel relay is activated by the reed switch…

Incidentally; your ‘11V’ indicated that the battery is low/defective; the connections to the fuel pump etc reads battery voltage - which should be 12,8V for a fully charged battery. A half charged battery should be around 12,4V. However, the low voltage may deliver to little power for proper pump output! *Voltage needs to be checked/evaluated - but apart from pressures; it will not interfere with the proposed tests

xj6 85 Sov Europe (UK/NZ)

I charged the battery some more with a trickle charger, and moved the fuel pressure gauge back to the fuel pump itself. The battery reads 14.5 volts, but the fuel pump is only getting 12.4ish now. It pumped unregulated at about 38psi for both tanks, leading me to the conclusion that its failing. Still, i continued with more tests, working my way through the fuel relay with information you provided and this https://www.jag-lovers.org/xjlovers/xjfaq/fuelpumpcheck.htm other checklist I found.
I’ve tested the fuel relay to be faulty. It power comes from the purple/white wire, and goes through the white/green when jumped with a test wire. But with the relay, nothing happens, and after taking it off and testing more the fuel relay is definitely faulty.
I suspect the two separate issues are the faulty fuel pump (or inadequate voltage) and the broken fuel pump relay respectively.
I hope a functioning replacement relay proves me right

Indeed, Graham - sure sign of failure. It will likely start and run the engine, but is unlikely to maintain pressure under high consumption. A fully charged battery may hold above 14 volts briefly or with the alt running - but will quickly drop to ‘normal’ when left alone…

Within ‘reason’ the pump will perform OK at ‘any’ battery voltage/state…

To clarify; the relay, when activated, connects white (from ign key) to white/green (to pump). The white/purple wire controls the relay with power from the AFM reed switch (or the white/yellow cranking circuit in ‘crank’.

Ie, the white/purple does have power with the reed switch closed (AFM flap open - or in crank), but is not meant to run the pump, only controlling the relay.

Before discarding the relay; do the proper jumpwire test between test between white and white/green (as per socket colours).

The relay itself is tested by applying 12V and ground to white/purple and black) - there shoul be a click. Then measure resistance between white and white/green; ‘0’ ohm without and ‘1’ with power applied. Replacing a working relay will of course change nothing…

If failing this test the relay is indeed defective, but as the relay seems to operate in ‘crank’; I think something else is at play here.

In any case; jumpwiring between socket white and white/green will run the engine normally while you are musing. The reed switch addition is a safety devise - preventing the pump from running with ign ‘on’ unless the engine is running.

xj6 85 Sov Europe (UK/NZ)

You were correct, the fuel pump relay seems okay after further testing with your information. The white/purple wire got no power from the reed switch of the AFM flap, which explains the relays incomplete function.

I tested by supplying adequate ground to the proper pin on the relay, then providing voltage both to the prong corresponding to the white/purple wire to turn the relay on and to the prong corresponding to the ignition socket, thus imititating both the functioning white ignition and questionable white/purple reed switch wire. The fuel pump white/green wire prong got power as measured by my multimeter, meaning the fuel relay behaves as it should, and my fault is somewhere between the AFM flap and the purple/white wire socket.
I’ll look into the AFM when I next get time, thankfully the writing above with ricebubbles will be good reading and reference material

Thank you for the help, I’m impressed with the knowledge on this site every time I check my email, and its certainly a huge time-saver

Indeed, fix the fuel pump first :smiley:
My fuel pump was jumped to always be on with the ignition because the afm switch had failed, I presume. Did jumping it help your issues?

Test is that with ign ‘on’ pushing in the AFM flap the fuel pump should run, Graham…

The relay working as it should; in ‘crank’ the relay is activated from the ign key - in ‘run’ the relay is activated by the opened AFM flap through the reed switch. Fault in ‘run’ s either the reed switch itself or a failed diode in the (red) diode pack. Ie, the pump runs in ‘crank’ and engine starts - releasing the key to ‘run’, the pumps stops - and without fuel supplied the engine runs out of fuel and stops…

As David rightfully says; fix the fuel pump itself first. Then jumpwire the fuel relay white to white/green; the pump will then always run with ign ‘on’ (and in crank) likely solving ‘something’ and keep the engine running. Then you can pursue the failing cylinder problem…

In the meantime, you can address the possible reed switch problem by disconnect the (red) diode pack and measure power, on its base on the pink/blue wire. Opening the flap slightly, simulating a running engine drawing air; you should have 12V - indicating a functioning reed switch. If not; the switch has failed or needs adjustment, requiring accessing the switch inside the AFM. Otherwise, the diode pack is at fault - and can be repaired or renewed…

As a curio; the flap may deflect enough during cranking and activate fuel relay operation both by the cranking circuit and the operating reed switch - but with a defective reed swich feed the pump will stop running in ign ‘run’ position…

xj6 85 Sov Europe (UK/NZ)

Tested the diode pack, it got power at the blue/pink wire when the ignition was on, but not enough. When I moved the AFM flap no change was made to the ~5 volts I recorded. This leads me to the conclusion of a maladjusted reed switch within the AFM.
Also quickly confirmed the AAV heating coil was within the ohm spec

While I wait for a new fuel pump/filter to become economically viable, I have since jumped the ignition wire to the fuel pump wire indeed solving the fuel pump refusing to continue running with ignition on issue.

I suspect I have at least one stuck open injector. The moment the ignition/fuel pump turns off, the fuel instantly loses all pressure. I also hear a hissing noise from injector #6 (motor off), though I’ll try to use a stethoscope to verify it is that and not the nearby fuel pressure regulator before I pull and test tomorrow

Leave it that way for the time being, Graham - address the reed swich etc at leisure…

It does indeed mean fuel leaking out of the fuel rail too quickly. It could mean open injectors - in which case plug(s) may be wet, which may mean the plugs drown and won’t ignite. But also; it may be the non-return valve has failed - which is of little consequence for engine running…

xj6 85 Sov Europe (UK/NZ)

Not sure about that. But you will probably have to remove injectors. I thought our suspect was around cylinder 1, not 6?

The regulator hisses while bleeding (excess) pressure, that’s how I remember it.

I hope everyone reading along understands that the AAV and especially the heating element absolutely can’t be an issue here since the engine starts, and runs, the problem is somewhere else.

I did remove Fuel injector 1, it passed the test. The suspect is around cylinder 1, my brain simply associated the previously unknown hissing sound with the location of Fuel Injector 6.
Fuel Injector 1 fired appropriately when testing, leading me to some initial confusion. However, when partially blocking off the fuel flow at the end of the fuel rail via crushing the hose (and thus artificially building up proper fuel pressure the failing fuel pump couldn’t), the engine ran almost completely smooth. None of the intense shakes characterising previous runnings, only tiny trembles I consider a fault of some less-than-quality condition motor mounts.
When the hose was unrestricted and the “normal” fuel pump pressure of ~30psi was sent out, the engine started to run more rough and eventually stall. I suspect what had been happening was the low fuel pressure allowed the fuel injectors closer to the “in” side of the fuel rail to work as they should with the injector(s) towards the “out” side suffering the brunt of the low fuel pressure. I have purchased a new Fuel Pump and Filter to be installed when I find the time (hopefully this upcoming weekend).

Additionally I discovered a vacuum leak between the brake booster and the intake manifold. With the engine running, I could hear a noticeable difference in engine speed whether or not I was pressing on the brakes. I don’t believe this to be normal. I’ve theorised it could be either the plastic valve in the line, or where the hose connects to the intake manifold underneath the throttle body, as it looked pretty rough at a glance.

1 Like

When you push the brakes on any petrol car with vacuum brakes, the engine will speed up momentarily because the mixture gets leaner (you add unmetered air from the booster). If it stays fast it might be a booster issue. Plug the line before and after the valve etc.

Did you actually measure the rail pressure (at the CSI injector with the hose strangled, Graham?

There is something odd about the outcome of the experiment. Normally, the pressure regulator regulates the pump pressure by bleeding off fuel into the return lines - it sort of baffling that strangling the rail inlet hose can increase fuel rail pressure. And pressure can only be verified by measuring it…

In principle; as long as the ‘raw’ fuel pressure i higher than 36 psi, regulator working correctly. rail pressure should be to spec. Unless engine uses more fuel, or rail leaks, demanding more fuel than the pump can deliver. Rail pressure will then fall - and strangling the hose should not alter this…

Anyway; the ‘raw’ fuel pressure test indicates a faulty pump, which means replacing it - as planned. Then we’ll see…

With pedal released there should be no hissing - the system should be sealed. With a constant hiss, pedal released, there is a leak - either external or in the booster.

As pedal is pressed, air is let into the booster via a passage coaxial with the pedal rod. A brief hiss ensues, easily heard while listening at the pedal. It should stop instantly as the booster’s insides repositions and close internal valves.

If the hiss continues with the pedal depressed; the rpms will increase as engine gets more air - the engine is usually set up a bit fat, so the mixture is fat enough to compensate for the extra air…

Whatever, there should be no leaks - so try and locate the leak point(s)…

xj6 85 Sov Europe (UK/NZ)

I did not actually measure the pressure at the CSI hose, but the “raw” fuel pressure was certainly below the required minimum of 36 for the rail.
I replaced the Fuel Filter/Pump today, but I decided to let the gasoline I spilled and rinsed out dry out before I started the motor.
The Fuel filter was in pretty bad condition, this is the color of what I shook out of it.

I also shook out this debris from the intake of the old fuel pump

I know the previous owner replaced one of the rusty tanks with a shiny new one, but from what it looks like I don’t think they bothered changing the fuel filter/pump as well. Seems like the aftermarket chinese fuel filter gave what little life it had. I haven’t been able to test how the motor runs with the new pump/filter yet, but I’m hoping with some more fresh fuel, the new pump and a quality bosch filter now it’ll be adequate.

If you haven’t, good idea to drain the not shiny tank to get water and crud out and check if the filter sock is still in place. It’s messy so I understand if you don’t feel like it. Some debris is normal, it can however block the fuel pump on a rainy day, so many people install filters before the pump now.

1 Like

'86 XJ6 III…As soon as I finished power antenna installation, the engine would start(cold) but then after 20 -30 seconds RPM drop steadily and chug to stop. Sounds much like Graham’s description. Thought I might see if I can visualize the AAV that has been described. I’m not entirely sure I’ve IDed the right part. The air filter will probable have to be removed to see anything.

My plan is to:

  1. Check AAV per your previous descriptions.
  2. ?evaluate/replace CTS.
  3. Listen/look for fuel return.( I installed new fuel pump and filter 4 months ago)
  4. Maybe install new fuel filter per Paul’s suggestion

Remember, I am compromised by age (83), have a limited knowledge base, and I’m not much of a mechanic…but I am teachable.
I’m all ears…

I’m ashamed of dirty engine but somewhere I read that it shouldn’t be washed…only hand wiped.