Annoying mis-fire when cold

Evenin’ all,

Technical question. Just wondered if any obvious tips or sage advice before I tear the thing apart.

In the last few weeks, (UK, winter) t’Jag has developed a bit of a misfire – only when cold AND under load from low revs. Once half warm runs like a dream. I hope to get an hour or so to fettle the usual – all wiring is good so far as I can see, fuel filters are clean (but I will check again) and I suspect either air leak at inlet manifold (which clears /closes up when warm) or a duff spark plug (which again clears into life when warm). Truth be told car has only run once or twice a week recently, and it might be a bit of damp that needs to burn off somewhere. Twin SU’s, electronic ignition, Shell expensive fuel, recent plugs, good leads etc. engine rebuild 6000 miles ago, all good, everything else tickety boo.

Comments on the back of an internet please.

JCC

Have you got proper oil and level in the SU dashpots?

Yup – remaining entries to satisfy the 30 character minimum entry for this forum.

If it’s ok once warm I would say it points to a carb issue , don’t think it would be damp if it’s been run twice a week , my MK2 stands for weeks in the garage , and will run with out missing , once started I do let it stand for a minute or two .
Have you got a colour tune ?
Its a great bit of kit , to get your mixture right , rather then just get , I know it’s not as good as having the car on a rolling road , but for around £20 it’s well worth the cash !
Can’t be much wrong if it run’s ok from warm !

What cold start system do you have? If it’s the ASC, might be worth checking its operation. Paul

My car does something similar, it runs roughly and won’t idle at all until it’s almost fully warm. I have to fast idle for 10+ minutes before it’ll run well enough to start driving, but once it’s warm and on the road it runs wonderfully. At this point I just think it’s a quirk of the motor. My starting carb doesn’t work tho, that might solve this, but I can’t get mine to work quite right.

My starting carb was converted to manual by my PO. He just overrode the thermo feature with an under dash switch - and Bob’s your uncle. I run the starting carb for about three minutes then switch it off.

Mine has this too. There’s either some crud in there or it’s misadjusted, as it doesn’t always turn on with the switch despite correct wiring, and the car won’t run with it when it is on.

What is a starter carb :rofl:

I have the same issue with my 3.4 MK2. I have the starting carburettor wired to the otter switch and it works perfectly. I know that my car is running ‘rich’ when cold and fouls the spark plugs until the engine is quite warm. This is normal as the fuel vaporises properly when the manifold is hotter so can deal with a ‘richer’ mixture. I know that I need to pull my carburettors off and overhaul them. I’m guessing that the float levels are incorrectly set, though this is easily set by simply taking the top off the float bowls and setting the level as per the Service Manual - I think it’s a 3/8" bar from memory? Check the brass floats as they sometimes develop a leak and can slowly fill with fuel causing richness. Worn needles and seats can cause the same issue if they don’t cut off properly. Setting the mixtures is pretty simple, again following the Service Manual. I find that with the air intake removed exposing the piston you just lift it with a fine long screwdriver 1/8" to test the mixture. Balancing the carburettors is easy too, just use a piece of plastic tubing and put it to your ear with the other end to the intake of the carburettor. You will soon hear when the intake ‘hiss’ is the same on both - you just need to slacken the joining piece between the carburettors so that they can be adjusted independently, of course.
Cheers,
Tim

My MK2 does this but my E Type doesn’t.

I’ve noticed it’s worse if the previous time i have driven it was only a short trip and not properly warmed up - so suspect fouled plugs affecting the next trip…

that doesnt sound like much fun.

I would remove my carbs, dismantle them and get that issue sorted, their isnt a lot in them

rich tuning/running of the main carbs will foul the plugs, they shouldnt be black

Then the MK2 is too rich during the warm up phase, fouling the plugs. Having three 2" SU’s on the E-Type means that you can set the carburettors to be lean unlike the two 1 3/4" SU’s on the MK2. Just lean them off 1/2 a turn on the mixture screw and see what happens.

Tim

The misfire…

Limited time to get at the car since posting, and had decided when time permits to a round of WD’ing, drying, checking leads plugs etc – but even this time eluded me. Bonus however is I had time to mull it over and was reminded of a day, probably in the 1970’s when I was but knee high to a wheel spinner that my grandfather’s car (with a single SU carb or similar) had a not dissimilar problem – would start fine, idle perfectly but would only rev lumpily with no power. A friendly neighbour appeared and enquired as to the problem – was told – he then removed the carb damper, took a screwdriver and got a ‘grip’ of the carb piston by gently jamming the screwdriver in the damper tube – lifted the piston to maximum lift a few times, and sorted – sticky carb piston – bit of dirt or whatever.

In the few mins I had this morning before setting off I did the with both carbs and by jove it appears to heave been resolved. I’ll know for sure in a day or three and if the case, I will find time to remove plenum, carb bells and pistons for a jolly good clean.

JCC

If you are going to rebuild or just want to eliminate a potential variable, buy these:

No affiliation, just a satisfied customer.

Gerard

Thanks Gerard,
Just a sticky piston after all that - all is now tickety boo!

Do you guys have BG44K on that side of the pond? I use this every year in my scooters, mowers and cars that have sat to remove varnish and carb clogging deposits. I buy it buy the case for the best price of about $15 a pint.

Gerard

We have most things , I am using this at the moment , I was told a bit of oil in the fuel does the same thing , that Ethanal just dry’s things out , guess the oil stops it , never tried it myself !

Have seen this in an 80s Rover SD1 with magnetic triggered sparks. Managed to isolate the problem to a specific cylinder. The rotor (with magnets vertical in its outer edge) clearance to the pickup was at the max (.016"), so I closed it to the minimum of .014", problem fixed. One magnet weaker than the others.
jp

Had a look at my floats. Front one is barely off the floor of the chamber. 2mm? And corresponding low level of fuel. Rear one much higher with more fuel. Time to replace front float?