Delanair II Servo motor and main temperature pot

Hello everyone,
I have a 1985 XJ with climate control issues.
The PO had replaced the amp. When I checked for an ohm between the red and purple wires, I got 0 ohms. I tried to power it up with a 9 volt battery. No luck.
I pulled the whole servo unit out of the car and tried to power it up. Nothing.
Doesn’t seem easy to remove the servo motor.
I am also trying to check to feedback pot but I don’t think I can if servo motor doesn’t want to move.
Should I just try to get a used servo control unit on ebay?

Also, I checked the main temperature pot by disconnecting the blue and white wires and read 0 ohms no matter what position I turned temp knob.
Can I replace it with any 10k pot or should it be a certain type of potentiometer.?
Thanks!
P.S, I was able to get the servo motor to work using a car battery power.
Looks the issue is the feedback pot. I have to find a replacement. What is the latest on feedback pot replacement? I noticed many 2k pots on ebay but does anyone know which one would be a direct replacement?

**
The temp control has very specific values - which escapes me. It cannot be replaced with a 10 ohm one…

Frank
xj6 85 Sov Europe (UK/NZ)

What does it look lije? My Rovers with Delanair might ork.

Paul, not sure since i didn’t take it apart yet.

**
Make sure of the diagnoses before acting, jdere - the AC system is rather involved…:slight_smile:

Are you now sure that the servo motor is operating - turning both ways when power is suitably applied? A failure of the temp control, ‘0’ ohm reading whatever the setting, will affect servo operation.

The ‘usual’ test of amp/servo operation is to alter temp settings - which would make the servo reset. Crudely, the AC amp reads the resistance in the in-car sensor and the resistance in the temp control - then powers the motor to change in-car temps. The AC amp aims to equalize the two resistances…

With the temp control reading ‘0’ ohm; the amp turns the servo to max heat(?) - and it stays there, whatever you do with the temp control. So a non-moving servo may have various causes - but the first step is to replace the temp control resistor…?

As an aside; if cabin temp is outside the temp control range - the servo is set to full cold/heat, and will not respond to temp control changes…

Frank
xj6 85 Sov Europe (UK/NZ)
**

You should be able to move work the servo with 9v.
There are two diodes in there, check if the are ok.

Take it apart and measure the total resistance of the carbon tracks inside.
Same with the main knob pot.
Once you know their values it would be easy to find replacements.
tme.eu is a very good source.

Frank,
I definitely was able to move the servo motor all the way in both direction with a 12 volt car battery. I could not move it with a 9 volt battery.
I connected and checked for ohms on the feedback pot while moving the servo motor back and forth, I read 2.1k ohms throughout the whole time connected to yellow and orange wires. Orange and green wires, ohm read a high of 350 ohms and would go down to zero but not steady (reading would jump around a bit).

Aristides,
9 volt battery won’t move servo motor at all. I checked with voltmeter, It’s definitely charged at 9 volts.
I have a spare car battery that is charged to 10.5 volts and it moves servo back and forth.

**
Yellow and orange are to the ‘end’ point of the pot, jdere - constant is correct. Orange is the center pick-up, so orange/ green and yellow/green should be reciprocal - when one increases the other decreases. Ie, the two readings should be symmetrical - and if they are; the pot likely works. ‘Jumping around a bit’ goes to the precision of the servo setting, maybe dirty tracks, but should not prohibit the AC amp from moving the servo.

Your test of the temp control pot indicates that it is faulty, and a much better suspect - and it must work, or the system will not function.

That the servo won’t turn with 9V may relate to the capacity of that source - not being able to deliver necessary amperes to the motor…?

A word of warning; it is important that current to motor is cut at endstop - or the motor will burn out or strip the gears. Nominally, this is done by the amplifier, but as this is bypassed during your testing; I don’t know if there is a back-up endstop…?

Frank
xj6 85 Sov Europe (UK/NZ)

I think you meant that green was the center pick-up?

**
I sure did, Kirbert - you are absolutely right…

Incidentally, there are indeed two motor power cut-off microswitches - cutting power at full travels, preventing servo/motor overrun. The motor power and the feedback circuits are entirely separate, of course.

What puzzled me most was his reading of ‘0’ ohms over the motor circuit - this means a dead short, and power applied would certainly burn something. I can understand ‘break’, ‘1’ on a digital multimeter - caused by a motor circuit break; it would be the case with the servo at extreme travel. And turning the camshaft a bit should then measure proper motor resistance - giving some indication of current required…

Frank
xj6 85 Sov Europe (UK/NZ)

I should replace the feedback pot and main temperature pot. I did not take anything apart yet. I have an article “Delanaire II Troubleshooting”, written by Karl Nelson that describes new pot replacements but that was in 2006. Anyone find any new resources for both pots?
I noticed a few utube videos on how to clean a typical pot. Does anyone have any experience with cleaning pots?

Again, jdere - there is no indication that the feedback pot is a source of trouble…?

If your measuring of the temp control is correct; that item sure is - change it…:slight_smile:

Frank
xj6 85 Sov Europe (UK/NZ)

Hi Frank,
I updated my last post looking for info on replacement of the temp control pot.
You stated that it has a very specific value.

Somebody on the list must surely know, jdere…?)

The manuals are silent on specs and testing, but AC sensors are low current devises…

Frank
xj6 85 Sov Europe (UK/NZ)

The servo should operate just fine on 9 volts. The gear set in the servo is covered in grease. When this grease gets old…it becomes very thick and tar like. If a 9 volt battery will not move the servo…you should remove it and perform a degreasing and relubrication of the gear set and bearings.

The feedback pot Yellow to Orange should read ~2.1k and Orange to Green should read a steady rise from ~100ohms to 2.1k ohms while the servo is rotating. If it drops signal…it can cause the climate control system to “hunt”.

The temperature select pot has a max value…but is limited in travel for the necessary range…I will have to look up that information. If you are reading 0 ohms…the system will not work as there will be no target value for the amplifier to balance the circuit.

Reading 0 ohms on the servo motor leads is not completely unexpected…if the servo is at a limit switch. That leg of the circuit will be broken. While manuals include this value…I think the number listed is wrong…and generally is of little value…its more valid if the motor runs or not.

In car and ambient temp sensors generally do not fail out right…but tend to have a value shift with age…so a recalibration of the amplifier would be called for.

Sounds like you have an outright failure of the temp select and need a service of the servo.

Start there and work thru the system.

Cheers

Gary

3 Likes

Thanks for the reply and info. Do you know of any replacement for the temperature select pot?
I have been trying to get a used replacement on ebay for now,

I have not searched for a direct replacement…but I will look up the values and range of motion and see what I can find.

Cheers

Gary