Does the computer in the boot control the door locks?


(Phil_W) #1

My 1986 Daimler Double Six would start but ran badly and died on new years day. I’ve tried starting it a couple of times since that morning with the same results; starts but runs poorly, emits white smoke at first, and eventually dies and won’t re-start. The last time I had that problem and went through all the usual suspected components, it turned out to be the computer and I had to buy one from a breaker yard in England. I later saw one for a similar year XJ12 on ebay and bought it for much less, so I do have a spare to try. I hope swapping the computer gets it back to normal since it was doing so well before this. An odd thing is that the Code Alarm remote fobs were no longer locking and unlocking the door locks even with new batteries in them, but the driver door lock switch did, and now the driver door lock switch is not locking and unlocking the other doors. Can anyone tell me if the door lock function is controlled by the main computer? (Open the pod bay doors, Hal. I’m sorry, Dave, I’m afraid I can’t do that).

I may have to take the back seat out to see if the aftermarket Code Alarm control’s brain is hidden there and try to figure out how to disable it. The alarm was originally installed by the first owner in Belgium and I’ve never had an owner’s manual for it to know for sure what the two micro-switches behind the left side of the dash are supposed to do, but the remote fobs have previously worked to silence the alarm’s beeping when the battery is re-connected by locking and unlocking the doors. I removed the alarm siren years ago but left the beeper, and there are also two LED lights on the steering trim with a red one that blinks when the alarm beeper beeps.


(David Jauch) #2

White smoke means water, Phil, but I bet it is also cold where you live. Maybe it is misfueling.
If not it is probably the head gasket. If it is the same as back then there can of course be an underlying issue.
Aftermarket alarm systems are often an issue, I’d rip it out or at least disconnect it - but - the ECU in the trunk does not control the door locks to my knowledge.
Does the battery voltage check out? Is the alarm connected to the ECU?

David


(Phil_W) #3

Thanks for the reply, David,
It was 30 degrees F when I had the no restart on New Years day, but it has been in the 60s other times I’ve tried since then. I don’t know if the alarm is connected to the ECU but if so it has to be through other wiring and not at the ECU itself. the 2nd owner said there was an alarm disable switch under the ash tray and maybe another switch there also and the 3rd owner said he found a broken switch there and taped up the wires. I (4th owner) did find two small black taped up wires under the ash tray and made sure they were well insulated from each other and from any ground. I have also found some kind of car jack (LO Jack?) device under the driver dash along with a smaller device related to the Codealarm but neither is the alarm control according to info from the maker.

I did change out the 16CU ECU today for my 6CU spare that I’ve used successfully in the past, but it made no difference in the current failure to start. The battery is not new but OK and I’ve been fully charging it between tries to start. The driver door lock switch did activate the other door locks today so I might not have had the driver door fully closed before.

When I had a similar failure to start back in 06 I replaced the coils, the GM Module, rebuilt the AAV, replaced Vacuum lines, and tested various sensors, and nothing helped until I replaced the ECU with a Lucas 16 CU CONTROL UNIT, DAC6636, I bought from an English breaker. That ECU (which I removed briefly to test the XJ12 6CU fuel control unit I bought on eBay to keep as a spare) had been working well until recently and may still be working well if there is another problem causing the poor run and right now no run condition.

I did check the coolant today and added maybe a cup at the block filler to bring the left side expansion tank level up to the neck.


(Doug Dwyer) #4

As installed by Jaguar the electric locks are not connected to the fuel injection ECU in any way.

There’s no reason for an aftermarket alarm system to be connected to the ECU…at least not the typical alarms I’ve seen over the years. But, some installers do strange things. I agree with advice to remove all of it. This can be a bit involved as some systems have wiring branches spreading far and wide. But, IMO, worth the effort. With age they often create problems.

The white smoke is probably water vapor. In and of itself nothing to worry about if it disappears when the engine (and exhaust system) is fully warmed up. If it persists…well, let’s not go there right now.

The starting/running problem could be many things. I’d begin with jumping the terminals in the connector for the coolant temp sensor and see if anything changes. If on the blink the sensor can massively over-fuel the engine. Jumping the terminals bypasses the sensor. Carefully inspect the sensor wiring as well.

Cheers
DD


(Frank Andersen) #5

**
You mention two separate faults, Phil - the non-start and the door locking/remote/alarm…

While door locking in itself is an entirely separate problem, unrelated to engine running; alarm systems are tricky - and may include engine disabling features. But dismantling an alarm system with unknown features is not straight forward…

However, disabling features should be detectable by the usual tests - and you have not mentioned if any has been carried out? Changing parts without checking for symptoms is not advisable. Did you switch tanks and try starting?

Do you have spark when cranking; connect a triple gapped plug to any lead and crank - spark quality should be blue. Have you verified that the injectors click regularly while cranking? Do you have an injector test lamp (NOID) to check injector signal - and various other things? Have you verified that the fuel pump is/was running after engine start?

The next thing to check if ign and injectors are working; check fuel pressure. Connect pressure gauge (150 psi rating) to fuel rail inlet hose and run pump - you should read minimum 60/70 psi. An as new pump should read 100+ psi…

Connect the pressure gauge to a CSI hose and run pump - you should read some 30 psi. (Later versions of the V12 omitted the CSIs, and you then have to use one of the injector hoses). Incidentally, while performing pressure tests; stop pump and watch for a couple of minutes to check leak-down. Ideally; none…

Incidentally; topping up the coolant beyond normal cold level is wasted - the excess will be ejected as the engine warms up. Coolant level should be checked regularly with the engine cold - to establish a level benchmark…

Frank
xj6 85 Sov Euope (UK/NZ)
**


(Phil_W) #6

Thanks, Frank,

I did try both tanks with no apparent difference. The driver door lock switch is working now but makes no difference in the alarm beeper which is set every time the battery is re-connected. Perhaps I did not have the driver door fully closed when it did not work before or the door closed switch did not make good contact. In any case the replies are correct that the door switch is not controlled by the alarm, although the remote fobs did formerly lock and unlock all doors similar to the switch action.
.
I did notice today that upon initial re-connection of the battery with the alarm beeping and a red LED in the steering wheel trim flashing, that sometimes turning the ignition to run position does not turn on the dash check lights nor run the fuel pump (but does turn on a Green LED opposite the red one) until I push the top one of the two micro-switches hidden behind the driver dash at which time the beeper stops, the red LED goes out, the dash check lights come on, the fuel pump runs for 2 seconds, and the green LED flashes twice and goes out. At other times the fuel pump and check lights do come on when the ignition is turned to run but the flashing red LED and beeper continue until I push the micro-switch. It may be a timer function dependent on how long the battery is disconnected.

So far I have checked the voltage at the coil with the ignition on, and with a battery voltage of 12.69 the voltage at both coil terminals was 11.96. Next will be a spark test and then a check of the temp sensor as Doug suggested, but the bitter half has me moving furniture today so I’ll report back later.

Oh yes, I believe the coolant level spec is 3 inches below the sealing surface of the block filler neck which also fills the expansion tank to just below its sealing surface. My engine has a slight leak when it sits so in topping up I usually watch the expansion tank neck as I slowly add a cup or two and stop when it reaches the sealing surface.


(Frank Andersen) #7

**
If the leak is internal, Phil - it will explain the initial white steam at start-up…

This has no bearing on the non-start, but may imply that the head gasket on one of the banks is leaking. A compression test will be necessary to confirm…

An important clue is that the fuel pump does not start when ign is turned ‘on’ - and that the alarm system’s microswitches must be manipulated to activate the pump. This implies that the alarm system has an ‘engine disabling’ function. Adding that the flashing LED and beeper is a general indication that the system is active - but without specifying which functions are disabled…

I think you should consider doing ‘something’ with those microswitches - to see wheter the engine will actually start after/with microswitch manipulation…

Though dismantling the whole system should be the aim; without the diagrams of the system; dismantling is difficult without possibly doing more harm than good. And there is no telling whether your present problems relates to a malfunctioning alarm system or something else…

As an aside; the start and ‘3 second’ run may be explained by the thermotime action. While cranking the cold start injectors open for a predetermined time - depending on engine temp. Typically at temps mentioned somewhere between 2 and 5 sec - depending also on delay system fitted.

Fuel injected will then start the engine, but it will run only briefly without further injection from the injectors. However; once activated, the thermotime switch requires several minutes to reset. Repeated cranking within the TT ‘downtime’ will not open the CSIs - and the TT will again require minutes to reset after each cranking…:slight_smile:

The ignition key powers some systems in ‘on’ - and while these systems will also be powered in ‘crank’; additional systems is then also activated. This requires perfect ign key performance in both situations - but the alarm system may disable one or more functions in either situation. Either deliberately or due to a malfunction…

Function checks; the fuel pump must run for 2 seconds as ign key is turned ‘on’. If not; the cause may also cause a non-start. The pump must run in ‘crank’. To test; place gear lever in ‘D’ and turn to ‘crank’ - the engine will not crank, but you should hear the fuel pump. If not; the engine will not run. The fuel pump should run while the engine is running - obviously only testable with the engine running. If pump ain’t running - neither will the engine…:slight_smile:

There must be plug sparking with the engine cranking - no spark, no run. The injectors must be clicking while cranking. No injector action - no running engine…

The tests are simple and fairly conclusive - a ‘failed’ test may/will cause a non-start. The cause of the ‘fail’ may relate to the alarm system, or something else - but some judicious jumpwiring may bypass the problem for testing…

Frank
xj6 85 Sov Europe (UK/NZ)
**


(Phil_W) #8

I hear the fuel pump run for 2-3 seconds each time the ignition is turned to “on/run”, but I do not hear the pump run when I turn it to “start/crank” with the shift lever in reverse (engine not cranking of course). Are you certain the fuel pump should run when holding the key to start with the engine not cranking? On my XJ6 the engine must be sucking enough air to open the flap in the intake and close a switch for the fuel pump to run, but I don’t remember if the V12 has a similar intake device or if the ECU detects the engine turning to activate the fuel pump during cranking.

Is the same relay used for the fuel pump short prime run and for continuous run? Since I tried my spare 6CU ECU and had the same symptoms, I assume it is something other than the 16CU ECU causing my starting/running problem.


(Doug Dwyer) #9

Just to prevent a needless search, the car in question won’t have cold start injectors or a thermotime switch. Jaguar stopped using them circa 1983-84 on the V12s !

Cheers
DD


(Doug Dwyer) #10

On the V12s the fuel pump circuit is ECU-triggered. When the ECU sees a ‘cranking signal’ (from the starter relay) it will trigger the fuel pump. The signal comes from the white/red wire of the starter relay…the output side of the relay. Thus, the turn-key-to-start-while-in-D trick won’t work !

Assuming a Series III XJ6 4.2, your fuel pump should run while simply cranking …but the V12s are wired differently so don’t compare the two

Same relay, yes.

Cheers
DD


(Phil_W) #11

OK, thanks, Doug,

So if the fuel pump runs for the priming period, the relay for the cranking and continuous run should be OK. I couldn’t hear if the pump was running while cranking because of the engine sounds.

Yes, it does have the “square” fuel rails which I understood meant no cold start injectors. It does have a timer (15 minute?) that I think changes several vacuum circuits affecting timing at idle. Years ago I added an LED in the engine bay to indicate whether it was on or off. Much time and dealing with different car’s problems have dimmed my memory of all the things I checked or changed before replacing the rebuilt ECU that was installed when it was imported to the US from Belgium with the 16CU, DAC6636, from the UK breaker that seemed to fix all its start/run problems. Now the symptoms are again similar to the “before” situation so time to re-read my notes and Kirby Palm’s “experience In a Book” to decide what comes if the CTS and spark check out. It’s a rainy day today so a good day to read by the fire.


(Frank Andersen) #12

**
I keep forgetting this is a V12, Phil - and Doug rightfully keep reminding me…:slight_smile:

Doug is right, of course - one way of checking is then to have someone listening, in ‘crank’, that the fuel pump is then running.

You may also locate the fuel relay, and jumpwire relay orange to ground - which what the ECU does in ‘crank’. The pump will run as long as the ign is ‘on’.

However, the sole purpose of the fuel pump is to pressurize the fuel rail. One problem here is that if the non-return valve has failed, the rail pressure will zero as the pump stops. Which may be countered by turning to 'crank before the pump stops…

In principle this should start the engine, or at least catch briefly. But the the two other tests, sparking and injector action in ‘crank’ should be verified…

With ignition and injector action, and correct fuel pressure there is little that will prevent a V12 from starting - but that the fuel pump runs doesn’t prove it is delivering. For which a fuel pressure test is required…

Frank
xj6 85 Sov Europe (UK/NZ)
**


(Phil_W) #13

Cold weather has limited my progress on the DD6 no start problem, but I did check the spark by removing the distributor lead from the coil on top of the engine and connecting a spare spark plug lead to the coil with a bolt in the spark plug end and clamping the end of the wire to the engine bay braces so there was a 3/8” gap from the bolt in the wire to the bolt on the braces. I briefly cranked the engine and there was a fat orange/yellow spark repeatedly jumping the 3/8” gap with a snapping sound as it jumped so I assume I have spark.

I also checked the CTS resistance in 40 degrees F temperature at 4.58 K ohms and again today in 50 degrees F at 3.57 K ohms which are close to the specified values for those temperatures. I had also tried starting the engine with the CTS connector shorted as Doug suggested with no change in failure to start.

I found a you tube video that said the CTS input to the ECU is between pin 5 (5th from right on the bottom row) and pin 19 (1st on the right in the top row) looking at the ECU connector with the wiring harness to the right, so after checking the CTS resistance today at 50 degrees F I reconnected the CTS and measured 3.55 K ohms between 5 and 19 in the ECU connector. Then I disconnected the CTS again and expected to have infinite resistance between 5 and 19, but measured 3.72 Meg ohms. I shorted the CTS connector with a paper clip and measured 8.4 ohms between 5 and 19. Then I tried measuring again with the jumper removed and got infinite resistance and put the jumper back in and got 0.6 ohms. I reconnected the connector to the CTS and got 3.44 K ohms. I was beginning to suspect the wiring in the CTS connector so I had my wife squeeze and wiggle the connector on the CTS while I measured the resistance between ECU pins 5 and 19 and it remained a steady 3.43 K ohms and the CTS was at 53 degrees F now.

So… was I measuring at the correct ECU pins?

I am going to reinstall the 16CU ECU and then re-check the fuel pressure in the boot at the fuel filter (the easiest place to put a T for the gauge). It was 40 PSI last time I checked it and if it is still 40 PSI, I will be stumped again. CTS seems OK, Spark seems OK, if fuel pressure is OK I’ll have to find something else.


(David Jauch) #14

Yes! As it changed when you did things at the other end.

Megaohms instead of kiloohms would be infinite enough to me. But 8.4/0.6 is a larger difference - that is how good your contacts are, I bet. That paper clip doesn’t have a perfect surface.
So I would conclude that the CTS and systems check out fine.

Spark is there, and if it doesn’t die when the engine dies it is not at fault.

Fuel pressure and spark should probably be observed in the situation in which the engine passes out. Maybe you lose fuel pr spark in that instant.


(Frank Andersen) #15

**
The CTS is a resistor, varying resistance with coolant temp, Phil…

‘19’ is delivering 12V to the CTS (and the Thermo Time if CSIs are fitted). The ECU then ‘reads’ the variations at ‘5’ as CTS resistance varies. The internal connections between ‘19’ and ‘5’ are electronic and ohming is inconclusive between them…

Ohming must be done with wires disconnected - ie, the ECU connector must be disconnected from the ECU.

However, the standard tests of the CTS function are indeed to check temp/resistance - which in your case is indeed correct. Then, with ECU connected; disconnect CTS and measure resistance between the two wires. This measures the internal ‘resistance’ between ‘5’ and ‘19’ - which depends on electronics within the ECU, usually giving somewhere between 2 - 4 Kohm. The readings basically verifies that the wiring to the ECU is intact.

The third test is to ‘squeeze and wriggle’ the wires and connector while watching the resistance readings. As in your case, no variations means good connections.

Basically; you did all this, though from the ECU end, and should indeed show ‘0’ ohms with the CTS plug shorted - the ECU multiplug disconnected. That resistance varied during testing may be due do bad jump connection…?

The very high, but not ‘1’, resistance reading between ‘5’ and ‘19’ on the ECU connector with the CTS plug disconnected is likely just ‘creep’ in the connector - and immaterial. As David says ‘Mohm’ is as near to ‘infinite’ as makes no difference in this case…

I think your CTS circuit is working as it should - and at temp the V12 should start, or at least catch, anyway, so the problem is elsewhere…

As an aside; the easiest place to measure fuel pressure is at the fuel rail connection - a ‘T’ there will work equally well…

Frank
xj6 85 Sov Europe (UK/NZ)
**


(David Jauch) #16

But 8.4/0.6 is a larger difference - that is how good your contacts are, I bet. That paper clip doesn’t have a perfect surface.

Actually, it is ohms on a scale of thousands of ohms - doesn’t matter at all. All your CTS readings are very good.

On a V12 what is the best place for a pressure reading - can a hose from one of the frontmost injectors be pulled off? Obviously, before disconnecting, depressurize the system first by cranking without the fuel pump.
But if it is not too lean due to an obstruction, teeing off in the trunk should be just as good - ?

Did you do something about the alarm thing? I‘d yank it out by now. Not only do I hate alarm systems in general but we all know how bad the late 80s-90s contraptions can be. Especially if they include broken microswitches and taped wires.
You might want to wire in a test lamp with the fuel pump, with the ignition power feed,… so you can watch these while starting, in real time, while you crank. Strange after all that it would catch and die. That sounds like a failure to acknowledge the ,run‘ position (can it be the ignition switch that doesn’t allow fuel or something else to be powered after the key is released from crank?)


(Doug Dwyer) #17

On the V12 there is no particularly easy place to take the fuel pressure reading. The matter is complicated by having an inlet regulator and an outlet regulator. The outlet (LH) regulator is what actually regulates rail pressure.

To measure what pressure the fuel rail is actually operating at the reading must be taken after the inlet regulator. Most commonly a tee is inserted into the feed line seen as item #11 in this illustration:

https://www.jaguarclassicparts.com/uk/series-iii-xj12-parts/air-and-fuel-delivery-systems/electronic-fuel-distribution-equipment/fuel-pipes-and-pressure-regulator-5-3-litre

The fuel hoses at this pipe (and others, and the injectors themselves) are press-fit onto barbed nipples. This means A) the hose can’t simply be removed from the nipple, B) the hose must be cut away from the nipple and C) cutting into the hose to insert a tee means replacing the hose or leaving the tee in place.

Jaguar dealers were supplied a pressure testing kit which has pre-made fittings using correct thread sizes/types, allowing the #11 pipe to simply be disconnected…rather than cut open. An enterprising DIYer could duplicate that set-up, with some effort.

Checking raw or ‘deadhead’ pump pressure, however, is easy. This is pressure before the inlet regulator. Item #1 in the above illustration is the inlet hose from the pump to the engine bay. It is simply clamped to the supply pipe…meaning it can be easily removed and the pressure gauge fitted to the supply pipe.

If the inlet regulator is suspect is can be easily disconnected and bypassed. Many V12 owners remove it permanently, in fact. The true intended purpose of the inlet regulator has been discussed and debated over the years but, in any case, it is not essential to proper running of the engine

Cheers
DD