Engine Limp Mode help!

Hi there,
I have a manual X300 3.2 Sovereign that has just gone into limp mode after going through lots of standing water yesterday. My belts were squealing so everything got pretty wet up front.
The car will now not exceed 2000rpm.
I tried a cheap code reader but no codes are shown and l have no warning lights on the dash.
I’m wondering if the cold water could have killed my O2 sensors or whether the ingested water might have got to the TPS?
I inspected the air filter and everything looked dry (next day)
I’m in the UK (Boston Lincolnshire) and am a bit stumped who to turn to.
I have had the car 5 years and it has given me many miles of pleasure, l do my own servicing and it has never seen a dealership/garage in my ownership.
Any advice would be very gratefully received :pray:
Cheers
Nick

Welcome to the forums, first off have you tried doing a hard reset?
For a code reader I have a iCar 930i, not sure what they are going for now as I have had mine for a while.

Hi Robin,
If you mean disconnect the battery and wait half an hour, yes l have tried that. Or is there a better method?
The car drives better for a while after disconnecting the battery but then slips back into full limp after a couple of miles……

Yes thats the long way to do a hard reset, the quicker way is to disconnect the neg lead and hold it against the pos terminal for about 30 sec. There’s no danger doing it this way as the battery is effectively out of circuit.
I think you may need to clean all the plugs in the engine bay to check that any water has dried out.

^ That doesn’t make sense.
If the Ecu isn’t seeing any faults it will perform as it should, so there must be a code being recorded.

Well l can assure you it wasn’t happy and definitely holding up traffic only able to do 47mph on an A road :smiling_face:
My code scanner is Lidl’s finest at £15 and probably not very capable of understanding 1996 OBDll :roll_eyes: there might be a code in there but l can’t see it….
I did notice the O2S said not ready, maybe that is a clue?
However l drove the car to the supermarket (Lidl :laughing:) today, a trip of 2 miles and it performed perfectly as if nothing had ever happened.
I hadn’t even done a reset since its last hissy fit, just parked overnight.
Cars honestly :grin:
I will give it some time to make up it’s mind if it needs attention or not, I’ve found a local specialist who has all the tech for any year Jag. Haven’t spoken to them yet though.
Thanks for your help and suggestions!

The readiness monitor not having run it’s cycle is a result of the reset. It has to run a cold, hot, cold cycle before it completes a drive cycle.

I would have said the code reader can’t read the appropriate protocol, but it appears to be able to read readiness monitors.
It’s possible that UK supplied 1996 Jaguars are not OBDII, only OBDI.

When l first connected the reader it found a P1621 code which apparently isn’t anything to worry about and not connected with this issue.
I was able to delete that code and it hasn’t come back so far.
So the reader can pick up from the car but I’m not confident that it isn’t missing something……

X300s are OBD11 compliant.

1 Like

P1621 is the Eprom data storage overloaded, but is most likely a result of low battery voltage.

The reader will either function, or not, so it sounds like it is working fine.

I would have thought a full limp mode would have triggered the check engine light which is definitely working (lighting at start up) but it didn’t/doesnt?
As you say if the ECU is unhappy there should be a code of some sort thrown.
Maybe full Jaguar diagnostic equipment can dig deeper than generic code readers can?

The check engine lamp is only illuminated for certain faults and OBDII is generic, so a proprietary reader won’t see any codes, but should be able to see live data, the same as any other more highly configured diagnostic tool, or oscilloscope.

I drove the car for 1.5 hours yesterday.
It will now do 60mph and only above that does it misfire, reducing speed reinstates the power.
I’m wondering if it is even ECU induced or in fact is vibration induced :thinking:
Would explain why there is no fault code.

I did a 5 hour round trip in the car today, it is functioning without fault at all speeds. Completely back to normal.
No parts have been replaced, everything as it was before it got wet so it is a self healing car :wink: