Faulty wiper blades 82 XJ6 S3

So I just got the car back from the panel beater, it went in as the windscreen they fitted in a previous job leaked and they had touch some paint worked that was also not done that well.

Now the wipers don’t work, took it back and they said they did touch the wipers. Could be true.

The wipers are trying to move but just seem stuck or maybe the motor for the blades is not working properly. Sometimes I can get a bit of movement of the wipers but it stops shortly after that. Other times no movement at all.
So just wonder what if any are common faults with the wiper system. I recently changed the wiper switch arm ( a brand new one) and that has been fine for months.

1982 XJ6 S3.


Bit more info. The large connector from the wiper switch arm gets hot. And left and right wiper doing identical faulty behaviour.

Could it be in the wiper switch or is there something else common to both wipers, relay?

I would start with the connector itself, clean and check for corrosion.
Get the diagram and apply 12v directly to the motor and see if it works.

You have of course checked the fuse, Andrew - if the motor is stuck for whatever reason, the fuse will blow…

Is it the same whatever either stalk switch position - and have you tried lifting the blades off the screen to ease the load? You can also remove the fuse and, using a test lamp or ammeter over the fuse contacts, check whether the motor draws current at all.

The wiring of the wipers are rather intricate, but it is possible to concoct a situation where the motor gets power without turning…

xj6 85 Sov Europe (UK/NZ)

Thanks Aristides, sounds like a good starting point. Will do.

Connectors should not get hot. Getting hot means voltage is meeting resistance, and there shouldn’t be any resistance in a connector.

I dunno what sort of connector it is, but on the XJ-S forum we’ve had reports of bad connections inside those solid rubber block connectors, where the wires connect to the bullet terminals.

Yes, sounds like the same connector. This is it.

Hi Frank,
Fuse and the holder are good. Different response depending on stalk position, haven’t figured out any pattern with it yet. Will see if it’s drawing current.

Where is the actual wiper motor located?

Behind the battery in the wing. Both wipers are linked together and driven by a wire. The motor pulls and pushes the wire and that moves the wipers. I would look at the park switch but the connector getting hot means short and or bad contact.

Thanks David. The connector is a very tight fit. The fact that the fuse is ok, might very well mean bad contact/high resistance.

If I have to get to the motor do I have access behind the battery or is there access inside behind the glove box?

You have to remove the battery and the motor is in a pocket: if you want to remove it you could mark the position on the windshield, remove the wiper arms and the cover plate on the motor unit and just pull the wire out slowly (it will be obvious).

Not sure if you need to remove the unit; depends on the side the park switch is.

It could be the motor, too. Or the stalk switch.

bypassed the stalk switch, put it into slow mode, initially with no wipers bolted on. It moved back and forth, looked ok. so bolted on the blades and it did move at all. Took the blades off and then won’t turn at all. with stalk switch bypassed and in intermittent mode is when the bullet connector gets real hot, but there is movement without blades attached.

Not sure whats going on in itermittent mode but he slow mode behaviour seems to point to the motor (winding short?).

OK, got into the wiper motor area. Took the covers off and disconnected the cable. I cannot slide in or out at all, not even a fraction of a mil. What could make that so tight, could it be the mechanism that the wiper arms bolt onto or is cable jammed up somehow??? Looks like a good strong cable, hard to imagine it causing a problem. Hope it hasn’t burnt out the motor.

Did you disconnect the cable from the motor, Andrew - to verify whether it’s the motor or the wiper mechanism that is stuck?

also, the motor is not all that powerful; it is perceptibly slower on a dry windscreen - and indeed, over time the grease in the mechanism solidifies over time, interfering with operations. How did you bypass the stalk switch? The stalk switching is very intricate…

xj6 85 Sov Europe (UK/NZ)

In principle, if the motor or mechanism is stuck, the fuse is supposed to blow. You should indeed report, with the fuse removed as described, how much power the motor is drawing.

As far as the motor is concerned, there is no difference between the intermittent and the normal operation, it’s the relay that is turning it on and off.
The hot connector thought is not normal.
Is it just the connector or the cables as well that get hot?

The fact that even with everything disconnected you can’t pull the cable in and out suggests that for a reason the cable is jammed.

The wipers system on these cars is marginal to begin with, because all the current goes back and forth and through the stalk switch. Adding relays transforms their operation.

yes, disconnected the cable from the motor. Cable is jammed won’t move ay all. Found a good s3 schematic at SKjagtech.co.uk sometime ago, shows how to jumper the various wiper modes.Schematics_SIII.pdf (574.3 KB)

Not sure why the fuse did not blow, measured 11amps. Original fuse is still in there and says continous 10amp and 20amp blow. Maybe thats got something to do with it.

How do you remove the wiper gearbox off the tube and cable? Want to get them out and clean/lub them in case they have bound up.

It’s just the connector getting hot and that’s with the stalk bypassed. But only on intermittent, don’t understand why that is yet.

Cable definitely jammed. How do you remove the wiper gearboxes from the tube and cable?

Will put in a relay when it’s back up and running. Good suggestion.

Maybe there is a fault at the relay?

On the XJS its somewhat easier than the saloon, others will have more details.

You will need four of them.
Yes, they should be up and running before you start this.
Details in the Book.
What I did was to cut the loom and connect the relays with a plug so I can revert back at any time, great for troubleshooting.

My wipers work(ed) great on both XJs.

Could be seized or a jammed wheel box. Shouldn’t be too difficult to replace any of the possibly faulty parts.

Yep, both wheel boxes very hard to turn. Was hard to get them off the cable. Centre spindle on both boxes bent.

Chasing up some boxes, the 2 boxes are not identical

1 Like