Fuel Pump Intermittent

I found out yesterday the fuel pump has quit working. I was working on the NO SPARK issue that many of you here are all too familiar with and which has not been resolved. When I turned on the ignition I heard the familiar half second hum from the fuel pump. After several more tries it registered in my subconscious that the fuel pump was not priming. GREAT, just what I wanted, another issue to solve. I started at the first logical place I could think of and checked the fuel pump relay in the trunk, it was working. I had power to the relay but when I jumped the 30/87 terminals in the socket the pump didn’t run. I checked the wire (blue/red) from the connector on top of the tank to the relay and it is good. It had been a while since I had turned the ignition on so I tried it again and on the first try the pump did it’s half second prime but when I tried again I could hear a little noise from the pump, very short, not a priming sound but something that let me know the pump was getting the call to action, getting power. Bottom line if you let it set for a while you will get a prime from the pump on the first try, no prime after that, it just makes a small noise, enough to let you know it’s getting power.

So here’s the question, (and unfortunately I think I know the answer), Is the fuel pump going bad or is there some other condition that would cause the pump to act this way?.

I am really bummed out at this point and would like to get on with my life. I haven’t resolved the initial issue and now have two more, limp mode & fuel pump. I replaced the fuel pump many years ago and it’s no easy job. I believe I have to repair the pump before continuing with the No Spark issue because the Jag is never going to start if the pump is bad.

Please share your thoughts on this and again, many thanks for your help in advance.

The fuel pump was moved from a frame mounted external to an ‘in-tank’ unit for the 1991MY onward.

You don’t state the MY so any advise could be incorrect.

bob

Sorry about that, 1994 VDP, in tank fuel pump. Thanks for pointing that out.

Joe …

Wow … when it comes to your car if you didn’t have bad luck you’d have … well you unfortunately know.

As I understand the system, every time you turn on the ignition it provides a short priming burst from the fuel pump. I would put a volt meter on the power connection going to the pump. If you get a 12v reading every time you turn on the ignition but the pump doesn’t respond, then I’m afraid it’s the pump.

If you don’t get the quick 12v reading then the problem is obviously up stream and the pump is probably good.

“NO LUCK AT ALL” ha ha. I haven’t looked at the power while cranking but I can sure do that before ripping out the fuel tank. My initial thought is that cranking doesn’t even come into play, the priming happens at the first turn of the ignition switch before the dash lights on the second position of the ignition switch and of course the third position engages the starter. The other thing I get from reading is that jumping the 30/87 terminals should just run the pump continuously and I get nothing. I’ll give the cranking/voltage test a try. Thanks for checking in, always goo to hear from you.

No you’re correct that the signal to the pump should come with the ignition being turned on not cranking the engine.

md5653a

item 25 is listed as the fuel pump protection module. I’m assuming that the module recieves the voltage and the fuel pump plugs into that. So I would try to read the voltage before and after that module.

On a 94, the oxygen heater relay on the firewall also controls the fuel pump.

Hey abercanadian, that’s correct, it’s not an issue of getting power, I have power to the fuel pump relay in the trunk, I’ve tested the relay and it’s good. With the relay out I jumped across the relay terminals 30&87. By all rights this should activate the pump, it does not. If this is not correct please say so, electronics and wiring is not my strong suit. Thanks for your input.

Joe …

“With the relay out I jumped across the relay terminals 30&87. By all rights this should activate the pump”

Well yes and no.

smallrelaywiring_grande

Referencing the diagram (substituting your fuel pump for the lights) even if you jump pins 30 and 87,
as you correctly did, the pump will only operated if pin 30 is recieving +12v power. You can check this by pulling out the relay and using your volt meter to look for a brief 12v across pins 30 and 86 when you turn on the ignition. That will tell you the relay is receiving power.

Now do the same thing reading across pins 87 and 86. This will tell you the relay is powered AND working.

Thanks Grooveman, will go do that right now and update.

The ‘Evaporative-Flange’ in the top of the tank is prone to ‘burnt’ contacts from the power link lead to the flange connector or inside the tank at the flange connector to the power harness for pump itself.

Clogged filters or a failing pump can draw excessive current and damage the pins in the flange connector. The ‘Evaporative-Flange’ is NLA as far as I remember.

The X300 did away with the pump module plastic housing assy and simply fitted the pump into a steel pump sump and mounting bracket in the tank bottom. (much simpler system)

bob

Joe …

If your relay test checks out OK that gets you power to the “fuel pump protection module” …

s-l225

… that I know absolutely nothing about. Anyone ever deal with this ?

I must be losing my mind. I went out to run the test on your drawing, with the ignition OFF I pulled the relay and checked voltage in the relay socket across 30/87 and registered 12.25V, then across 87/86 again 12.25V. I then wanted to check voltage with the ignition ON. To my surprise and utter amazement when I turned the ignition ON the fuel pump primed without the relay in, how is that possible? Then as before, when I tried again I just got the little umph like it got power but refuse to prime. My wife has hidden all my guns.

I believe that is what motorcarman was referring to, that it is prone to being a problem, however it is getting power to the pump. I just don’t understand why it primes once but will not repeat without a rest. The fact that it did this with the relay out now has me wondering if it really is a bad pump. I almost said screw it, I’m just going to pull the fuel tank and replace the pump, not so sure now.

Orf 6Joe…

Strange !

Before you go to all the trouble of pulling the gas tank I would definitely crawl under the car and make sure the pump is really bad
If necessary unplug the pump’s electrical connection and apply 12V directly from the battery.

Unfortunately not being familiar with the “pump in tank” setup I can’t help you with the wiring under there.

Grooveman, there’s nothing to do under the car except disconnect the fuel supply and return lines, everything is done from the trunk.

Not possible, can’t get to the top of the tank without taking it out. There is a heavy sound deadening mat over the top of the tank which I had to cut just to get to the connection at the top of the tank and check for continuity between the tank connector and the relay, zero room on top. I’ve included some photos for clarity. There are two grounds in the trunk (may be a third on the driver’s side by the taillight). There is normally a connector behind the battery that connects the Blue/red wire and Black wire to the relay and ground. When I replaced the fuel pump the last time I eliminated that connector because it was a problem area. I spliced the Blue/Red wire directly to the relay and attached the Black directly to the ground (see photo)

Joe …

I assume the black and blue/red wires in your second picture are coming from the pump.

Can’t you just cut the blue/red wire where it’s joined to the blue wire in your third picture (red arrow) and run a wire from the positive + side of the battery to that blue/red wire. Since the black wire should go to ground that should power the pump. If the pump still doesn’t work cut the black wire and jump it to the negative - side of the battery. Now if it still won’t run you’ll definitely know it’s the pump that’s the problem.

You are absolutly right, I can do that. Here’s the thing, it’s still running through a connector before it gets to the pump. If the connector is bad then the pump will not run so if the pump does not run I would still have to pull the tank to find that out. I did back probe the connector at the tank and had 12.23V. It’s no big deal to cut the wires and go direct just to make sure. Now that I think about it I believe I used aircraft connectors under those black wire covers that I can just take loose (in the first photo in front of the float sensor. left click on the photo right click when it opens, chose view image and then left click again), . I’ll let you know tomorrow. Many thanks again, so nice to have guys who love their Jags to bounce things off of.

Well this is interesting and above my ability to solve on my own. Big thanks to Grooveman for his above suggestion because I would probability not have checked it this way left to my own devises, that’s the beauty of this forum.

As mentioned earlier, the fuel pump connections under the black cover in an earlier photo are secured by aircraft connectors (photo below) so I didn’t have to cut any wires to run the test. First, as suggested, I disconnected the Blue/Red wire running to the fuel pump and jumped it stright to the battery without disconnecting the Black ground wire. Keep in mind that I checked resistance and continuity on the ground wire and they were prefect. the result was Zilch, Nada, not a peep from the fuel pump.

Here again I want to stress if not for Grooveman I would have been finished with this test, but NOoo, Grooveman wanted me to disconnect the Black ground wire and jump a direct wire from the battery. I have to be honest here, my mind said “what’s the difference, ground is ground and I know I have a good ground”. Fortunately I have made it a rule not to discount anything suggested by others here on the forum, with Jags you never know where the issue lies. So being the obedient forum member I disconnected the Black ground wire and jumped it directly to the battery. (see photo) SHAZAM!, the fuel pump was running.

Now the obvious question is WHY. The fuel pump relay is good, Blue/Red wire is good from relay to pump and Ground is good. I now do believe that all three issues I am currently experiencing, (no spark, limp mode & now fuel pump), are somehow related and it seems like it may be Ground related. I’ve included a schematic of the fuel pump wiring.




This may seem too obvious but if the ground connection straight to the battery works but the normal ground connection does not - and considering the other issues you are having that MAY be ground related - have you revisited the negative battery terminal to body ground connection in the trunk/ boot? I know you stated in post #61 of your “1994 Jaguar VDP No Spark” thread that you have “Cleaned all engine bay ground terminals and Neg from battery to ground in trunk” but it may be worth checking the integrity of both the ground cable and the connection to the ground stud.