Heater Help Needed

I have a 1988 XJS with the MK3 system.

So now that it’s a frosty 30F morning here in Seattle, I drove today to test out my heater. (I have replaced all heater hoses, and also the heater control valve)

With my engine totally warmed up to 180F, I turn on the heater to max, 85F. I can feel warm air coming out of the lower vents (although I would say it’s only in the 70’s), but there is ice cold air coming out of upper vents. So my feet and legs are warm, but my upper body is cold. I assume this is not the way Jaguar designed it?

Can anybody point me to how to diagnose and fix my issue? I’m assuming there is a series of vacuum operated flaps? And how to get at 'em?

Thanks

When you say upper vents you mean the central vent or the two side vents?
In the first case the main suspect would be AC Amplifier, the system is stuck in cooling mode.
In the second, probably your Delanair inner mechanical flaps are not set correctly.
Check also that the heater valve is indeed working, even if it’s new…

What happens when you put the system in defrost mode?

The upper central vents are cold. But I have no A/C. It is just outside air coming in.

I checked new heater valve, I’ll double check. But like i said, warm air is coming from lower vents.

inner mechanical flaps???..that’w where i’m lost. I have no book or reference about them.

The MkIII has servo-operated flaps. One of your servos has probably given up the ghost – which is bad news because they’re expensive and very difficult to get at.

Hmmmm, remove glove box to investigate?

In summer, I got warmed air coming from upper vents, and now in winter I get cold outside air. Seems like it’s backwards.

just discovered a write-up by forum member Doug. I’ll look through that. Sounds like the upper vent should be closed when heating.

Don’t know if this helps, but on way home, turned on heat, for about 20 seconds I could feel lukewarm air out of upper vents, but then they turned cold rest of the drive.

Yes. As I recall (heh heh) that’s the only way to really get a clear view of what’s going on. From memory, the servo motors have an exposed spindle so you can see when it is rotating

While you’re rooting around seek out and inspect the 6-8 tiny connectors with tiny wires. On my car, and a couple others I’ve worked on, these were green and cruddy with corrosion. Cleaning them solved some mysterious symptoms. They’re all pretty easy to reach, as I recall, except two on the left side of the main case and up rather high

What write-up? Probably from a long time ago. I recall a problem with the flap linkage for the dashboard center vent…which should be open only in full cooling mode. i think the linkage somehow became ‘out of phase’. I dunno.

Cheers

DD

1 Like

When I first got car last year, I noticed the fan blower didn’t work. Then suddenly after sitting several minutes on, the fan started working. So obviously there was some corrosion.

My instrument cluster was badly corroded, I have since replaced.

I will take a look, hopefully just cleaning up wire connections is all it needs.

What position do you. have the bottom control lever in

pushed to the right, to the red indicator. Doesn’t make much difference left/right, though.

I got a possible break thru this morning…thinking about how I got the fan blower working last year, I turned the fan on/off about 20 times. Suddenly, the heat only came out of the lower vents, and the upper middle vent nothing came out. Success! But upon turning off the fan, and on again, air started blowing out of the top.

So hopefully I just need to clean some wires and/or get that servo moving back and forth a bit to free up 7 years of sitting.

Greg,

Attached are some resources I accumulated over the years. They should help.
aircon-schematics-mk3.pdf (285.9 KB)
Delanair Mark 3 Information.pdf (131.9 KB)

Good luck…and yeah, toasty feet and hands are good right now. Dropped into the single digits here in Colorado.
Matt

1 Like

Here’s some info on the actuator (servo) that controls the center vent.
http://www.goflyrc.com/projects/XJS/xjsheater.htm

Kirby, what do the little solenoids on each side of the console, down behind the radio, do? I don’t remember but I replaced a couple of them when I got my car. They control vacuum to the HVAC system somehow… IIRC there are four, two on each side?

Thanks guys! A lot of resources now, I’ll take a look this weekend.
Will make a change not having to work under the car on jack stands!

No idea! Sorry. Is that on the MkII or the MkIII?

Greg

check the upper actuator on the passenger side. It is probably stuck. I had the same problem earlier this year. You have to remove the glove box and the Delanair ECU to get to it. I managed to wiggle it around and it started working again. Other listers on this forum reported that it is a pain to get this actuator out. On of the two bolts that hold the actuator is only accessible after removing a metal brace. And that is why I did not attack it right away. Perhaps you get lucky.

Stephan

Well, I may have got lucky. Switching the fan on/off a few dozen times may have been enough to un-stick the upper actuator. This morning, upper vent stayed closed, and I got nice heat flowing from lower vents only. Although it’s not as furnace hot as my Volvos, but nothing is. Perhaps I’ll need to replace the heater core at a later date for better heat transfer.

Thanks for all the help!

These are what I was thinking of… my car is a MkIII and has them. Unsure if they were present on earlier versions.
http://www.jag-lovers.org/snaps/snap_view.php3?id=1139147747&n4=
Looks like they control the vacuum to the actuators.

I presume that’s how the MkIII controls vacuum to various vacuum-actuated devices.

Correct - I had to go back thru my notes. When I first got my car, my “flap issues” were 90% related to failures in these solenoids. The solenoid was corroded or inop and was not allowing vacuum to the actuators when told to do so. So the moral of the story is, at least with a MKIII, don’t assume bad actuator (aka servo). These solenoids are easy to get to, easy to test, and used to be relatively cheap and avaible. Course that was 12 years ago…

1 Like