Ignition Switch Removal

On my 2000 year 3.0, when I pull the ignition key out of the lock there is a little flap that is supposed to close. Sometimes it doesn’t, and I have freed it up by spraying in lock-lube graphite. Now today the radio and clock stay on, there is a chime when I open the door, and the remote locking doesn’t work, although I can lock the car with the key in the door, so all the electrical locks are working, but not the red light on the dashboard. The chime stops when I close the door, and I turned off the radio but the clock is still on.

So it seems to me like the thing thinks the key is still in the ignition switch.

Have I diagnosed this correctly?
Do I need a new ignition switch?
Can it be taken apart and cleaned?
I have the wiring diagram and it shows the switch has 5 switches inside it.
I found the removal procedure in the JTIS page 57.40.29 under Chassis Steering Column.
Anybody done this, any tips?

Rock Auto has a couple of different aftermarket brands at different prices.


I suspect that you are right and that somehow the Key In switch is now stuck indicating the key is in even though it isn’t. If this is the case, the PATS will detect an error because it will expect the signature from the key. As the key is not present, that could be why you get the warning chimes and the remote locking doesn’t work.
I have had the same thing when the key shutter didn’t close when the key was removed. That also prevented the central locking from working. In my case there were no chimes and I never noticed whether the clock remained on. Luckily, some switch cleaner solved the problem so I have no experience of removing the ignition switch.


Ok thanks Eric.
I ordered a new switch from Rock Auto, $124, delivery promised for Monday but they are often faster than that.
This is my daily driver with 230,500 miles so I guess I wore it out, have to spend some money keeping it up. Hope the clock doesn’t run the battery down overnight. I’ll post pictures when I get it out.

I was thinking about how this happened and wondered if the graphite had somehow got into the Key In switch and was making it conduct enough for the PATS in the Instrument Pack to see it as closed?

A plausible theory, so I tried squirting in some cleaner degreaser, but it didn’t make a difference. Might try again in the morning.
Another surprise tonight, I went to unlock it from the passenger side and discovered there is no outside lock there. Funny thing to discover after 10 years of ownership. The joys of being in the habit of using the remote.
But the chiming only happens when the driver door is open, not any of the others.

Well, here’s where I am stuck.
Got the lower panel off, there is a sneaky plastic expansion fastener that you have to pry the inside square part out of the round part like pulling a nail out of a drywall anchor. The other fasteners are springy tabs you pull straight out.
Then there is a duct and a large steel plate held by hex head screws, 8mm and 10mm sockets.
I tried to unplug the back connector.

The connector plug catch is a tab which you squeeze in and the plug pulls out. So far so good.
Trouble is there is about 1/8" less room in there than you need to get the plug out. There is a big metal frame in the way that is part of the steering column support. No luck there.
So to pull out the whole ignition switch, you need a 7/32" socket, yes not metric. Maybe there’s a 5.5mm socket somewhere in the world but not in my tool chest.
There are two bolts, not three as the JTIS says (maybe that’s for RHD). You need a swivel joint and long extension to get the top one, also very hard to see it.

Unplug the green connector by pushing a tab on the left side and pry it off.
Here its out and you can see the green and red connectors.

Then there is a trans cable to disconnect, use a T15 Torx screwdriver on those yellow painted screws.

And you’re out. Another T15 Torx screw and the rear switch is off.

There is a plastic case on the front, yellow paint on the clips like that’s going to stop me, 4 pin connector, what’s in there, must be more switches? Nope, circuit board.

I’m beginning to think my problem is in these front switches. So how to get it apart? The key cylinder seems to be spring loaded. There is a pin (white arrow) holding the key cylinder in the case, moves with the cylinder but doesn’t unscrew or compress, seems to be pressed in, can’t get any needle nose pliers on it.

What to do next? Maybe I’ll try soaking the whole thing in alcohol to clean the graphite out of the inside? Any other ideas?

One thing I’ve figured out is it doesn’t have to be actually in the dashboard to run the car, I can try things with it dangling down.

I’ve no experience of the S Type ignition barrel but on older cars I’ve worked on the lock part is secured by a bolt with a head that is meant to shear off when you tighten it. This is meant to be a security measure and you have to drill it out to change the lock. The pin could be a modern version of this.

I would take a guess that the circuit board is the reader and amplifier for the key. The head of the lock will have an exciter ring built in. In my XK 8 it’s a separate item and you can unclip it and replace it. Looks like S Type is different in that it appears built into the lock.

Isn’t your new on coming on Monday?

Sorry, dumb answer - it’s late. You need to swap the lock over to the new switch, don’t you?

Maybe you can see what you have to do to release the lock when the new switch arrives.

I’ve had the front end soaking in isopropyl alcohol for a few hours, and the little door in the key hole now snaps closed most of the time when I pull the key out. I’m still getting a bit of graphite in what dribbles out so I will continue this treatment until it seems clean.

I begin to suspect that this trouble was caused by my squirting lock-ease in there.
The Tech Guide says there is an electronic device inside the key, so I suppose that must interact with the circuit board as Eric suggests.
The black plastic ring on the end including the circuit board does come off if you get the lock barrel out first.
I’ll wait until the new switch arrives before I consider drilling out that pin holding it together.

The key needs to be in the lock and turned to position one to get the button to depress.

1 Like

Brilliant! Thanks very much Rodney! :+1:

I don’t think it comes apart much more than this as that chrome cover is crimped over a flange on the main body, holding the rest inside.
I would have to wreck the cover to get it apart and I don’t want to do that.
Maybe more cleaning will help.
I’m curious to know how the key transmits to the ring on the outside.

The key doesn’t need to be in the lock to transmit, as long as it is in close proximity it will activate the sensor. All you have left in the lock is tumblers and springs so a soak in a suitable cleaner and a good dry out afterwards should hopefully cure your problem. As a precaution I would just stand it on end in cleaner up to the button in case they have hidden some electronics in the bottom.

The ring contains a coil of fine wire. The ones I have tested are about 35 ohms. If you look at the key, in the end away from the bit that goes in the lock, there is a little plastic plug. Inside that is the transponder. They are all different shapes and sizes but early Jaguar (Ford) ones look like this:

only not so large!
Inside is another coil of wire which and chip which can be programmed using IDS.
When you put the key in the ignition lock the electronics (on that board you found) fire up the exciter ring at a frequency I measured once. I think it was around 200kHz but it was a while back. Anyway, that induces enough power in the transponder for the chip to communicate with electronics and the code is read and amplified and passed on to the security system.
I studied XK8 in more detail than S Type because I had a big problem with mine. The systems are different but the principle is the same. There are various handshakes between modules and if all is OK the system says OK to start and fuel pump, ignition and starter cranking are activated.


I just read Rodney’s comment about the key only needing to be in close proximity which is quite right. When you are programming a set of keys, IDS warns you not to leave the any key other than the one being programmed near the ignition lock.

Fascinating, thanks Eric and Rodney.
So I won’t disturb that plastic ring.
There is a little roll pin in the tail end of the body and I pushed that out a bit with long nose pliers and got the tumbler cylinder out the back.

The round pin about 1mm dia and 10mm long sits in a groove in the tumbler cyl and rides against the tumblers inside, so permitting rotation only when the key is in. The rounded square thing is what I called the door in the key hole. It seemed to be hanging up sometimes, and so were the tumblers after all the alcohol cleaning, so I think maybe it only needs some oil to make it work right.
Pressing on.

Here it is with the little door thing back in the end of the tumbler cylinder. It is a hemisphere and swivels in a pocket there. I thought about leaving it out, but there is a spring pushing on the cylinder and it seems to prevent the cylinder moving in and out and the key didn’t work right with it out, so I’m putting it back in.
The tumbler stop pin is back in the slot.

Back together and awaiting the 8 pin black plastic switch on the back coming FedEx tomorrow.

I put some 3-in-1 sewing machine oil in the tumbler and now it feels right and the little swivel keyhole door moves as it should every time. Guess I should have used 3-in-1 in the first place rather than graphite Lock-Ease.

The switch doesn’t feel right, so I think I made the correct diagnosis about the original problem. BTW it ran the battery down Thursday night, but I think it was not just the clock being on but maybe the headlights came on late at night or something, because when I put the battery charger on it Friday morning the headlights came on with the key in my pocket.

I forgot to mention the white plastic cam. This goes on the back end of the tumbler shaft after the coil spring and lines up with the trans cable socket. It rotates with the shaft and blocks the cable hole when the key is in position 1. The cable end protrudes through in any other position and would thus prevent the key going to position 1 and being removed if the trans is not in Park.
Here is the other end of the trans cable at the J gate shifter (photo from a 2012 repair).

Not fixed. The new switch didn’t make any difference, the door still chimes and the radio is on with the key out. I’ve disconnected the battery. Any new ideas?

Well, it might help to know where the radio is getting its power from. There seem to be two main feeds, a permanent via fuse 18 and a switched via fuse 27. I assume the permanent feed keeps the stations the stored but the switched one shouldn’t be there with the ignition off. So, does pulling F27 make any difference?

Pulling fuse 27 stopped the radio and clock, but the door open chime continued on. The chime sound seems to come from a black plastic module located under the steering column.