Injector Loom Plugs PINS both 12V or Not ? ( AJ6 Engines )

Spent yesterday going over injector circuit wires form ECU to Injector Plugs mainly checking for shorts or grounds.

Test found constant ground present at ECU Pins 30 PINK/GREN & 12 PINK/SLAT wires which go to Resistor Pack which feeds INJECTOR Plugs Left Pin wires ORANGE/GREEN & ORANGE/SLATE.
Injectors loom Plugs RHT PINS 12V on all the Pink /black wires….and LFT PINS have 0.51v on the Orange /Slate & Orange/ Green wires from Resistor Pack ( Pack ohms are In Spec )
I’m con fused…many forum write ups state for V12s state: 12volts should be present at both pins of injector Plugs

If you visualize how the system works, you should never have a hard ground on an injector pin. Battery voltage is fed via the EFI relay to one side of all the injectors, the ECU grounds the other side (either directly to open, or through the resistor pack to hold) only momentarily when the engine is cranking or running. Easy test is to disable the fuel pump by removing it’s relay; turn key to run position- you should have battery voltage on both injector pins of all injectors. If not, unplug the ECU- if you now have battery voltage on all injector pins, your ECU is bad (injector control shorted). If still no battery voltage on some pins, unplug the resistor pack. If still no battery voltage you have either injectors that are open circuit, or a wiring fault.

hi Robert,
I think i’ve been stupid … i’m gonna check with boots connected to injectors ( back probe check for voltage ). Still no fuel pump prime at key on ? I’ve tried new main and fuel relays. Did 1 test light test on Orange wire (power on via battery terminal ) still no prime…is there another signal to tell pin15 on ECU to function.


Here you’d find +12V on both pins (backprobed) as the ECU isn’t grounding the injectors. IF it were, the voltage would be pulled towards ground (near/at 0V), and the injector would be powered on as energy flows through it’s coil, rather than simply being there at a static potential of 12V.

Pin 15 of the ECU (or it’s analogous one on a V12 6CU) grounds for a pre-set number of seconds with first ECU power on (key on). It ceases (safety feature w/o the engine running), and will not turn back on until it gets either the +12V High signal from the Starter Relay, - and continues with the RPM signal from the Amp.

~Paul K.

If you get +12V at the injectors with key-on then the Main Relay is functioning. The next thing to check is the Pump Relay socket. Is there +12V power on the socket for pin 86 with key on? (Or alternately continuity between pin socket 86 of the FPRelay and Pin Socket 87a of the Main Relay?)
Is there +12V on the socket for pin 30 ALWAYS (as it’s from the battery)?
Do you have some Ohm value for the path from pin-socket 87 to ground as it passes through the pump windings?

And… do you have (you may need a LONG test lead for this) continuity between pin socket 85 of the FPRelay and the pin socket 15 of the EFI ECU?

~Paul K.

Fuel pump prime logic is internal to the ECU; have you checked the inertia switch? The one on the above diagram interrupts power to the EFI main relay (noted as European and UK); on my V12 it is on the left cowl panel and interrupts power to the fuel pump IIRC. Plunger on top resets it.

Hi Paul
My FP Relay and Main Relay are both in boot next to ECU on Wheel arch in Wing .I did continuity test a few days back …checked out ok. I just checked oil ( fuel present ) then realised that the bores might have been washed clean over days of cranking. So pulled spark plugs and oiled all six pots cranked engine for 5 seconds and then oiled again . Replaced spark plugs, cranked ,she caught for a few second …then I realised I had no fuel pressure ( Have a pressure gauge set inline to cold start injector)…out of FUEL!! ??? Clamped off fuel filter either side , heard air escaping ,hardly any fuel in filter. Unclamped mini sump side hose & jumped fuel relay…spluttered like straw in empty cup. Just waiting for a ride to get fuel.