No heater 76 pre he

This is really a follow on from my previous post where I had no air conditioning, thankfully solved after much help from you all out there, thank you. However, now the weather in the UK has turned from super hot to pretty Autumnal heat would be good. Before I purchased the car the previous owner replaced the heater valve as when he was prepping it for me it blew. I have since replaced the radiator and bled the system as per the ROM and the car runs cool. I have no movement in the heater valve lever whatever I do with the temperature control and mode switch. Its pin is down and against the stop. I have similar temperatures on both pipes in and out. What is confusing me is that I was told that the vacuum would drop out for heat and the valve lever would be down and the reverse for cool. Well since I now have superb cooling and the lever doesn’t move I wonder whether its the other way around and and the heater valve needs to be up for heat? Anyway, a quick google suggests that its possible for air blocks in the matrix, Any advice would be much appreciated. I think the servos is all working, but I am just about to pull the fuse for the fans so I can hear the servo operating for sure. thanks Andrew

When you filled the radiator did you have the heater set to hot?

hi Robin and thanks for the reply. To be completely frank, I cannot recall. If that’s detailed in the ROM I would have done it. However, its fair to say that would be a strong contender for it not flowing through the matrix. Not sure how I can bleed the matrix without removing one of the heater flow pipes now though. It would be helpful to know for sure which way the valve should be.

Pretty sure no vacuum the lever is down to open, which is heat.

Thanks Robert. That concurs with what I have been told elsewhere. In which case maybe the reason my Air Con is working fine on cold is that there is no flow through the matrix due to air lock or blockage. If I get heat I may well expect to lose cooling until I get the vacuum to work correctly. I have just checked for the operation of the servos when the mode switch is cycled and that is working so its going to be blockage, stuck flap or air lock by the looks of things.

Both are common problems.

Cheers
DD

1 Like

I’ve unclogged a few plugged-up heater cores. Disconnect the hoses and fill the core with a radiator flushing/cleaning product and let it sit overnight. I use length of old heater hose as standpipes for this.

Next day, rig-up a hose and couple fittings (whatever works for you) to allow your garden hose to become the flushing tool. You want some water pressure to be applied to push out any gunk but, if you’re like me, there’s some worry that an elderly core might not tolerate too much.

Be prepared for a giant gush of muck when the blockage clears. A hose to direct this muck to the floor (rather than your engine bay!) is a good idea.

A ‘flushing tee’ in the heater hose simplifies purging the air from the core…which otherwise can be problematic. Lots of archived info on this. It really helps.

Cheers
DD

Or from afar, apply vacuum to the valve from a separate source. Mitty vac??? Does the pin react?

Aye, out on errands, my Jeep’s turn. Moved the control from blue zone to red. Nice warm air. Felt good…

Weather folks indicate I will move it back to blue, next outing…

PS" Way out thought. Remove the “power” wire from the compressor. Defeat any anomaly that is providing cold air. .

Carl…

Thanks Guys, some great ideas here. Lots to play around with. I just drove out and had the aircon all switched off. When I got home I tried the heat and hey presto we had heat!. But not for long. I reckon it may have just managed to draw enough water through the matrix to provide me with heat but it soon turn cool again. Strange! I think I will use the car a bit more and see whether the matrix will clear itself, although I suppose on second thoughts I dont really want the gunk from that in my new radiator!. Ah well I think its probably time to flush it through. Will report back in due course. thanks as always.

That means it’s open. Vacuum closes the heater valve.

This is a hot/cold deck system. Within the main housing there is an evaporator coil and a heating coil, normally both active – one hot and one cold. What temp air comes out the vents depends upon flaps directing the air to one or the other, and mostly some balance between the two. The heater valve only closes when the system is having trouble keeping the car cool and has to resort to the extreme measure of shutting off the coolant to the heater coil.

1 Like

That might be your problem right there. You might try my suggested mod of installing a flushing tee at the high point, allowing you to bleed all the air out of the heater circuit when filling.

1 Like

Do you have a flushing T

I don’t have a flushing T fitted. I am unsure where I can get one other than Ebay. I shall take a look. Thanks

At one time, flushing kits were standard fare at most parts houses. May no longer be so, as driveway flushes are discouraged. I think I have at least parts to one on my shelves… The other part probably left along with my IHC Scout II.

But, a trip tot he plumbing department of the local hardware store can result in a few fiitings in either plastic or metal to make one. Two ;legs of “T” to fit the hose. A cap for the third… Or even a simple valve!!

Carl

https://shop.advanceautoparts.com/p/dorman-help-5-8-radiator-flush-tee-with-cap-47121/22147144-p?c3ch=PLA&c3nid=22147144-P&adtype=pla&product_channel=online&store_code=&gclid=Cj0KCQjwoebsBRCHARIsAC3JP0KGedtBrCT1WOxxwogZxxDftSwYKqlq-6AaBjFlb8si-0mtLVHZpT4aAt73EALw_wcB&gclsrc=aw.ds

That plastic tee is pretty stout, but go find a brass cap. The wimpy plastic cap from this kit cannot be made to seal.

Many auto supply or Farm supply stores (around here in midwest) have them…

Are you asking about XJS OR E type…as I see you only list an E type

This is my xjs as per thread listing but I do have an e type and xj12 series one as well. Must add to my profile.