No start issue V12

Need some help from you smart guys. 1990 XJS V12. Blew an A bank coil recently, small fire, burned up the harness connector to the coil and the coil itself. Two huge backfires as it was loosing power running on only B bank. Managed to drive it onto and off a car trailer to get it back to our shop. Replaced both coils, new connector spliced in, new cap and rotor (didn’t need them but did it anyway, and yes, rotor mod done per The Book two years ago and now). Also installed new plugs. plug wires and coil wires look good, new two years ago. Well, after installing the new coils and other stuff mentioned, it wont start at all, not even on the B bank that it ran on before. We did verify fuel and spark working.

So, in we went; wrung out all of the ignition harness. Point to point continuity all the way to the computer in the footwell. Checked coil wiring, checked crank/speed sensor wiring including the problematic little solder connection on the crank sensor, checked ignition amp wiring, all good. Still no start just mild backfiring as if it were out of timing. rechecked all plug wires to validate we landed them correctly at the dizzy. Then did a psuedo timing check by lining up the rotor with A1 at TDC, all good. We then replaced both the crank and speed sensors, still no start. Found a used computer which was claimed to be good. Installed that, still no start. None of those things changed anything, still just mildly backfires like a timing issue. The only ignition parts we didn’t change were the ignition amps up front on the radiator support. They are stupid expensive and as you all may see from what I have replaced I have spent a ton already. Any thoughts or suggestions? I’m at the very end of my ideas right now!!

You say fuel was verified, which probably rules out the inertia switch
The other thing that is a common problem on the Marelli’s - the sensors.
If the CPS or flywheel sensor is not providing proper signal, it won’t start.

Please do check both. Reversing the polarity at the connector (especially since you repaired the harness) is also something you need to cripple-check.

1 Like

Yup, maybe you missed it in my long diatribe but, both sensors were replaced. Polarity at the coil connector is pretty simple, hot, neg, feedback to computer or tach. But, thanks for the response, keep thinking!! :slightly_smiling_face:

One added thing we did and forgot to mention; did a compression check while changing the plugs. All 12 cylinders between 171 and 175 psi.

What did you verify about the fuel? Did you listen to and confirm with a mechanics stethoscope that all fuel injectors fire when you crank the engine? Did you connect up a fuel pressure gauge and verify fuel pressure at the fuel rail?


I’d be trying to verify that all wires were connected properly, starting with making sure the HT leads from the coils weren’t swapped.

I was going to suggest the same thing, make sure ignition coil wires aren’t swapped

Cataverters melted/clogged?

You may have missed it in my response. Polarity of the connectors to the CPS or flywheel sensor :-))

Just take a look here, Gene Holtzclaw documented very well his ordeal with a not starting Marelli engine:

First off, I really appreciate the replies you guys, everything helps.

Paul: Fuel pressure was measured and verified at the fuel rail. However, we did not check activation of each injector.

Kirbert: Leads have been checked and rechecked. Will take a fresh check again.

Motorcam: Cats and honeycomes in the exhaust were gutted two years ago. Nothing but straight pipes and cans far cats now.

Sbobvev: Polarity of the crank/speed sensors. Well, we just plugged new ones in. didn’t need to frig with connector wiring for the sensors. Plus, can’t really frig up the connectors front to back, leads are not long enough for that.

In any event, please keep your thoughts coming. I wonder if the two severe backfires explained in my opening message could have caused a timing chain jump or worse yet a few broken rockers. Compression was good but broken rockers would not show up on a compression check as cylinder pressure would shut the valves. Just another angle for you sleuths to consider.

Have you checked the stinkin’ little white coax carrying the trigger signal to the EFI ECU?

Get a mechanics stethoscope and confirm whether or not your fuel injectors are firing when you crank the starter. It is a simple test but it will tell a lot. A cheap mechanics stethoscope ($10) and a helper is all you need.



Not sure that you wouldn’t see a difference with a broken rocker, on a car that has rockers, the Jag has direct acting cams so thats out of the equation. A jumped cam timing however might be something to check.

On a Marelli ignition?

Please do us a favor and check the thread from 2013 I linked in my previous message.

You said (verbatim):
“So, in we went; wrung out all of the ignition harness. Point to point continuity all the way to the computer in the footwell.”

This is very, very similar to that story by Gene - every wire was ohm-ed, everything was checked.
At the end, his new harness had a flipped polarity at the connector for the CPS and once this was corrected, the engine run.

If I’m not mistaken didn’t Gene also have a marelli ignition car that both sensors needed adjusting because the gap was too wide, may even be the same car in the thread you referenced.

I understand that stinkin’ wire is still there. In fact, IIRC someone told us it’s still in the same place in the engine compartment, with a new wire from the Marelli ECU in the footwell up to meet it.

Whether or not that’s true, the EFI ECU still needs a trigger signal. It’s something to look for.

Note: Without a trigger signal, some have reported you can get the engine to run for a while by pumping furiously on the throttle. That indicates the injectors work.

IIRC, this topic has been covered multiple times, Kirby.
“Trigger” signal for the Marelli is generated by the Marelli ECU itself.
Takes CPS and flywheel signal inputs for that, here:

Then, the Marelli ECU in the passenger footwell, via pin #24 (shielded wire, not coax - shield on pin #7) send the “speed signal” to the EFI ECU in the trunk. Here:

I don’t think the “white stinkin’ coax wire” which we know for the AB14 box (the one that is the culprit behind the no-start of many Lucas cars) and the Marelli shielded wire can be put in the same category.

But I agree, given the fire history and given that replacement harness, this is another possible place in the harness where things can go wrong.

I’m not sure what distinction you are trying to make here. They are both pretty much the same thing. Shielded is just a slightly more generic term (possibly multiple wires) for coax (usually considered as a shielded, single wire).

Please read my post in it entirety. Many Lucas cars suffer from the stinkin’ wire syndrome. Wiggle it it comes back alive (many thanks to Kirby for that - he has probably saved many Lucas cars from the crusher).

Marelli cars - not. There is no such a thing.
Those “shielded wires” from the Marelli ECU to the ignition amplifiers for example can be confused as a wire and a jumper attached to it.

In any case, shielded or coax was not the point I tried to make in my earlier post.