One last thing .... (hopefully)

My problems began in June with a blown head gasket resulting in milkshake oil. I pulled the head, had it rebuilt. The bottom half was in beautiful shape so I pressed on and decided to replaced everything I could get my hands on while it was apart … all hoses, new radiator, starter, injector harness … etc … etc. The whole project went surprisingly well and except for several sheared bolts on the water rail was rather enjoyable (I am lucky enough to have an air-conditioned garage and that REALLY helped :smiley:)

Next my power steering pump started leaking so it was either $250 for a rebuilt unit or $12 for a seal kit. I opted for the kit and other than getting at the inner pump mounting bolt that worked out fine. Of course then my P/S RACK started to leak at the top of the tower and I had to pull it and install a new/rebuilt unit.

Next I noticed a vibration in my driveshaft when I had it up on a lift replacing my catalytic converter (more on that later). So I took it home and put the rear of the car up on jacks, removed the driveshaft and had it rebalanced. While I had the car up I decided to pull out the gas tank to repair a pesky leak on the very top near the vent tube … and why not change the diff fluid while I’m at it.

All of this worked out well and the car now runs, smells, and handles like a dream … EXCEPT …

I have a check engine light Code 4 (O2 sensor system full rich) that I can’t figure out !

As previously mentioned I replaced the font catalytic converter and installed a new O2 sensor. no change. So I had the emissions checked at the tailpipe and it did in fact show a slight over rich situation.

So I guess this tells me that the O2 sensor is actually doing it’s job and telling the ECU (engine control unit) that there really is a rich fuel situation and therefore it’s not a false alarm.

So why is it running rich ? That’s the question. Since the ECU controls everything there’s no adjustments that I know of.

Any ideas ?? The crazy thing about these early computer cars is that they have just enough smarts to tell you something’s wrong but not enough to tell you what it is. The later XJ40s (1990 on) are a little better but still nothing compared to modern cars with OBDII

I don’t know how helpful this is, but in my experience a small vacuum leak can fool the o2 sensor into requesting a longer (richer) fuel spray. I used to get ff23 (94MY) [rich] before I found I had a slight air leak at the intake manifold gasket.

How is your mass airflow sensor? Is it still the original?

Thanks Larry …

When I rebuilt the top of the engine I was VERY careful about the gaskets and hoses but you never know so I’ll check everything again.

Other things I’ve considered …

  1. coolant temperature sensor … replaced with new unit

  2. engine temperature sensor … new unit

  3. injectors … removed and thoroughly cleaned internally, new O rings

  4. mass airflow sensor … removed, dissembled and cleaned internal element

  5. inspected spark plugs … all a nice tan color

Joe …

Yes, it’s still the original unit.

I haven’t checked in the Haynes manual or online if they can be tested.

It’s strange that you should mention that. When I took my car over to Jose at the “muffler/everything else” shop to have my CAT replaced I explained my CEL code 4 problem and told him all the things I thought could be the problem. Jose (being extremely car savvy and a man of very few words) just shook his head and pointed at the MAF. Hmmm

One of the way to test the MAF is to start the engine, let it idle then unplug the airflow sensor. If the engine keeps idling then the sensor needs replacing. Mine did that and that’s when I bought one on ebay for a '94 Land Rover Range Rover. I payed around $90.

How did you know that the MAF from a Range Rover would fit? And what year of Range Rover was it off of?

Would a leaking fuel pressure regulator be a culprit?

1 Like

Steven, I simply looked at the pictures and the connector. Looked exactly the same as mine. I typed in a search box 1994 Land Rover Range Rover Mass Airflow Sensor. I created a topic about it.
Still available on ebay:

I don’t know if there’s a difference between the earlier and later airflow sensors in our cars. It fit perfectly in mine and working well.

Robin, I guess it won’t hurt Grooveman to check the FPR. He cleaned the injectors but I don’t know when he replaced the FPR if ever.

Gents …

I followed Joe’s troubleshooting tip and unplugged the MAF while the engine was idling and it immediately shut off, so no help there.

The car still has the original fuel pressure regulator. I did apply vacuum to the regulator and it held so I assume that means the diaphrapm isn’t ruptured. Also when I removed the vacuum line from the regulator and idled the car for a while no fuel was detectable at the nipple where the vacuum line attaches.

Joe’s MAF on EBay looks very interesting, and the price is certainly right. I’ll do some detective work on capability with my 3.6L engine.

I tested the MAF multiple times and the engine didn’t always die. Try to clear the code and do the test again right after the code appears.

How is your EGR valve? I don’t know if it’d mess up the air/fuel ratio.

Joe …

I’ll clear the code and try the MAF test again. The MAF for sale on EBay has 5 pin connectors, mine has 6 so who knows if it would work on my 3.6L engine ?

My '89 doesn’t have an EGR valve or an AIR system.

Here’s one with a 6 pin connector and it’s way cheaper too. But you decide.

Well this is interesting …

Today I decided to pull the connector to the MAF on my car to make sure it was clean and getting a good connection, and appears that it is. But I did discover that even though my original MAF has 6 male pins on the connector, the harness side of the plug only has 5 sockets and one of the male pins just goes into an empty space … interesting.

So it appears that gives me a lot more options on replacing the MAF since most only have 5 pins.

1 Like

Yesterday (12/30/2019) I got a CEL with a FF23 code. Fuel supply, rich exhaust indicated. Darn! I don’t know if the EVAP system could have something to do with it. I’ve never serviced it.

Reply moved to the FF23 Thread :astonished: