Runs great for 30-min then loses power

New to car. 1969 S2 OTS. Starts and runs great, but……after about 30-min, starts to lose power. Seems like it’s not getting fuel (gas pedal to floor and won’t rev above 2k). I’ve searched the forum, but haven’t found an explanation. Hoping someone here can provide some advice as to what it might be or where to start the diagnosis.

Thanks in advance for any help.

Have you tried removing the gas cap when the problem occurs? The cap on a 1969 should be vented with a small hole. If the vent is clogged, a partial vacuum forms in the tank as gas is used and the pump finds it harder and harder to operate. If, when you undo the cap, there is a whoosh as air goes into the tank you’ve found it. If you can’t see a vent hole in the cap, someone may have fitted a cap from a later car (1970 on) which used a different method to vent the tank.

2 Likes

Thanks David for a quick response! Pulled the cap and cleaned out the vent hole after reading your post. It’s been sitting in the garage for an hour so couldn’t do a “woosh” test. Will try it out first thing tomorrow. Thanks again for the help.

If you have the paper filter in your sediment bowl clean it the dirt will be on the inside of the filter so it won’t be visible in the bowl.

Rotor arm?

does it. make a difference whether the tank is full or closer to empty?

Here is one of many threads in the Jag-Lovers archives with symptoms similar to what you experienced:

Paul

Have you checked the ‘sock’ at the end of the fuel pick up tube in the gas tank? It might be full of junk or collapsed.

for reference:

I experenced a similar problem with my '68 a number of years ago. It had a very fine disc shaped brass filter (about 1.5" round) that fit in the top of the fuel bowl that had over the years become clogged. This was a factory install in lieu of a paper filter which as the years go by may have been fitted on your car in addition to the brass one. If you have the brass one look at the light through it and see what shape it’s in.

Thanks all for the help. I started with the article you referenced Paul but still having issues. It’s strange because it runs great, then loses power (but motor still sounds appropriate), then after I stop (with motor running) all is fine again. No stalling, no weird noises. No problem starting.

Replaced the fuel filter, pulled the pickup tube from gas tank (screen was collapsed so cleaned/straightened), replaced the ignition coil, cleaned fuel cap vent. Nothing has changed.

Terry will try your suggestion and report back.

Thanks again everyone!

Ben
I have owned my 69 since 1982
I had that fuel starvation at one time and the fix was a vented gas cap.
Fast forward 20 years, my car would run flawlessly for 30 minutes than the stuttering would start. I thought it was fuel starvation, i bench tested my electric fuel pump and found that every 10 x I tested it it would not turn on unless I tapped it with a hammer, I thought i solved the issue. But no dice. I did notice that when I drove it the coil got very very hot, not normal
What ended up being the issue was a very bad corroded wire attached near the voltage regulator
Plus all my electrical wires on the Alternator harness were as crispy as bacon
I replaced the harness and that was the issue
When there is a bad wire, it causes the resistance to back up, causing the coil to work harder and it overheats, in 30 minutes, causing it to malfunction
Word of caution, , label all the old connections , because the folks I bought the harness from had the voltage regulator wires mis labeled notice where the negative wire was in the pic
Good luck, it solved my issue 100%





Add images

FYI, Woodboatchick had a similar issue and this was what solved the problem

Thanks Rock. So you replaced the alternator harness? Curious as to how long that took as I hate rewiring projects (who doesn’t).

First check the condition of what you got
Check the terminal near the voltage regulator
Clean them up
As per one of my pics you can see one wire the copper was green with oxidation, that was the wire that was barely attached, it fell apart in my hands
The alternator harness is 90% accessible until those two wires that enter the bulkhead into the interior.
Just label everything

Kev - ordered rotor (would be an easy/ cheap fix)

Bill - behaves the same whether close to empty or full

Does your coil get super hot?, Then check all your connections and clean them up

I had a 1968 Fiat Spider that did that. Turns out it was rust in the gas tank. It would run great until the rust particles clogged the fuel filter, an in-line steel can type. After letting the far sit for a while enough rust would settle off of the filter that the car would run OK until the filter clogged again. I figured it out by replacing the filter with a clear plastic case variety that showed the rust accumulation. The cure was to pull the gas tank, clean it and coat the interior with the gas tank sealer sold by J. C. Whitney (remember them?).

Something else to check is the coil.

1 Like

Another possibility is a bad condenser if you are still using points in your distributor. If so you might want to consider a Pertronix upgrade.

Many of the rotor arms currently available are poor quality and short through the rivet when they get hot, hence the fine when cold scenario. I have found the best to be the red ones from “The Distributor Doctor”.

1 Like

Check all the wires first to make sure the connections are clean. A bad ground will also create a issue
There are other members here that can better explain the following.
Learn how to use a volt meter to test for continuity, it’s not that hard

I am not too much of a electrical expert but as I read up on it I started to understand that if the current does not flow freely, it will cause items maybe the coil or other things to work harder until it heats up n falters, when my coil cooled down it worked , until same thing happened