Series II Starter Won't Stop

I have a 1970 Series II FHC with factory A/C (the ignition switch is attached to the lockable steering column). The face of the switch shows O, I, II, III. I recently had the starter rebuilt. Also installed a new starter cable. Just tested the starter. It cranks the engine (had the coil wire off so it wouldn’t start) but when I turned the key to O the starter continued cranking. Had to disconnect the battery to shut down the starter. I noticed there is a small purple wire connected to the bottom of the ignition switch that is severed (I think I broke it getting the A/C evaporator out of the car).

Is that broken wire my problem? Never had an issue with the starter or ignition switch previously.

Checked the forum and couldn’t find anything quite like what I’m dealing with.

The purple wire is for a buzzer that’s not used on your car. It’s possible the solenoid was put together without its spring. You may have to remove the starter to fix this. But first disconnect the small wire from the starter and reconnect the battery. If it cranks the solenoid is stuck.

Thanks for your quick reply! There are two small wires on the solenoid. One wire has a loop connection and it goes on the same solenoid terminal as the starter cable. The other wire has a spade connector and hooks to a spade terminal on the side of the solenoid. Are you referring to the spade terminal wire?

Interesting, you might want to see how it’s wired it could be it “latched” itself on. In other words, when the solenoid closed it applied power to itself to keep itself on. It may be the wiring of the solenoid is your problem.

Remove all but the big wires (one in/one out) from the solenoid, try and if it runs the rebuild wasn’t so good.
If it’s quiet it may indeed be something latching on, it could be a miswired relay perhaps?

Thanks everyone, for your recommendations. I tried them plus several more suggested by a knowledgeable friend. Bottom line - when all the leads are connected as they should be, the starter still won’t stop engaging unless the battery cable is pulled. The last time I tried was interesting - with all leads hooked up I turned the key and the starter just clicked - as if the solenoid wasn’t engaging. I then turned the key off and turned the key back on to start - starter engaged and the engine cranked as it should, but again would not stop cranking until I pulled the battery wire. I’m beginning to think I have an issue with the rebuilt solenoid. Am I looking at this incorrectly?

Is the ignition key “springing back” to the run position?

Unplug the white/red wire that runs between the starter relay and the solenoid. If the starter stops running, the problem is either the ignition switch or the starter relay. If it doesn’t the solenoid is bad.

Problem solved! I ran all the tests suggested by Forum participants and everything pointed to the solenoid. Removed the newly rebuilt starter/solenoid and took it back to the rebuilder. They tested it and said, “That solenoid is really messed up”! They offered to replace it with a new solenoid from another vendor and have it ready the next day. Sure enough, I picked it up the next day, installed it, and it performs as expected.

Thanks to everyone for your suggestions - they pinpointed the problem and saved me from taking the starter/solenoid in and out several times.