Series III speed sensor behavior?

I have a 1983 US-specification XJ6, which was retrofitted by the original owner with a contemporary Jaguar XJ6 manual transmission. When that later failed, a shop replaced with a Tremec 5-speed for me, and adjusted the speedometer drive ratio with a mechanical ratio adjuster between the transmission and the speed sender. When the drive gear in the transmission failed, my current repair shop proposed replacing the sender with a magnetic induction sender on the drive shaft, and an electronic ratio adjuster from Dakota Digital. This works fine for the speedometer/odometer and the cruise control, but the trip computer is only counting about 25% of the pulses.

The wiring diagram indicates that the signal goes to all three loads, plus the (now disconnected) service interval counter. (Unplugging the service interval counter, for which I no longer have the lamp in any case, made no difference.) Unplugging the speedometer and cruise control made no difference, so it is probably not a question of too many loads on the Dakota Digital output.

We tried several trip computers, and all behave the same.

The shop and I each tried spinning the stock sensor (both the one which was working, and a brand new one), with +12 VDC applied to the input wire and the case grounded, but did not see a signal, so we could not establish what the signal should look like, to compare to the Dakota Digital output.

  1. What is the expected waveform? If a square wave, what is the voltage and duty cycle?
  2. Is there a way to bench-test the stock sender, with an oscilloscope on the output? Does it require a particular load resistance? How must it be grounded? (Grounding the case does not seem to work.)

The original transducer produced a signal that fitted the speedo, Earl - were converted in an interface unit to suit the trip computer. The magnetic induction sender and electronic ratio adjuster were tuned to suit the speedo and the cruise control - but the interface unit doesn’t like it…

Either because the waveform/frequency is incompatible with that, but suitable for the speedo and cruise control. Which doesn’t need an interface unit; the speedo and cruise are analogue and the induction sender signal can be tuned to suit - while the trip computer is digital. Or your interface unit has failed?

xj6 85 Sov Europe (UK/NZ)

I can see an item “358 Interface Unit” listed in the “key” for the circuit diagram of my copy of Edition 2 of the Series III Service Manual, but cannot find it on the circuit diagram, although there is an unlabelled box next to box 357, the trip computer. That box, however, seems to be connected to the gray (G) wire, whereas the yellow (Y) wire is connected directly to the speed sender., says that yellow is the signal from the speed sender, meaning it is coming directly to the trip computer. The interface unit is modifying the fuel signal from the ECU, and does not see the speed signal. As I noted, my unit is recording fuel consumption correctly, but missing 75% of speed pulses, so the interface unit is not the issue.

Do you know the correct shape, duty cycle, and amplitude for the speed pulses?

I got it a bit backwards, William. You are right apart from the ‘grey’ wire - ‘G’ is for green in the wiring diagram. Powering the trip computer, interface unit and the transducer - with a green wire also powering the speedo. The yellow (Y) wire does indeed connect the transducer to both the trip computer and the speedo - giving speed/distances to both…

So we are back to the respective waveforms of the original transducer and the Dakota Digital - and the frequency. Main point here is that the waveform is likely immaterial for the speedo and cruise control - it’s more a matter of power inputs? Which may be adjusted by the Dakota - while the trip computer might be more discerning…

It’s awkward, and strange, that you could get no signal from the tested transducers - and I do not have the data on the output waves. Nor on the Dakota outfit - but obviously the trip computer does no like it. Giving, as I understand correct ‘fuel’, but incorrect ‘ins’, ‘ave’, ‘dist’ and ‘avsp’? Implying, as you say, that the interface unit is working…

Sorry I cannot be of much help…

xj6 85 Sov Europe (UK/NZ0