Spluttering/hesitation issue on light throttle

Hi all,

I’m having quite an annoying issue with my XJ40 (3.2).

Recently it has started to splutter/jerk when cruising only when above 2100rpm.

I initially suspected it was a transmission issue as it seemed to be at its worst in drive and at 50mph (I.e TC lockup).

It however also does it in 2 and 3 at lower speeds when above 2100rpm. It can be felt as a jerking/bucking, like the engine is dying and restarting quickly. It doesn’t do it when accelerating, or when no throttle is applied, just when I’m trying to maintain speed.

I have changed the TPS as the VCM displayed a Fuel Fail 17. I’d hoped this was the issue, and while it improved other things (throttle smoothness, MPG), this issue still persists.

I think it’s fuel system related, so this is my main area of investigation at the moment.

I plan to take off and clean the MAF, and change the fuel filter.

Wondering if anyone has experienced similar or has any other ideas?

I’m not ruling out ignition but I think it sounds more like fuel at the moment.

Thanks in advance!

Try changing the rotor, these things can be problematic as they have a resistor built into them. The Maf plug can also act up if the connection is dirty - in fact I’d check the connection at the coolant sensor too.
Coolant sensor and rotor replacement is a fairly cheap fix as both of these components can affect running quite dramatically if out of whack.

1 Like

Fuel filter, pump.
Rule out MAF by disconnecting it and driving.

Thanks for the advice! I’ll have a look at those, I wasn’t aware about the resistor in the rotor arm.

On the MAF, I tried unplugging (whilst running) and the engine died.

I’ve ordered a rotor arm and fuel filter so will replace those (not a bad idea even if it isn’t the issue).

One new piece of info:

When I unplugged the MAF, a check engine light appeared. I had assumed it was due to the MAF but it won’t clear when I disconnect the battery for a while.

I checked the code “Fuel Fail 16”, which seems to suggest that it’s the Air Inlet temp sensor. Could this cause a similar issue? I read somewhere that it’s meant to retard the ignition under light load. I will of course remove, clean and also check the plug contacts, but don’t think I’ll have a chance until the weekend.

The temp sensor is usually part of the MAF. I don’t think it’s the problem.

I think mine is separate (there is a sensor sticking out of the elbow just after the MAF)?

I can’t seem to get the code to clear though, I’ve disconnected the battery for several minutes but Check Engine light won’t go out.

Good to know that it doesn’t sound like the issue though. I’ll need to take it off and clean it in hopes that the CEL will go out though!

Actually, it could be the problem, but try the filter first.

Make sure that you reconnected the MAF plug correctly.

Daniel - I don’t know the year of your car but on the later XJ40s (93 & 94 MY at least) you do not have to disconnect the battery to clear codes. You can, with the key turned to position I, pull fuse #9 (3 amp) in the center console fuse panel and wait a few seconds (until the needles on the tach and speedo drop below zero). Then replace the fuse.

Thanks all, I will probably take off/clean the MAF first as I’m still waiting on the filter.

Will confirm the plug has been reconnected properly at that point too.

Should the car run if the MAF is disconnected? I suspected it would go to a default map but it seemed to die. I didn’t try to restart the car at that point though.

Mike - thanks for the tip. My car is a 94 and that would sure save the hassle of having to put the radio code in eveey time!

I took off and cleaned the MAF + the connectors to all sensors but no change.

I’ll change the filter this weekend probably.

One thing I noticed is that the fuel filler drain pipe was blocked, so the fuel filler area was full of water. Perhaps water has been mixing with the fuel? Would that cause symptoms like this? I haven’t put fuel in it for a while, so hadn’t noticed.

Doubt it. It would not be load related.

Did the problem come up just after starting or did it take a while? Maybe the tank ventilation is clooged and a vacuum can build up. On old cars this can happen, don’t know enough about modern fuel systems.

Ah that makes sense, the load part is the most confusing thing about it.

It happens all the time, when I’ve just been driving for 30 seconds or if I’ve been driving for 30 mins. It’s really quite annoying because I can’t work out the logic of what’s happening.

I took the rotor arm off today and there was a lot of rust on the distributor shaft and inside the arm, I cleaned it up but still no luck. I’ll fit the new one when it comes but not sure it will be the cause unless the resistor is playing up.

Fuel filter is the prime suspect at the moment.

The fuel filter idea is because when accelerating you get load enrichment that may temporarily help and at low rpm or not enough throttle you don’t use enough fuel…
Normally the car should adjust its mixture according to the lambda signal which needs to get hot to work. And stumbling at constant high power demand is a classic fuel issue symptom. Just as you think. I hope the filter fixes it, otherwise you need to dive into it a bit more.

Default map or die: The cars I know go to a default map and don’t die. Then again if the car is dying the MAF clearly works and works correctly. But that’d mean the default map (if there is one on the XJ40) doesn’t run. I don’t know these cars (yet?) so I can’t help further.

It could, if…I once had a vehicle that would start and idle OK but when you tried to get up to speed it was no bueno. Mind you this was when the temps were below freezing with a carbureted engine but adding a couple bottles of Heet to the fuel tank solved the problem. Add a bottle or two of Heet (or similar) to the fuel tank and see what happens.

Or run regular gas with ethanol, same result.

I’m using E10 (10% Ethanol), so I guess that would rule that out?

I really hope the fuel filter resolves it!

Always check you fuel pressure at fuel rail.

I’m going to change the filter in a couple of hours, fingers crossed…

Failing that I’ll check the fuel pressure (need to buy a gauge). Does the XJ40 have a lift pump as well as an inline pump? Is there an in tank strainer too?