Start problem, sdd coding issue

Hi guys,
I’m back in Jaguar ownership after a few years and it hasn’t taken long to find a problem ha ha.

I’ve written a long post which is really a timeline of what I’ve done and what’s been happening.

  • I have bought, fully charged and fitted a Yuasa 4yr 95ah 850a battery
  • I replaced the fob battery with a new Duracell
  • I have removed the isolater and battery monitor entirely but the problem remains and the car won’t start at all without it so I’ve refitted it for now.
    *I have included all relevant detail regarding the wiring.
  • the isolater fob IS controlling the car, probably coded into the ecu (this is where I’m stuck)
  • I have read the codes many times but there are none
  • I have ordered Jaguar sdd software and will be using it asap

So with the above facts stated,here we go.

I recently (Saturday) bought an 07 xkr,test drive and 100mile drive home was faultless,however a few days later it wouldn’t start.

The car is fitted with a Chinese (no name that I can read) remote controlled battery isolater. The battery negative goes to the isolating relay & from the relay to original ground (he ground is perfect). The relay is powered from the battery +. It has a tiny aerial on the side that is controlled by the isolater fob.
There is also a battery monitor fitted which has 4 wires coming from it. 2 simply go to the battery terminals, the other 2 bridge across a shunt fitted in the ground lead that goes to the relay.

I have removed both of these entirely but the ignition will not turn on without the isolater in the circuit.
The monitor should be disregarded, it’s not the problem.

I have been double locking the car and pressing the off button on the isolater fob for the few days I’ve had it just to see how it works really. I understand it’s not a good idea to keep effectively disconnecting the battery to avoid current spikes etc.

Normal operation seems to be pressing the on button on the isolater fob,the indicators and sidelights (markers) flash,unlock car and press start.

Tuesday morning I pressed the isolater fob “on” and the indicators flashed but the sidelights stayed on,I unlocked the car pressed start but the ignition didn’t come on. I tried the sequence a few more times and eventually the sidelights flashed & the car started. I turned it off and it wouldn’t start again (sidelights stayed on). Turned it off again,isolated itand waited a while and it started again.

I disconnected the isolater entirely and bolted the battery - to it’s ground. The car will unlock but is dead other than the interior lights,horn and CD player seeming to have power.
I reconnected the isolater and pressed the isolater fob on, unlocked the car and it started. I turned it off to try it again,the indicators flashed but the sidelights stayed on and it won’t start again.

So I double locked the car and left it isolated again for 10 mins,pressed the isolater fob on, the sidelights and indicators flashed, I unlocked the car and it started, so I went for a drive, checked for faults but there were none, I went home,turned the car off but left it unlocked, an hour and 45mins later the sidelights came on by themselves (light stalk set to off). I opened the unlocked door, tried the start button and it was dead, I pressed the isolater fob off and on again, the indicators and sidelights flashed and the car started.

Yesterday evening (4pm) I locked it with one press of the key fob as an experiment, I left it for 4hrs, unlocked the car, pressed start and it started.

I’ve just been out (11am) and it started again.

Double locking the car must put an ecu into a state where the isolater fob must be used before the car key fob works normally. I do not have to press off on the isolater fob, after double locking it, it seems to automatically drop into a sleep mode that requires use of the isolater fob.
I can only assume the isolater was fitted for long term storage without access to power. Who knows.

The fact that the indicators and sidelights flash prove it is linked, maybe coded into the cars security. It must have developed a fault or glitch.

I have mentioned all the wiring involved, everything else is standard.

The monitor won’t be part of the problem nor will the shunt. The readings on the monitor should be disregarded as they were the old batteries state of charge.

I’m really asking 2 things:

  1. Has anyone ever had one of these type of things linked with the car security.
  2. Can anyone that’s got Jaguar sdd experience point me to where I should be looking.

Thanks for taking the time to read this post.