Strange Tach behaviour and engine issues after distributor service '85 HE v12

Hello all!

I purchased my first Jaguar about 2 months ago, a 1985 XJ12 Sovereign with the Lucas CEI, it hadn’t been used more than an occasional start every year for 10 years until I purchased it.
The car has during my ownership always suffered from a rough and hunting idle, but performed well at higher revs, fuel consumption has been around 15l/100km which I understand is quite normal.
To try and combat any future issues with rough idle, and to catch up on general maintenance I decided to change spark plugs, and to take out the distributor in order to clean it and service the advance weights.

After reinstalling the distributor I went to start the car, first start was easy, but I noticed a very rough idle, something which I had hoped would be solved by setting the timing. When I then revved the car to 3000 I noticed a very strange behaviour with the tach, it would climb to 2500 rpm then immediately drop down to 2000 rpm after which it would climb like normal; when decelerating the engine the tach follows the same pattern, down to 2000 then up to 2500 to continue down. Here is a short video: https://www.youtube.com/watch?v=s1VeIH2dcC4 Keep in mind that I am accelerating at a steady pace. I apologize if the video is unclear.

When I purchased the car one lead from the ignition amp was disconnected, the previous owner reassured me and said that it was an extra lead which wasn’t necessary. I believe that this is the lead from the ignition amp to the tach, it is the white male bullet connector from the Lucas AB-14 amp. I have no idea how the tach is getting a signal if this lead isn’t connected as I understand that the tach source is the ignition.

I am not sure if the tach problem is related to the distributor service as I believe I might have noticed this issue earlier, for about a month the tach has barely moved when shifting from 2nd to 3rd, even though the revs drop noticeably, the shift occurs at around 2000-2500rpm, so the rev range as the issues occurring now.

Hopefully some of you might have experienced a similar behaviour or have some ideas/solutions!

Kind regards!
Rasmus

The tach signal wire is tri-colored: white/slate with a blue spiral.

Just on GP’s I’d inspect that wire carefully…but my gut tells me the problem lies elsewhere. I’ll do some mulling

Cheers
DD

1 Like

Hi Rasmus and welcome.

First of all, download and read “The Book”.
http://www.jag-lovers.org/xj-s/book/Jaguar.html

My thoughts on the issue:
Revisit your distributor according to the book.
Change the GM module of the ignition amplifier
Check your throttle setting and bushings

Best of luck!

1 Like

Need more clarification on your ignition set-up, Rasmus - and the tacho gets its signal from coil neg…

The AB14 is connected to the coil by two wires; white to coil ‘+’ - co-connected with the white wire from the ignition switch. And a white/black to coil ‘-’, together with a white/slate/blue (to the tacho) and a white/black to the ECU. The AB14 is connected to the distributor by a double wire, with a connector at the amp end.

If this is not the case - clarify; you may just have a faulty tacho…

Pending clarification of your ignition set-up; your tacho problem is likely unrelated to the uneven idle. That the engine idles at all, implies that the ignition is working - what is your idle rpms…?

The V12 is of course, by nature, dead smooth at any rpms. The easy suspect is ‘crossed’ plug leads - are you dead sure of your ignition sequence? It’s incredibly easy to get it wrong, and particularly with a V12. Causing easily observable idle unevenness, but not readily detectable with higher idle - the loss of power is not necessarily obvious. Crossfiring due to a cracked dist lid or some rotor fault may give similar symptoms

Secondly; have you checked compression? Uneven, or lost compression in one or more cylinder will again cause similar symptoms as above.

Thirdly; one or more injectors faulty - clogged or inoperative for various reasons - again similar symptoms.

None of these factors will cause abnormal tacho response, (tacho not following engine rpms) - tacho is tied to the ign amp…

There may be more exotic causes for uneven idle - but the mention ones are obvious starting points.

Frank
xj6 85 Sov Europe (UK/NZ)

1 Like

Rasmus,
In addition to the excellent advice already provided, I recommend that you clean all the contacts on the electrical connectors in the engine bay and at the tachometer so that you know that they are good.

Paul

1 Like

Hi again, and thank you for all the replies, I must say the response has been above all expectations!

Thanks for the clarification Doug, I thought that the bullet contact from the ign. amp was the lead to the tach, I’ll go ahead and revisit the contacts, especially the one to the tach!

Thank you Aristides! New GM amp. purchased, will be installed tomorrow, throttle settings were already checked and adjusted, and new bushing installed on the one side where it was missing, I will order the teflon bushings which were reviewed on the youtube channel ‘Living with a classic’ for both sides.
I used the book when initially servicing the distributor, however if the problem persists after further diagnosis I’ll go ahead and lift it out again.

Great post Frank, as I wrote above I thought the wire from the amp was the tach lead, but I’ll revisit the ign. connections! The ignition is connected according to your description, I’ll post some images down below, but they are quite unclear so I’ll take some more when I continue working on the car tomorrow. My idle RPM is about 1500, cold, I haven’t taken it up to operating temperature to see if the idle returns to normal again since I’d like to make sure there isn’t any risk of damage due to bad timing etc. Previously the idle has been around 750 when hot, and 1400 when cold, but hunting and ‘lumpy’.
I glanced over the plug wires today and they all seemed to be connected correctly according to firing order, I’ll double check them tomorrow, distributor lid is in good condition, as is the rotor.
I have to admit it was an oversight of me not to check the compression when I replaced the plugs, but if the problem persists I’ll check the compression on all 12.
The car had been sitting for 10 years prior to me purchasing it, however was only run for 10 minutes before I filled the tank with fresh gas, fuel filter was replaced the day after purchase and looked normal. I have added some injector cleaning additives to the fuel in order to try and clean any debris of the injectors, however this hasn’t made any change, if problem persists I’ll go ahead and remove them and replace the filters, all injectors click when running.

Thanks Paul, I’ll go ahead and do that! Thanks again for the tips and suggestions!

I suspect the tach signal may have something to do with the spade connector on the coil, when I purchased the car the previous owner evidently has had some issues with this connector, the spade connector was already replaced and poorly fitted, resulting in it falling off when I had to unplug it from the coil, I then replaced the spade connector myself about a month ago, which coincides with the tach problems; I’ll go ahead and try to get a better connection with a new spade connector for the tach wire tomorrow. Other wires to the coil have also started to peel, I will clean the connectors and cut the wires to a new fresh point with good insulation.

Images as referenced above:

Picture of inside of the amp, new will be installed tomorrow.
Picture of male bullet connector.
Picture ca. 1 month old of the coil, I have since replaced the spade connector (red in this image), you can see wires with cracked insulation.

1 Like

**
There were, reportedly, some unspecified issues with the V12 HE idle, Rasmus…

For that reason, or whatever, the ignition advance system is rather complicated - and differs between the US and ‘European’ set-ups. The latter uses an oil temp switch combined with a changeover valve to alter between manifold and ported vacuum.

The US uses a vacuum operated ‘dump’ valve in conjunction with a vacuum delay valve to control distributor vacuum advance. There is also a throttle vacuum switch - which likely relates to fuelling.

I have no idea whether this relates to your idle problem - so the initial suggestions may be more relevant. And the US system seems relevant for dynamic situations rather than steady idle. he European set-up, however, seem to imply a different vacuum source to the distributor based on engine temp…

As an aside; a ‘quirk’ of the V12 is that while the distributor is driven by the common crankshaft, the vacum is taken from one bank. Likewise, engine temp data, including the temp gauge, is also taken from one bank. As the two banks share the same radiator, sort of mixing the two flows; they have separate thermostat thermostats…

All of which means that the engine management system operates the two banks identically - the banks may have different actual requirements. Ie, the ECU operates the banks as they were identical, which they certainly should be; anomalies may exist, and may be pertinent?

Frank
xj6 85 Sov Europe (UK/NZ)
**

Hi again!

Managed to set the ignition last night to 18*, ignition started way off, but after moving the distributor five or six times I finally got it correct when turning the set screw fully. Engine idle seemed high at first, but after readjusting the butterfly-valves and setting the AAV idle I’ve gotten it down to about 850 when warm; so something is still possibly leaking, I’ll have to continue investigating.

I believe the idle issues might be related to fuelling, when removing the vacuum line from the B-bank FPR there is a strong smell of gasoline, I don’t have a vacuum tester so I can’t test whether the FPR holds vacuum, however I still think fuel in the vacuum line warrants a new FPR. I’ll check fuel pressure tomorrow.

I also replaced the ignition amp with a new GM generic amp and redid the tach and amp wires to coil, tach seems to be working fine but now I have an issue with the car suddenly dying when driving.
I first believed this could be related to the ignition cable to the coil, so I redid the connection without any difference.

The problem occurs when I am driving at aprox. 60-70km/h light throttle, sometimes the engine seems to be gurgling, or struggling for half a second before it shuts off, other times it simply just stops working. Throwing the transmission into N and cranking starts it right up, then into drive for another 2-3 minutes before the issue occurs again. At first I believed this could be a problem with the vacuum advance, since it only occurs when the throttle is very slightly pressed for a duration of time (high ported vacuum), or when I let of the throttle for a few seconds then press it lightly, ie. cruising at 70 km/h. I disconnected the vacuum advance but there was no difference. The car was imported from the UK, and has the dump valve and delay system installed. Could also be that the fuel pump intermittently just stops, however it would be supremely unlucky for a fuel pump issue to occur at the same time as repairing part of the ignition system, and I’d expect for the engine to loose performance or struggle for a second or two at least, like when you run out of fuel.

I am thinking that it might be an issue with the ignition amp, I still have the old amp and will try installing it tomorrow and see if anything changes.

I took this short video of the issue, I was just going to record and hopefully catch it acting up, but pretty much as soon as I pressed rec the engine died so I apologise for the short clip. Coolant light is unrelated as I had low coolant at the time of recording due to slight leak.


Here is also an image of the coil, the connections have been redone inside the covers, and I am yet to find a suitable cover for the tach spade.

Let me know if you have any thoughts on possible causes for the sudden dying.

Kind regards!
Rasmus

I went through the identical experience several years ago on my 1986 series 3 XJ6. I’m still not certain which component failed, but I can tell you that replacing the fuel pump , coil, and ignition amplifier as well as removing and refitting the distributor cap several times after cleaning the rotor contacts finally cured the problem. Car has been running fine ever since.

Mine was behaving like that a couple years ago. The problem was very intermittent. Long story short, after eliminating various suspects and possibilities, replacing the pick-up in the distributor solved the problem. It was a guess derived from desperation; I got lucky

But in your case it could just as easily be a poor connection somewhere, or perhaps the “dreaded white wire” which is known to give problems

Cheers
DD

Just use shrink tubing.

Or, you can buy covers (and assorted other wiring goodies) from British Auto Wiring and other specialty vendors

Cheers
DD

Rasmus,

The fuel smell on the vacuum hose of the FPR means that it needs to be replaced, and as soon as possible.

On your video you can see the Tach zeroing in a split second… It clearly looses its signal, and with it the ignition as well.
Change the GM module, me thinks it’s a primary suspect.
Check also the famous shielded cable from the Ignition Amp as suggested (details in the book)
With the engine running, wiggle any ignition related cables you can see with the hope that you can replicate the problem.

Good luck.

**
You are aware the 18 deg is set with vacuum ‘off’ and the engine at 3000 rpms - for the V12 HE, Rasmus?

With ‘set screw’ do you mean a vernier adjustment? In which case; the vernier should be set midpoint, and the dist itself moved to crudely set timing. The vernier then used for fine setting…

**
If fuel is leaking out of the fuel pressure regulator’s vacuum hose; regulator is defective - to be replaced. Mere smell of petrol is inconclusive - removing the vacuum hose just increases fuel pressure. Which in itself may cause fuel smell from some other source…

Vacuum testing is irrelevant for the fuel pressure regulator is irrelevant - only a fuel pressure test will confirm FPR state…

You have 3 wires on coil ‘+’ - nominally there should be only 2…?

**
This is odd - the ‘UK’ and ‘European’ did not use these items? They used a changeover valve - which switches vacuum source based on engine temp. Given by an oil temp switch - no delay…so…?

The items mentioned is the US set-up. But do the items you have actually work?

**
As Aristides say; the tacho drops to zero, indicating loss of ignition - hence the engine instantly quits.

Which is likely caused by a failed ign amp, or indeed a broken amp wire. As suggested by Aristides; do the ‘wire shaking test’ with the engine idling. No matter which wire is shaken, there should be no engine reaction. If it does react; you have touched a tender point - to be examined…

Other sources of engine cut-up; ign switch problem. To test; jumpwire from batt ‘+’ to coil ‘+’ and see if the problem persists.

That this occurs with the engine cold(?); both (or either) the ign module and the coil is temp sensitive. When you changed the ign module; did you use the heat conducting paste?

That said; watch the tacho whenever the engine falters/quits. Whenever the tacho, otherwise working properly does not follow engine rpms; the ignition is failing. Tacho dropping to zero as the engine quits is a sure sign of ignition failure - to be pursued…

Frank
xj6 85 Sov Europe (UK/NZ)
**

I am, ignition is currently 18* with vacuum advance disconnected @ 3000rpm.

I believe ign. amp overheating is the issue, I used high thermal conductivity heatsink paste when installing, so I believe the new amp is defective.

Kind regards!
Rasmus

Hello again!

I believe the ignition problem is related to a heat sensitive ign. amp, the new amp works fine until the engine gets to operating temperature, then just quits. When installing the old amp the same issues as before show up, however the amp never completely gives up. I will inquire with the shop who sold the amp and hopefully I will get a replacement unit. This despite using high quality high thermal conductivity cpu heatsink paste.
Wire shaking didn’t change anything so connections seem fine.

New ordered, arriving tomorrow!

Will keep you posted on new developments!
Rasmus

Is the module a GM part?
I had an aftermarket version that failed a week after installation…

**
There is something odd in your coil set-up, Rasmus…

You indicate ‘to second coil’ as to the three wires at coil ‘+’ - and at the same time refer to the AB14 ign amp. Ie; do you have two coils fitted?

The ‘two coil’ set-up was used on the earlier versions, but with a different type ign amplifier. Coupled in parallel it would draw twice the single coil current through the amplifier - and it would in all likelihood overload and overheat the AB14 module…

I emphatically suggest you discard one of the coils - and see what happens. The later, CE, ignition system, using the AB14 uses one coil - and on some coils; an external resistor was also fitted to reduce coil current. Current flows through the module to ground, inevitably causing heating - and the more current the more heat…

You do not mention the uneven idle in your later posts - is it still present?

This uneven idle is most likely unrelated to the ignition failure - which is likely, as you say, related to the ign module failure…

Frank
xj6 85 Sov Europe (UK/NZ)
**

Frank, no.

The V12 HE with Lucas CEI did indeed use two coils and never used a ballast resistor.

The two-coil arrangement is often discarded in favor of a single, higher capacity coil.

It couldn’t hurt to disconnect the secondary coil just to see if anything the changes; perhaps a defect there is affecting the rest of the system.

The HE V12 will run fine on the single primary coil until 3000 rpm or so, and then start objecting.

Cheers
DD

So I was able to get a replacement amp but the problem still persists, measuring temperature with an IR thermometer shows 80c after shutdown on the amp and 55 on the intake manifold, so the problem is an overheating amp. I was unable to get an oem GM amp, the aftermarket amp is a ‘Standard LX301’.

Any ideas on what might cause the amp overheating?

Next step would otherwise be to import an AC delco amp from the US, since I can’t find one for a reasonable price nearby, of course risking to blow a third ignition amp.

Regarding the uneven idle, the idle seems better with a new amp, I am yet to replace the fpr and check fuel pressure so it could still be related to that. I am mainly focusing on getting the ignition to work at all.
Secondary coil is measuring aprox. 1.1 ohm. When running with secondary coil unplugged there is no difference, i didn’t rev it past 3000rpm, however the amp still died about as quickly as with both coils connected.
Primary coil primary resistance is 0.5ohm, secondary resistance 6.12k ohm.

Thanks for the help so far!
Rasmus

I think I light have a clue as to the origin of the issue, about a month ago I had an issue with what turned out to be an exhaust leak from the intake manifold on B6 (PO had removed air injection system allowing exhaust leaking out of the intake manifold). When trying to diagnose this issue I was instructed to pull the B6 plug wire with engine running, of course the leak then stopped and I was able to find diagnose the leak. It is around this time I believe the tach started acting up, however i never noticed this until trying to set the timing and revving the engine to 3000rpm, which was the initial reason for this thread.
I suspect that pulling the plug wire damaged the first amp, and that some issue is causing the new amps to overheat.

I measured the press fit diode in the corner of the amp case, with it measuring .44 forward drop and ol reverse drop.

When changing spark plugs I did measure the plug wire resistance, with all normal measurements.