Sudden stall on XJ6 then no spark

Hi Mike, The rotor is ok. I’ve actually got a couple. I also did an unorthodox check of the rotor this morning by fixing it in place to the underside of the cap (cap off distributor), contacting the centre - with a small gap to the lead contact - imitating it’s normal configuration with an ignition lead and plug on the end. I cranked the car over and the plug fired repeatedly. So the rotor is ok. I’m really at a loss to explain what’s going on. I thought there might be an intermittent wiring fault. Every so often I crank it and it sounds like it’s going to start but doesn’t, so there must be a few weak sparks getting through.

This suggests to me that there’s still a chance that the reluctor isn’t in sync with the rotor. I presume I could see a signal on one of the wires from the distributor to the amp to see when the reluctor was lined up with the pickup coil.

Would my amp perform erratically if the zener diode and condenser in the ignition amp module were failing?

I put the old cap back on (It’s cracked and the contacts are worn). It behaves the same way as the new one. No spark on ignition leads.

Anyway - back to bashing my head against the wall, or the Jaguar bonnet!

The Zener is meant to allow high voltage at coil ‘-’, coil ‘ringing’, to go to ‘ground’, Lloyd -preventing amp damage. If shorting or leaking at 12V, it will delay or prevent the amp to break coil ‘-’ ground - causing bad or no spark. Similar with the condenser; shorting to ground - ditto…

However, as you have strong blue spark on coil center lead; the amplifier is(!) functioning as it should - the spark is just not distributed to the plugs! Also; if the injectors are clicking (check), it confirms ‘some’ amp action - as does the flickering of the test lamp when cranking. It shows that the amp ‘makes’ and ‘breaks’ coil ‘-’ ground as it should. Though in principle, the test lamp should be connected between coil ‘-’ and ground…:slight_smile:

Your test with the rotor was ingenious, but as Mike points out; the rotor problem he mentions involves the rotor being grounded to the dist axle - with the rotor detached this won’t happen.

You being ingenious; repeat the test but with the rotor’s dist axle connection grounded. Even this may not be conclusive - rotor is a tight fit on the axle…

It all implies the rotor does not connect the coil center lead to the plug wires - for some obscure reason. As you rotated the dist while cranking; you move the dist plug lead tabs relative to the rotor - which means that misalignment of the rotor, firing between the tabs seems to be eliminated. However, have you actually checked, with the engine at TDC, a reluctor tooth is aligned with the pick-up - and the rotor is aligned with a dist lid tab? In principle, the dist turning test should be done very slowly, or in small steps - but you know that. And confirm that the rotor and cap is(!) fitting properly…:slight_smile:

I’m just as bewildered as you - so there is something that eludes us, though you seems to have covered all the ground. As usual; it will be a simple fix - once found. Again; the sole problem only seems to be no connection between coil center lead and the plug leads…

As an aside; once you have got sparks at the plugs; don be too surprised if the engine won’t run. your manipulations may have interfered both with ign timing and the ignition sequence. And may have to be rechecked…

xj6 85 Sov Europe (UK/NZ)

Hi Frank, I may have misled you earlier - I’m now thinking that the spark isn’t strong enough. I more than tripled the spark plug gap and attached the plug to the coil lead. It sparks, but it’s more yellow than blue. I purchased a coil as mentioned - that didn’t make any difference. I also tried another new coil I had lying around Same result. However, the spark is weaker than I thought. I might remind myself of how strong a good spark is by checking the spark on another car at home. If the coil has been changed out (once or twice!). Maybe there is an issue with the Zener diode or condenser?

I did adjust set the engine at TDC and the reluctor tooth did line up with the pickup. I may double check I was lining up the right mark as there was surface rust on the crank pulley.

Just to confirm, I definitely saw flickering of the test light while cranking, although possibly the amp is not producing a clean signal. I may look at replacing the zener diode and condenser, although I’m not sure what the specs of those are. More research.

Thanks, Lloyd

Hi Lloyd…have you correctly measured the resistance of your spark plug leads and most important coil to center cap (king lead)…i dont just mean a continuity test but…correct resistance depending on type of leads your useing…Steve

Shouldn’t matter much. And the king lead seems to work

Hi Steve, Yes. All good. Changed out the coil lead just to be sure. They ranged from 8kohm to 13kohm.

Spark is definitely weak. Maybe that’s why I can see it in the coil lead and not in the spark plug leads. I initially monitored spark with a timing light, but that doesn’t show you its strength. If it is a weak spark, I’m not sure why, as I’ve changed the coil, the coil lead to the plug, the distributor cap, the rotor, the pick-up, the amplifier. I haven’t changed the zener diode or the condenser. Of course, one of the new parts could be faulty too.

Try a coil with something less…a lot less, hopefully…than 16k ohm secondary resistance

I like the Lucas DLB170 if they’re still available

In V12 circles it’s common to ditch the condenser. Only takes a few minutes to try. Given what you’ve been through I say give it a whirl


Replaced the coil - now has around 10kohm. Got a second hand distributor and amplifier from my helpful jaguar shop to use as a test. Haven’t isolated which component is faulty, but I do have a really healthy spark from coil to distributor through cap. It makes a nice crack! I’ve also noticed that the injectors are not making a noise. I’ve put a test light on one of the injector leads whilst cranking - no signal. So another dimension to my problem. A week or so back, I had a pin hole leak in a heater hose at the back of the engine. The radiator low warning light came on (temp was fine) and there was a high-pressure squirt coming from the hose. I’m wondering whether moisture has seeped into the harness connectors directly below it and caused a short somewhere. ECU? The trigger wire from the coil has a signal until it disappears into the harness on the manifold (including the bullet connector).

Try with the ignition on, make & break the signal wire, every third time it will click.

The plot thickens, Lloyd…:slight_smile: You really need to connect a spare spark plug to a plug lead - just to monitor actual plug sparking. And of course (needless reminder) ensure that the plug body is securely grounded - without plug ground there is no spark. Actually, a healthy spark from the coil center lead can jump more than an inch…:slight_smile:

As ign amp works, so should the injectors. Do you have clicks from the injetors if the bullet connector is repeatedly disconnected connected? With ign ‘on’ you should have 12V in the coil side of the bullet. Ohm, with ign ‘off’ the ECU side of the bullet. I don’t know expected values, but if you read ‘0’ ohms you have a short - if ‘1’; you likely have a break. Anything in between likely means the wire is properly connected to the ECU. Any fault with the ECU itself is in a different ballpark - unlikely caused by a coolant leak, as is wire shorting…

Sorting out the lack of spark to the plugs is the first step - even a the weak spark should reach the plugs. Sorting out the cause of the weak spark with the original set-up; first try replacing the ign amp module…

xj6 85 Sov Europe (UK/NZ)

Some progress. In all, I’ve found three connections that were bad (including two coil wires). Touch them and they literally fall apart, which is what happened. Probably taking them on and off has sped up the ageing process. After getting a nice healthy spark from the coil, I still had trouble starting. There was a bad connection in the wire for the fuel injection and no ticking sound. I traced it to a dud relay. I had a similar one spare so I fitted that and hooray, I managed to fire up the engine. Initially there was a loud knocking sound which scared the pants off me. Never heard that before. It runs, but on the first three cylinders only. I discovered that the rear three injectors aren’t clicking and there is no signal with the test light on those. There is on the other three of course. So somewhere there’s another bad connection. Frank - just saw your post come up as I’m typing, which I’ll read now.

1 Like

Thanks Frank. I should add that the plug spark is now a very healthy one.

As i mentioned previously re crimp all connections and solder…50year old crimp connections arnt great…Steve

Power to the injectors are delivered via the injector resistor pack, Lloyd, one resistor for each injector - the ECU just grounds the injectors for opening them.

Check that there is 12V on both wires at each injector connector. If not; check connections at the injector pack - square box at the right hand front side in the engine compartment. It’s ‘unlikely’ to be an ECU problem…

xj6 85 Sov Europe (UK/NZ)

I saw on the wiring diagram that there are two brown/slate wires on the wiring, one for the first 3 and one for the last 3 injectors, respectively. so one of those wires is obviously making a bad connection with the resistor pack. There’s power on both of them at the connector to the resistor pack. I wiggled the connector and the car started idling smoothly. Almost there! However, it appears that as I move the unit, the revs waver, so there’s a bad connection somewhere. Anyway - much closer to solving this. Thanks again.

Tidied up the connector to the resistor pack. Car running nicely now. I think I had multiple failures, at least two, that lead to my problem. A weak coil with a broken wire. Other dodgy connections were likely exacerbated by handling them. The relay for the fuel injection on the firewall had definitely failed. My original amp unit was fine. However, I put my distributor back in with the new pick-up (same cap). It ran a little rougher, so I’m thinking the replacement pick-up is probably not a good unit. Hard to know. Thank you Frank and David for being patient and providing invaluable help. One of the best things I’ve found about this forum is that by simply putting into words what the issues are, it allows you to stop and think logically through it yourself. Thanks again. Lloyd


We are helpless without symptom description, Lloyd. And without owner actions and feedback, little progress can be made - compliments well earned After all, the ‘man’ on the spot, in this case you, has to do all the work…:slight_smile:

It is not a criticism, but you were a bit hasty - which cost money and time. Only with hindsight, one can usually find the proper way it should have been done. But, with old cars; the ‘fiddle factor’ has tendency to play up - complicating matters, as it did in this case…:slight_smile:

Job well done…!

xj6 85 Sov Europe (UK/NZ)

1 Like

Fair comment. Wasted money on the pickup. I guess I can use it as a spare.

That’s certainly, one thing I’ve learned after spending more than I needed to, Frank. So often, there’s a simple cheap fix rather than just replacing stuff. These forums are a real “cost-avoidance” treasure trove.