The main issues with my 1985 XJ6 Series 3

Hello Jag. experts
Please I need help to resolve this issue once and for all.
Kindly watch my video closely to see the behavior of the temperature sensors with connector on and off.

Hope your experience will assist me get rid of this trouble.

Thanks

I’m not 100 percent but it looks like that switch is newer
1st put another one in
Then follow the ground side of it the wires look pretty cut up
Go to mass air flow sensor and throttle body any plug undone or broken?

Many switches have changed both used and new, but same problem, just received this new switch from SNG UK. It was due to the problem that led to cut the wire as part of the diagnostic to check the issue. On the AFM, all things are plug, in fact this issue is draining me a lot and the reason I wanted to change the fuel system from injection to Carb.

It’s an ecm, ground loop or temp sensor or cut wire shorting the loop

The issue was there before I cut the wire to experiment and check what would happened, when that wire is not joined, fire stay, when wire is joined, engine goes off

**
Have you actually measured the resistance over the temp sensor, Michael? It should very precisely with temp…

The ECU applies voltage to one wire, and reads the result on the other - adjusting fueling accordingly. Ie, the sensor relates to the ECU, no other item is involved. Basically, with the plug disconnected the resistance is high (infinite) - indicating a very cold engine; rich fueling. Plugged in, the resistance depends on engine temp - at 88C the resistance is about 265 ohm; at 80C its 325 ohm.

In the video, you do not give engine temp; if the engine is cold it will/may run with the plug disconnected, but will seriously overfuel with the engine hot - and may then quit. As your symptoms, quitting when the sensor is connected, it raises questions of engine temp, and indeed the resistance in sensor, in the video test. Both should be checked - preferably with an infrared thermometer and a multimeter…

It’s indeed a puzzling situation. The main point is that the fueling changes when the sensor is plugged in, which actually is as it should be - but that the engine quits means mixture is outside engine running temp at the time.

You say the result is the same with other sensors used? You do not explain what testing was done when the wires were cut (and reconnected?)…?

With the sensor unplugged and ign ‘off’’; measure resistance over the two pins on the connector - it should be around 2 Kohm. This is really a test of the wiring from the plug to the ECU rather than a test of the ECU - but anomalies may be interesting. It may be an ECU fault, but as I seem to recall - you have tried swapping it with no change…?

Frank
xj6 86 Sov Europe (UK/NZ)
**

That’s what I was getting at
The wires resistance .
Good luck
Gtjoey1314

Good news!!!

Today after spending over 4hrs again checking and testing, I decided open relays one after one.
The first relay opened had a wire connected to it from same relay, I disconnected it, my helper an older auto electrician since 1940s l, I called him to come and see so we would know where to reconnect. He came to check it and what he did was to connect the sensor wires and asked me to start the car, I started the car and boooommm the engine started normal and fire stayed which has solved the engine issued I have video earlier.

On Monday I will move the car to see the performance.

Attach a photo of the connection that caused the whole issue

**
Where is this relay, Michael?

There should be no relay associated with the coolant temp sensor/ECU - but you can’t argue with success…:slight_smile:

Well done…

Frank
xj6 85 Sov Europe (UK/NZ)
**

The attach photo with the red cover that has a wire connecting from the side

That’s the diode pack!

OK, then that was where has given the headache on my 85 XJ6 for the past 4yrs and have been changing parts here and there to fix what might be the car until yesterday around 4:30pm when we sat trying to solve the issue.

Thanks God this car is in peace now

Finally! So it runs well now? That’s great news.

Dave, I got a dead battery afterwards so the drive test will tomorrow

**
No, David - wrong place and far too many wires connected…

I have a sneaky suspicion that it’s ‘something’ relating to an alarm/immobilising set-up, or whatever. It is certainly not an original Jaguar fitting. All of which could explain his drawn out problems…

Frank
xj6 85 Sov Europe (UK/NZ)
**
**

1 Like

I second that, Michael…:slight_smile:

However, I think this is some aftermarket addition - likely (part of) an alarm/immobilizer set-up. Which, when failing, cause mysterious symptoms. It is certainly not a relay - and while actions taken may be a permanent solution; it leaves some doubt…

The advise given on testing the CTS circuitry still stands, adding that one of connector wires should show 12V with ign ‘on’ - the other should show ground…

Frank
xj6 85 Sov Europe (UK/NZ)
**

It says PEKTRON on top, is red, has a red socket and original wiring. It is in the proper location. The other wires you see in the background are from the fuel pump relay and that other one. You’re correct that it is certainly not a relay.

It’s the diode pack… DAC 1861. Google it and you’ll agree it’s not some aftermarket item.

David

Exactly, one of the wires shows positive and the other(bk) is the ground

That red socket is an original and not aftermarket, I don’t much about the auto electrical and the reason a referred it relay - thanks all for correcting me there.

**
Your absolutely right, David - I plumb forgot that the early version had a more complicated ‘diode pack’ set-up…

As this set-up incorporates both the main and the fuel relay; it sort of explains some aspects of the problem - but not really how the CTS got involved. Possibly, at some time, the diode pack malfunctioned, and an attempt of bypassing the problem was made - instead of replacing the diode pack? Which may not have been available anyway…?

In which case; remedial action now taken may be ‘incomplete’ - and may cause some downstream repercussions…?

Thank’s David

Frank
xj6 85 Sov Europe (UK/NZ)
**