[v12-engine] marelli diagnostic socket help

I am working ignition issues on a '90 XJS with Marelli ignition,
and I have noticed in the electrical diagrams for this car, that
the Marelli wiring includes a diagnostic socket that has four
pins. Two of these are: trigger signal to one of the coils and a
ground. The other two are shown as directly routed to pins on the

Does anyone on the list know what these are for, or how they are

Mike, 90 XJS Convertible, a work in progress
Lakewood, OH, United States
–Posted using Jag-lovers JagFORUM [forums.jag-lovers.org]–

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !

Its crazy… I can’t find any information on this diagnostic socket, either. Looks like it’s been a question for near 20yrzzzz!!!

What ya do and where to go!?

As I explained to you in the other thread where you posted similar question, the diagnostic socket without a PDU is useless.

Here is the location on the 6.0L


For the early car, in could be in the engine bay, by the ABS pump

EDIT: here is the “other” thread and my response, in case someone does not cross-read the XJS and V12 sub-forums:

Between having no onboard diagnostics at all and having OBD I, the XJ-S was fitted for a coupla years with connectors for something Jaguar called a Portable Diagnostics Unit or PDU. The Jaguar mechs said PDU stood for “Pretty Damn Useless”, and within a decade or so it’s likely most of those units were thrown away. I think a couple of them might have been picked up by members here, not so much for utility as for curiosity. I’m not sure if this is what the connector you’re looking at is about, though. Perhaps Marelli has its own diagnostic scheme.

Hah! Both our replies popped up within a second or so of one another!

My standing offer to all Jag Lovers… bring your XJS to New Hampshire and we’ll hook it up to my PDU and see what the heck it does!

Hahahaha… Just one of those things I guess…

I will go back to the other thread (I didn’t see it because the hood of my XJS swallowed me today) but I “solved” my problem. I found the “Diagnostic Socket”. It’s the large black connector looking thing right behind the master cylinder and reservoir on the LH side. Big ol thing.

I saw a Marelli amp on eBay a few weeks ago and it was new, so cheap, I just bought it. I replaced the one on the car today due to the fact that my problems were showing up in the tach which is associated with the A Bank parts of the ignition system. Worked BUT, I have a feeling that the reason for the failure of the original amp had something to do with an electrical issue within the wiring of the ignition system under the hood somewhere. Although I wish I didn’t have to I’m compelled to go tomorrow morning and completely cut open the ignition wiring as far back as I can go in the engine back and see what I find. I learned today, and with the ED that it’s actually not so complicated a thing after all. At least not physically. Electrically, well that’s a whole other story…
The wiring didn’t look old, dried or cracked at all. The plug associated with the A Bank was a little corroded and unclean, I cleaned it up and plugged it back into the new amp. Then, rewired the plug for the CTS just because and built a new plug for it.

Idle smoothed right out - but as I’ve been told, if it’s toooo good to be true, it’s prolly not true.

I appreciate y’alls responses. Let me go back and see if I can find the replies to the other old post I woke up on the issue.

Deep bow, many thanks.

I’m getting ZERO alerts from the Forum… That’s odd

The socket may be next to useless for diagnostic purposes but l found it to be a very convenient source of engine speed signal for my aftermarket TCU.

It is NOT. When you set up the account, you must have disabled them.
This is a screenshot of my preferences (I hate them!), check yours:

I have/had… I’m just by chance seeing this as I am searching, looking for tips on replacing the shielded wire OR reusing the old but with a new spade connection… Anywho, my settings basically tell me the notifications are enabled… I look again. But really! Thank you