Very faint injector (noid light) signal

Hi all,
I’m the new owner of a very interesting '89 XJ-S. The car has been kept in great conditon and is quite stunning to say the least. Black on black with later model wheels, hidden driver lights behind the grille, AJ6 Superenhanced ECU, quad throttle bodies and a free-flow exhaust. Who knows what else. The previous owner unfortunately is no longer with us so I can’t confirm any additional mods.

The car came to me through a brief owner who had purchased the car at the gentleman’s estate sale. He was told the car ran when parked 7 or 8 years ago. He proceeded to go through the entire fuel system including boiling the tank, running new lines and of course a new pump, filter and accumulator.

He was unable to get a spark and or injector signal and gave up on the project. That’s when the car to me.

I immediately started checking all the usual stuff including Crank Sensor and Speed Sensor. They Ohm out fine. I have access to a 1988 (Marelli car as well) parts car. I’ve swapped out the power modules, Marelli and Lucas ECUs. I still don’t get any spark and or injector signal. That’s until after some more fiddling with wires and ECUs, etc, I went to crank it and I could tell the engine tried to fire due to the starter slowing down and speeding up. Almost as if it were out of time. I hooked up my light to a spark plug lead and installed a noid light in one of the injector plugs and lo and behold I had something. A very, very faint signal on the noid light but a signal none the less. After some more fiddling, I lost both signals and am back to square one. I was able to reproduce the low signal / crank situation once more back have not since.

Can anyone shed some light as to what may be going on?

Many thanks,

Mark
Columbus, OH

Hi Mark-
Its probably the crank or speed sensor. Testing with an ohm meter is not definitive. See my post (it’s about #14) on this thread for my thoughts.

regards
Bob

that is a SPECIAL V12 engine , it has 4 four throttle bodies, on a custom made inlet manifolds?

wonder what else could be modded , like pistons, camshafts,?

what does the exhaust look like ?
also the starter slowing and speeding up could mean internal engine damage or DROPPED valve seats! compression test time!
ron
ron

Mark,
AFAIK you can’t test the Crankshaft Position Sensor (CPS) with a multimeter. The procedure to test it with an oscilloscope is in the XJ-S Repair Operations Manual (ROM). The ROM is a very helpful document to own and use.

We just had another new member who had a similar no start problem and a new CPS fixed it. Check out the posts from the past few weeks and you will find the thread that just happened.

Paul

I wonder if you can test it with a multimeter if it has a Hz measurement feature? Both of my, relatively inexpensive, meters have such a thing and can easily pick up 50Hz mains frequency where it shouldn’t be. You should be able to register a frequency pulse when cranking the engine if the sensor is working correctly.

Well, my .02. As I have ranted before, is that anyone who owns Marelli car should own an o-scope. It’s not like they are crazy expensive. Then one can stop guessing and t-shoot exactly as the Rom prescribes

Oscilloscope Multimeter 2.0 Update,LIUMY Professional LED Handheld Oscilloscope Multimeter with 200ksps A/D Automatic Waveform Capture Function,DC/AC Voltage/Current Test,HD Display with Backlight https://www.amazon.com/dp/B071F1H3PG/ref=cm_sw_r_cp_api_i_IoRZDbMCNGWW4

Bob,
Thank you for posting this link for an $80 oscilloscope. I wonder, if I am a good boy for the next month or so maybe Santa Claus will bring me one for Christmas?

Paul

1 Like

Hi. Thanks for all the info. Yes, I just purchased an Amazon oscilloscope as well. I’m going to give that a shot.

Hi Paul!
Let’s hope Santa sees this! Way better than another pair of socks.
Disclaimer: I have not personally used this unit, but I have one that is similar in price that works fine, bought it years ago. This one looks a bit fancier.
Bob

Hi. What I meant by starter slowing and speeding up, is that the engine was trying to fire. When I don’t have any signal to the injectors and spark plug leads, the starter whine is constant…motor just turning over. When I have spark and fuel injector signal, I could tell some, perhaps all cylinders where firing or at least trying to fire. I smelled and physically saw some smoke (combustion from old gas?) emanating from right side exhaust. Engine never fired though.

If you’ve been a little bit too naughty for Santa at $80, I have one of these, eBay oscilloscope . Quite a bit cheaper. I’ve not used it to check a CPS but I can’t see why it wouldn’t work.

Many years ago, Gene Holtzclaw had similar problem.

This must be one of the longest threads on Marelli no-start problems. Here:

While I agree with everyone who says that the first suspect is the CPS, if the history of the car is unknown and someone else has messed with it, ohming wiring is good but not sufficient.

As you can see in the discussion with over 250 replies, Gene finally solved the problem by discovering that whoever worked on his car before, tried to repair the engine harness. In the process, s/he reversed the polarity of the CPS connector (next to the B-bank thermostat housing).

I think you need to check that connector and rule out the possibility that signal wires are shorted or reversed with the ground wire.

To repeat what others in this discussion already stated – the ONLY way a Marelli car will not start (I trust you’ve checked fuel delivery and have confirmed that spraying starting fluid in the intakes does not change anything) is if the ECU does not get signal from the CPS and/or flywheel sensors.

Good luck!

I have stated repeatedly that if you haven’t replaced the crank sensors on your marelli car, do that first. They are service items. These cars have two separate systems that don’t communicate with each other. The marelli ecu sends a speed signal to the Lucas
ecu, but the Lucas ecu has no way of getting any true communication that the marelli ignition isn’t firing. The sensor at the rear gives crank speed information, and the sensor at the front gives a timing signal. These things are magnetic. Time and heat are
their demise

Hi received my Amazon Oscilloscope yesterday and proceeded to check the CPS and Speed sensor. They both check out fine. After plugging them back in, the car went back into “trying to start mode” but sure does sound like something is off. I took a short video of the engine cranking for you guys to check out. Please give me your thoughts. The engine sounds like it’s struggling with ignition timing.
Here is the Youtube link…

Is the battery healthy and fully charged? To me, this seemed like very, very slow cranking speed.
I memory serves me right, you need to be able to reach at least 200-250 rmp with the starter, and the voltage should NOT drop below ca 10.5 V.

This is #1. #2, I did not hear sputtering in this 7 second video, what happens if you spray starting fluid in the intakes, does it want to “catch”?

#3. To repeat what everyone else said already – if the CPS and the flywheel sensors are providing signal to the Marelli ECU (passenger footwell – I am presuming you checked there for signal?), you’ll have spark on at least one of the banks. Given that you’ve swapped amplifiers and coils from another car, the odds that there are multiple faulty components are very low.

PS I I noticed that you say “after plugging them back in”. How did you check the sensors with the scope? They should be connected and you or assistant should be cranking to pick up the signal.

Not too long ago, we covered this very topic here:

I did that too. Both of mine checked out fine too. Although, during the whole process, I also checked the air gap. My air gaps were way wide. But there is no adjustment. It is a extremely tedious process to close the air gap. I accomplished it by breaking a
1" wide fine file, and shortening it to a piece about 2" long. I would measure the gap, remove the sensor, file the mounting boss, then reinstall, measure file etc. In my opinion, getting the gap to .020-.025 is the goal. The rear one was pretty straight forward.
The front, not so much as the 3 timing fingers in the damper aren’t completely even with each other. So, I filed until I got the closest one to .020, and the other two were .027 and .034 if I remember correctly. I understand the oscope, yet I am not so sure
it is a correct gauge of condition. The oscope shows wave function in ohms? yet I found that the magnet loses it ability to generate voltage. That’s why a airplane magneto is a service item. I had posted that the “sensors” don’t sense anything other than how
often ferrous metal passes by it. It creates voltage in AC. About .06 volts on the rear at cranking, but I had heard as much as 80 volts at 7000 rpm. I was soundly ridiculed, so I quit the discussion.

I bought a low milage marelli car that wouldn’t run. The shop that took it in threw 6k I’m parts and labor at it without getting it to run. The owner left the shop holding the baby so to speak, and I bought it from the shop for 1400 in as is condition.

Feel free to call me at 864-915-3703. Gene. Don’t worry, I love this stuff. I have 6 Jags, and am about to start a build on a 7th.

Oh boy. Looks like I goofed. I check the sensors after unplugging them. I ran the test probes into the sensor’s connector and cranked the engine over. I even took a video. They are linked here.


and here

Not really. The videos do show patterns that would indicate that the sensors pick up signal.
Now, connect the probe to the correct pins at the ECU and confirm that the signal gets there.

I am certain your no-start issue will be wiring related

I installed a new Crank Position Sensor but I still encounter the same issues. I get a 12V reading at the injectors when turning the ignition to ON. When I crank, it drops to about 9.7
V. I’ve charged the battery and even hooked another good battery up in parallel to boost Amperage. The engine still sounds like it’s not spinning fast enough and still voltage drops into the 9 V region. The NOID light flash is very, very dim. Is my starter bad? Robbing too much amperage?

I’ve sprayed Starter Fluid into all 4 throttle bodies but the engine still wont fire. Spark is there but it’s yellow and not a sharp blue spark.

I’ve checked and clean the grounds back by the battery. Anywhere else I should be looking? Perhaps the Pos lead to the ignition switch?

Thanks for the help.

Mark