Well crap! Check engine, poor performance, engine error drrrrr

Ok so i changed the oil, checked and cleaned my partial load nipple, and adjusted my throttle cable (it was reading 82% at full pedal and i got it to 100%. I didn’t test drive it since i had 2 other cars to work on, and then today i went to go to a friend’s house, it was 95deg so i thought the ac would be nice, and it fired up and ran smoothly. I pulled out onto the road and after about 2 min it started shuddering and the rpms went to about 500 at idle and the poor vehicle performance and engine error, and then the check engine lights came on. I brought it home and did a quick code read and a quick look online and im leaning towards the ecm. However i really didn’t look too hard yet. Could doing the battery cables together thing make a difference? Could it be from me adjusting the throttle? Part of me thinks maybe and the other part thinks its coincidental. Heres a screenshot of the codes.

I thought this was a G-rated, family website…:grimacing:

1 Like

Oh I forgot to say that it would all of a sudden run smoothly at standard idle, then shudder, drop rpm and flash warnings. Oh and i think its the slowest ive ever driven the car! Lol

Just went out and swapped my 2 ignition modules around and cleared the codes. I started the car and it ran smoothly for about 30 seconds then started shuddering and throwing lights again. I checked and they’re the same codes so the codes didn’t follow the modules. Drrrrr. So i guess my next thought will be my first thought of the ecm.

GO back to the original throttle set up…
Also did you SPRAY the throttle body with cleaner?
If so and you didnt put it on a rag and wiped gently you will wipe out the throttle body sensor with the cleaner!
All those years were sensitive to it.
Its your position of your butterfly or sensor not reading and its shutting the mixtures down.
If you pull the battery terminals and wait 20 minutes it will reset again but then crap out…
Im hoping you have done tensioners, chains , coil packs and pumps before this as well?

1 Like

I didn’t spray anything anywhere. I am planning on trying to put the throttle back where it was, just to see, but it’ll probably be at least Tuesday before i can try. Chains and tensioners were done. Coils and fuel pumps haven’t. Kinda odd that it stays with those codes for the one set of cylinders if it would be a pump. Also kinda odd for 4 coils to fail overnight. Which did lead me to the thought that it was my tinkering, however it didn’t do this before when i had checked and adjusted when i first got it.

The throttle position relay and sensor play a big roll.
Ive seen coil packs just crap out sending you into limp mode.
Believe me Ive been down the road with Aston Vanquish v12, its a 3 day process.
Put the butterfly back to where it was, disconnect the battery and then reset. Try it, Its igniting so pumps are good, Its limping so you have spark but I think you goofed up the settings. 97 98 99 had wash down issues with fuel loading at idle and quick turn off, by adjusting that butterfly, you might be doing the same.
good luck and report back.

1 Like

I actually readjusted my throttle and i took it for a drive. It went into engine fault 3times for about 3 seconds each time, but drove awesomely apart from that. I decided to take it to go get my allergy shots, stopping for a car wash on the way. It did do engine error sitting in the wash, but then performed flawlessly all the way to the drs! Wooohooooo! I thought. Then i went to leave after being there almost an hour and it fired right up and ran smoothly! Of course then i came to a stop sign and drrrrrrrrr! Engine fault, reduced vehicle performance and EXTREMELY low acceleration hit. I tried to pull out and it took some effort. I decided to just try to get home and needless to say, the faults never went away. There were times that i would get a big grumbling at the rear and then if i tried pushing it, she would buck and kick so i would back off and it would smooth out a little. I was able to get up to 55mph, but if i slowed down too far it was back to pedal car acceleration. I pulled my ecu and didn’t really see anything, but i have had boards go out without showing anything on other cars. I may just pull the ecu back out and send it for check and repair. I may also try just swapping in my spare throttle body just to see

Your almost there…look when you repositioned the throttle body it was fine BUT It heated up or cycled and died correct?
You should get a sequence which ones for instnce 351 is coil 1 cylinder 352 and so on if you have 352 353 354 they are done unless you have a mouse in the wire house.
You have engine wash down issues as well with that year or two.
Start with the coil packs.
good luck

1 Like

The codes I’m getting are 1638, 0352,0353,0355, and 0358. I was leaning towards the ecu mainly because of previous posts from others with the same, or other bank similar codes that ended up being the ecu. Also due to swapping the ignition modules and the same codes staying. Coils are definitely on my list of things that i had planned on doing, so i will look into proper jaguar oem too

Yep, as a matter of peace of mind , change the coils, bad coils will throw off other codes is a cycle as it all interacts.
When you switched left to right banks, the numbers should have flipped to the opposite plugs, make sense?

Good luck

1 Like

I actually did swap coils from my spare engine, and my spare throttle body this morning. Plugs look ok so i didn’t put in new yet, but did flip a couple of the plugs to different cylinders. Cleared my codes and fired it up. Ran pretty good, and i drove it around the “neighborhood” which is about a mile and a half look and 40ish mph, with 2 stop signs. It ran great for about 2 laps then the engine fault and poor vehicle performance popped up again showing all the same codes. It would be extremely coincidental to have bad coils in the spare motor in the same place i would think.

Your almost there
Put new coils and plugs
Your cats are good and not plugged correct?
You have to was the load in the cylinders and o2 sensors
Run it now again are you losing power?
If not run and clear run and clear
Then put new coils and plugs
Report back but that’s where we are going
Ecu crap out but your doing the simple stuff that even still it will work
Run it now then clear it

As far as i know of my cats are clear. Not sure i quite understand exactly what you mean. When i switched my ignition modules, the codes stayed the same, they didn’t follow the module. When i switched the coils, it didn’t change. When i swapped in coils from my other engine and changed the plugs around some, the codes stayed exactly the same as the original codes. Yes i loose power when i get the faults. It drops down to next to no real forward motion when stopped and very low acceleration when driving. I will try running it and clearing codes a few more times, we’ll see how that does first.

The power lose is the coil packs …
Run one more time for a bit, if it limps again, go home clear out the codes…THEN DONT RUN IT TILL YOU CHANGE THE COIL PACKS AND PLUGS.
You should be fine, then if it comes back which I doubt , swap out the ecu.

1 Like

Ok so I went out again not long after the last post and had the same problem. While I appreciate the sage advice, and am planning on replacing my coils and plugs in the near future, I decided to go with my gut and the cheaper option and sent the computer out to be checked and refurbished. A few days after I sent it out I got confirmation that they did find that the electrolyte had leaked out of the capacitors and had also corroded some of the board traces. When I had opened it up I didn’t see anything, however they said under a magnifying glass it was very clear. They shipped it back and of course USPS fumbled the ball! When I went to tracking it had originally said that it would be here by last Monday. Then it went into “in transit” for 2 days. Drrrrrrrr. I finally messaged the seller and had them talk to USPS. A little later I checked and it said that it arrived back in Texas on the other side of them smh. Then it went back to “in transit” argh! Long story short, it finally arrived today! It said out for delivery at 7:41, the mail came at 10, and then the same lady came back at 4:15pm to drop it off. Smh! I installed it and fired it up. It ran perfectly. I let it warm completely up, and then went for a 30mi drive. No issues! Then I came home and let it sit for an hour and then went out for a nice long drive again. Not even a hiccup! So hopefully that was my main problem! We’ll see!

All the electronics on high end cars now-a-days means this is not just a Jag problem.

1 Like

Oh believe me I know that for a fact. Even “older\anitque\classic” modern cars get frustrating! I say it that way since a 1995 is considered and antique now :flushed::flushed::flushed::flushed::flushed::flushed::flushed:. My nephew was trying to work on his 98 civic and called me several times to try and help. Of course he’s over 500mi away and holding the phone to the car and saying “you hear what I mean?” Drrrrrr. Then one of his friends said the old " if you’ve got air, fuel, and spark it’ll run". To which I told him that unfortunately while that’s generally true, in a computer controlled car, if a sensor doesn’t read something right, or if the computer doesn’t adjust something right, it’ll never run. “. He said oh ok. Needless to say after he threw a lot of money at the car he took it to " someone”, all of their friends are “master mechanics” :roll_eyes::roll_eyes::roll_eyes:. And they found that the head gasket was bad, and that at some point it had gone out before so the person FLIPPED IT OVER to make it good again! ARGH!

You have simply moved the pins in the tps socket when adjusting the cable this really sounds like your throttle body. The tps gets brittle from heat try a new one !

In my trouble shooting I did put on my spare throttle body, as well as swapping around the ignition modules and swapping around the plugs and coils. I then pulled my coils off my spare engine, even though all of my coils read the same. Nothing changed. I sent my ecu out and had it repaired and it has been running perfectly for most of a week now.