Wipers not working

(G-mac) #1

My wipers gave up the ghost in the middle of a rain shower.now they dont work in any setting. Ive cleaned the dash switch, earth and connectors at the motor. There is current to the switch and current getting to the motor in both settings. The motor works when given a jump from the battery. What could be the issue? Is there a relay in series 1 models? The fuses are fine. I was having issues when them all winter as they wouldnt turn off for at least 5 minutes after i switched them off.

Interchangeabilty wiper motor
(Robin O'Connor) #2

Just because they look good doesn’t mean they are :slight_smile: this was the fuse in my S11 for the wipers, found it yesterday.
Just because you are seeing VOLTAGE at the motor does not mean the fuse can supply the current required, as you have already worked out the motor is good to go.

(G-mac) #3

My heater fans are working. The fuse isnt the problem.

(Robin O'Connor) #4

Fair enough, a bit of a conundrum then.

(KrissMotors) #5

Failure to park immediately suggests a problem with the physical park/run switch in the motor. If this switch doesn’t “catch” properly, the motor will continue to run until it eventually catches, power is shut off, or the motor overheats and the thermostatic circuit breaker shuts it off (if you have such a breaker on your XJ). Could be dirt, poor contact with the metal park/run switch arm, or some related alignment issue. You will have to disassemble the motor to check this. Suggest you also clean out dirt/grime in the motor that may be causing excessive resistance and thus intermittent failures especially under heavy loads when raining.

Putting high current into the motor to make it run also suggest excessive internal resistance (dirt, poor contacts, etc).

I don’t think Series 1 has the delay relay, only the Series 3. The delay setup has 7 wires coming into the wiper switch (this includes the chassis ground). The no-delay wiring (same as the MK2) only has six wires at the switch.

Wiper circuits are complicated; just delivering power at the switch/motor doesn’t mean the motor will turn. This sounds like an internal motor issue, not a vehicle electrical system problem.

(Frank Andersen) #6

**
Did you check for power at the switch itself…?

The wiring is rather complicated, and the switch itself is a common source of problems. Another approach is to check power at the motor in various switch positions - wires connected and disconnected. For reason given by Robin; use a test lamp…

Frank
xj6 85 Sov Europe (UK/NZ)
**

(KrissMotors) #7

This is the wiper wiring diagram (illustration of Mk2 wiper but nearly identical to the XJ6 S1 system):

Wiper switch is on the far right of the diagram with terminals 1 through 6. Note that the park/run switch (lower left) is mechanical and simply grounds the motor. If your motor does not stop running and park as it should, this is probably a mechanical, not an electrical, issue.

The horizontal bar in the diagram (to the left of the switch) is the harness connector at the motor.

This is how the circuit works (again the Mk2 diagram but nearly identical to the early XJ6 without the delay resistor):

You can check at each point on the switch and harness connector for voltage given the various switch positions to see if there is a basic electrical problem external to the motor. Red lines show input current and black lines show ground flow. Note that the difference between FAST and SLOW is the use of a resistor in the circuit.

When you shut off the wipers at the switch, the motor reverses direction until the mechanical park switch is triggered to break ground and end the motor’s rotation.

1 Like
(G-mac) #8

Thanks that diagram is exactly what i was looking for. The auto electrican tested the motor and it was working intermittently and slow. So they are rebuilding it. If that doesnt solve it i will try an old stock new switch ive just ordered.

(Carl Hutchins, Jr. ) #9

I have “fixed” many an electric motor over decades. Congealed grease a common cause.
Cleaned and re lubed and they hummed!!

In some, just cleaned the armatures and in a few replaced bad brushes.

But, some just refused to respond. In reflection,. shorted field coils the likely cause…

I suspect you are on the way to functioning wipers.

Carl

(Andrew Waugh) #10

Hi G-mac.

If you fill in the “My Cars” field in your profile and add what year/series your Jag is then people can see which model you have. The wiper circuits are all electrically similar (if not nearly identical), but the switches vary from model to model.

(phillip keeter) #11

It’s been mentioned before that “fooling” with the flasher switch will solve the problem.

(Frank Andersen) #12

**
That’s as good as it gets, G-mac…

Be aware the wire colours in the Mk2 is different from the xj. Make careful notes before disconnecting your set-up on which wires goes where…:slight_smile:

Frank
xj6 85 Soc Europe (UK/NZ)
**

(G-mac) #13

Motor rebuilt and reinstalled…nothing! No movement on either wiper speed. However as i unscrewed the fuse dash to have a look behind the switches the fast speed setting suddenly started working…it wont park though and only works on fast speed. Could this be a park switch issue?

(KrissMotors) #14

When your motor was rebuilt, was it bench tested? It should have been! If the park mechanical switch worked on the bench, it should certainly work in the car since it is entirely mechanical, not electrical (apart from the requirement of a good ground connection). Also, if fast/slow worked properly on the bench, then you have a wiring/installation issue now. It is concerning that unscrewing a fuse suddenly makes the wiper work.

Are you testing while the engine is running? If not, are you sure your battery is supplying enough current?

(phillip keeter) #15

This could be a flasher switch issue. They are all connected in some fashion. **Fool with the flasher switch!"

(Frank Andersen) #16

**
The connections made by the stalk switch to alter motor function is rather intricate, G-mac - particularly if intermittent wiping is fitted…

There are three brushes on the motor, connected to the stalk switch. The stalk switch provides power and ground as required. Two brushes are used at a time, one for power, and one for ground - giving fast or slow wipe. The park switch is electrically bypassed…

In ‘off’, the switch reverse polarity, making the motor rotate in the opposite direction. The park switch engages, and 12V is applied by the stalk switch - giving 12V on both brushes, stopping the motor ‘parked’ position…

If ‘intermittent’ speed is fitted; the motor rotates in the ‘park’ direction - as connected by the stalk switch…

To test the system you need the proper wiring diagram. However, the usual fault is in the stalk switch - turning to ‘off’ the wipers simply stop, instead of reversing and self park…

Frank
xj6 85 Sov Europe (UK/NZ)
**

(G-mac) #17

Bearing in mind this is a series 1. There is no stalker wiper control. Just the dash rocker switch.

(Carl Hutchins, Jr. ) #18

I’ve no idea as to the circuitry and mechanics in the S! wiper system.

Does the rocker switch have multiple positions, speed, on/off, prk or something like that.

I do see two clues/

  1. The fuse thing you did, Check out and clean the rear of the fuse panel. Contacts??

  2. The internals of the switch. Can it be opened, cleaned and lubed ?

The window rockers in my SIII respond that way !!

And, aye you do need the schematic!! Mine ahs aided me a lot…
Carl.

(Robin O'Connor) #19

Karl should just be off, slow, fast.
Park is initiated by the off position when running.

(Frank Andersen) #20

**
Point taken, G-mac - but the self parking works the same way; by reversing motor direction…

Incidentally; the same motor was used on all series car - and it is barely adequate in power… :slight_smile:

Frank
xj6 85 Sov Europe (UK/NZ)
**