X300 xj6 no crank after sitting for months

Hello everyone.

I recently changed the starter motor to my -97 x300. ( was a painfull operation) Anyways, everything was going well, until i tried to start the car for the first time. Nothing happened. No crank. Well i ruled out bad starter motor by giving it power with jumper cables, and it worked just fine. Then went trough every single fuse and realy, and everything were fine. Car was in park but the P light is not lit up. Neither is neutral light when i put it on neutral. But i can hear the gear lock solenoid knocking when i wiggle the gear lever.

I have heard some people talking about faulty security modules and body processor modules. Could this be it? I pulled out the security module from the trunk, and it seemed fine for eye. Connectors seemed fine and inside of the box looked okay, no water of burn marks etc… Also one thread said that if body processor module was faulty, some electrics wouldnt work such as brake lights, but they all work…

Oh and the starters power cables are all okay. I found out that the starter solenoid is not getting power. Or atleast thats what multimeter told me.

Thanks in advance

  • Ozzo

Edit

The P lights up now. I hit it hard couple of times. Neutral light doesnt, but it might be burnt light. Could it still not recognise that the car is in park, and thats why it wouldnt crank?

On my X300/XJR the “P” would glow red when the system knew the gearshift was in Park. The starter would crank the engine.

If the “P” glows white, no crank

Adjusting the “linear switch” fixed the problem in my case. It’s located right alongside the gearshift assemble itself.

I can’t remember of the standard XJ6 uses a linear switch of if the adjustment is made at the rotary switch on the side of the transmission. Someone here will remember.

Cheers
DD

Thank you for the reply.

Okay so in my case, the light works now. But still no crank → means that the problem is elsewhere.