Xj12 ECU 16cu Advice Needed

It’s a way to bypass and troubleshoot a broken CTS so you can start and drive the car.
But this tells the ECU that the engine is infinitely warm and cold starts will be very difficult.

[quote=“PhilShot, post:20, topic:427094, full:true”]
Hi, there was no reading at all with the fluke. I read here (below link) that if you unplug the wiring to the sensor and bridge the connection it will give the ecu a false reading. I did this and the car fired up.

Bridging the connector, like with a paper clip, Phil; the ECU reads ‘0’ resistance - which indicates a very hot engine.

With the engine actually cold, say 0C (32F), the required resistance is 5,9 Kohm. With the plug shorted (‘0’ ohms) the the fueling will be very lean - and the engine cannot start and idle normally.

Flooring the pedal will to some extent enrich fueling, and the cold engine may run with high throttle settings. Needless to say, you cannot drive the car in this situation, but with the engine hot, the engine will behave better…:slight_smile:

It’s a bit surprising you get no resistance reading on the fluke - but a ‘cold’ CTS will be in the high Kohm range. So the correct scale must be used - at 80C (176F) the CTS resistance should be 325 ohms.

Measuring the resistance at various temps is of course the proper test of the CTS. If the reading is ‘break’, infinite, the ECU will fuel ‘fat’ - a short will fuel ‘lean’ as said…

You could use a variable or an assortment of resistors - but suggest you do other work, then work on engine’s running when you get a working CTS.

xj6 85 Sov Europe (UK/NZ)

Update re the XJ12. It’s been a while and although I’ve made some progress it’s still being a pain. Last time I was online the coolant sensor wasn’t working and when I did get the car started the rocker cover developed an oil leak. So far to get the car running it has had the following:

Replacement ECU

Injection rail removed, new fuel hoses and o rings. I didn’t energise the injectors while they were off but inspecting them there didn’t seem to be any debris in the little basket filters and they appeared ok

New fuel pressure regulator

Rocker cover gaskets and half moons renewed.

New ignition coil, plugs and distributor cap

New ignition amplifier

New coolant temperature sensor

New thermostats

New fuel pump & filter

New fuel tank change over valve

New fuel return valve both sides

I think that’s it.

I’ve double checked the throttle position sensor through the range and the volts raise smoothly.

Fuel pressure is good, although I have not had a gauge on to prove. If I back off the hose connection a little at the FPR on the left hand side there’s enough pressure in the system to spray a jet of fuel a good 6ft.

I thought it was pretty much sorted so took it for a run up the street. It wouldn’t drive above 2000rpm and was really sluggish, almost like driving in limp mode, although I know this isn’t something the car has. To verify the gearbox I raised the back of the car off the ground, securing it on axle stands and removing the rear wheels. Fired the car up, engaged drive and accelerated. Again the car struggled around 2000rpm. Tried first gear, revs built up then second gear and I could hear the rear disc scrubbing and see a fair bit of smoke. Rear calipers had been stuck. Put it in drive and bingo the car revved freely. Tried in reverse and then the other gears again and everything seemed fine. Put it back on its feet then drove it up the street, unfortunately the backfiring returned until the engine cut out. I managed to restart it but it refused to drive above 2000rpm and anytime I tried to use more throttle it backfired and tried to cut out.

As it stands if I make any movement with the throttle the engine hesitates almost stalling and backfires through the inlet manifolds. I’m leaning towards a fueling issue but that doesn’t explain the pressure in the rail. The injectors all click and have power to them but I’m at a loss at what to try next.

Again any thoughts and advice appreciated.


Have you checked if the distributor vacuum advance is working properly? Failure of the vacuum advance is a common issue in the 5.3L V12s with Lucas ignition particularly in cars that have sat undriven for years. I had one fail in my Canadian market 1990 V12 Vanden Plas that I discovered when I noticed my engine appeared a bit sluggish and fuel economy numbers had suddenly decreased. I tested the vacuum advance with a handheld vacuum pump and confirmed that it had failed. I replaced the distributor with a spare one that I had on hand that had a good vacuum advance and engine performance and fuel economy instantly improved. I suspect that your problem may be caused by a failed distributor vacuum advance. Test procedures for distributor timing and removal and replacement are in the Series III Service Manual and/or XJ-S Repair Operations Manual (ROM). I tend to use both of these documents when working on my Series III 1990 V12 Vanden Plas.


As Paul says, Phil; check ignition timing - it’s rather intricate set-up on the V12, and the most likely cause…

Also check that you ha manifold at hose at the ECU…

xj6 85 Sov Europe (UK/NZ)

Hi Phillip,

You did so many things in one go and that makes troubleshooting quite difficult.

Unless tested in an other car and proven good it’s an unknown.
Is good vacuum reaching the ECU?

Try energising them with a 9v (or very short 12v pulses) power source to test if they all click.

It should work ok, but the only way to verify that is with a fuel pressure gauge.

The vacuum and centrifugal advance is definitely the first thing to check as suggested.
Are you sure that the firing order is correct?


Did you test the Resistance/temperature values?

Do they have min. 41mm of travel (fully open) ?


Did you check that they work as intended? Sometimes they are bad out of the box…

Did you sort this out?

Sounds like that either your ignition timing is way off or the engine is starving of fuel.

All the best.

1 Like

I’d say you’re at the point where actual fuel pressure must be confirmed.


1 Like

Hi Aristides, not sure how to breakdown my reply the same way you have and comment on each point but I’ll try and cover them best I can.

All the parts that have been replaced were done over a period of weeks and not all in one go so was eliminating possible/faulty components.

Replacement ECU, when I bought it I was informed it was a good unit from a running car and this is what initially got mine running. Haven’t tried it on another car but there is a vacuum to the unit.

Pressure regulator was changed as the old one was leaking.

CTS, original one was broken. New one was tested at various temps and signal/values were correct.

Non return valves and change over valve operate as they should.

I’ve double checked the HT leads and they’re all in the correct location. The distributor isn’t seized and moves freely.

Ignition amplifier is a new Lucas one.

I believe the fuel filter is a mann. I can’t remember the make of pump but it’s a high pressure one same as on my TVR.

The rear brakes are now free.

Following your advice Paul, when I got home earlier I removed the vacuum hose to the distributor below the air filter and sucked on it to see if there was any resistance. There is non. I can suck through this pipe and blow through it. I haven’t done any research to see how this works but I’m assuming this should have resistance to work properly?


Attached is a picture of the Lucas distributor in my Series III V12 Vanden Plas that should help explain how I tested my vacuum advance.

The picture shows the distributor with the spark plug wires and cap removed. The component circled in red is the vacuum advance capsule, the component circled in yellow is the nipple where the vacuum hose connects to the vacuum advance capsule, and the component circled in teal is the distributor rotor. When I applied vacuum to the vacuum advance capsule nipple with my Mity-Vac hand held vacuum tester, the distributor rotor rotates counterclockwise advancing the ignition. This vacuum will slowly bleed off and without additional pumping of the Mity-Vac the rotor will return to it’s initial position. This is normal. If your rotor does not rotate counterclockwise with vacuum applied it is possible that you have a failed diaphragm or another failure preventing the rotor from advancing as it should under vacuum. Of course you should have a good vacuum hose with one end connected to the vacuum advance capsule nipple and the other end connected to the proper vacuum source. If not, that is a problem.
When my 1990 V12 VdP was acting sluggish and fuel economy dropped considerably I checked the vacuum advance this way and the rotor did not rotate at all. I removed that distributor, replaced it with a spare that I had with a known good vacuum advance, and once I put everything back together again the engine performed noticeably better on acceleration and the fuel economy returned to what it had previously been. I also checked the ignition timing as detailed in the Series III Service Manual and XJ-S Repair Operations Manual afterwards to ensure that the ignition timing was to specification.
I hope this helps.


I’m leaning (no pun intended) towards a fueling issue

You shouldn’t be able to blow thru or suck easily. The vacuum advance diaphragm is ruptured, I reckon. It needs to be replaced.


Lack of vacuum advance causes this:

Many drivers wouldn’t notice the difference at all.

In fact I’ve gone for weeks with an inoperative vacuum advance with not problem other than what Paul mentions: a bit sluggish and using more fuel.

So, I personally don’t think you’re done finding problems :slight_smile:

Pull the filter and empty the contents into a clean jar. What do you see?

Rust in the tanks (common) can clog a new filter very quickly.

After that, fuel pressure test


1 Like

The main points about changing a component, Phil; if there is no change, either the original was OK - or both have the same defect(s). In the first case, you then have good spares…:slight_smile:

There is certainly not wrong to replace components, of course - to reveal an undisclosed fault. And it’s the only way if the component can not otherwise be tested/measured - but it is an expensive exercise…

In addition to sage advise given by all; you need to backtrace the vacuum line(s) from the distributor to the source(s) and check out the components you encounter. While checking the distributor itself is essential, you must also ensure the distributor actually gets the vacuum that it needs - as provided by your lay-out…

It goes, without saying, that the advance should be set to specification given by market and model. But ignition has a multitude of parts variations, and it is not a matter of mix and match. Both ignition timing and fuel are major factors in engine performance…

xj6 85 Sov Europe (UK/NZ)

Again, thanks for the advice everyone. Not sure when I’ll get back under the bonnet but hopefully sometime over the weekend.

Regarding changing the components. Some were service items others were to replace known faulty ones.

CTS was changed as it was broken, ignition amp and coil were replaced as there was little to no spark. Rectified by replacing.

Fuel pump was to ensure supply as they’re not too expensive.

Following the advice given I’ll check the fuel pump and pressure to rule this out. All being well with this I’ll look at the distributor & vacuum.

Thanks again, Phil

It seems that your vacuum advance is kaput Phil…
To be sure, remove the distributor cap, get a big syringe and apply vacuum, you should see things moving.
As Paul said, some vacuum units have a small bleed hole so it might retract slowly.

You will have to remove the distributor to change the capsule.

I’ve done them in situ 2-3 times…but wouldn’t recommend anyone doing so if they’ve had too much coffee or shaky fingers for any other reason :slight_smile:


I am not certain which vacuum hose Phil removed and sucked on for his test. From his vague description it could very well have been one of the two vent hoses that prevent fume buildup in the distributor and they should easily pass air. So I have no idea if he has a distributor advance problem or not based on his test. That is why I suggested he remove the wires and cap, connect a vacuum pump to the vacuum advance capsule nipple directly, and observe if the rotor rotates counter clockwise when vacuum is applied. This will determine conclusively whether or not his car has a vacuum advance failure (which I highly suspect that it does) and I like conclusive tests. :grinning:


1 Like

You are a talented man Doug…
Removing that little pin that holds it in place must have been fun!

Paul, it won’t be the rotor that turns. It’ll be the plate below the rotor that turns. Which is probably what you meant to say.


You are probably right. I worked on the distributor in my 1990 V12 Vanden Plas in 2018 and I know that the failed distributor didn’t move when I applied vacuum to the advance capsule, but the replacement one did. Exactly what moved at that time could have been the plate. Unfortunately I didn’t take a video of that.


Hi Paul, thanks for the advice and pics re the distributor.

Aristides, to confirm the hose I sucked on was the vacuum hose to the vacuum advance module circled red in Paul’s picture.

I haven’t had time to check the distributor, but, as I was home early from work yesterday I had a look at the fuel lines. Removing the hose upstream of the filter proved very little flow from the filter. I removed it to see what was in there and found a fair amount of crud/rust particles

I can only assume when I checked the FPR hose connection the filter wasn’t too blocked building pressure but restricting flow. Lesson learnt to always double check as advised.

Looks like I have a couple of fun jobs to concentrate on to keep me busy. I’ll get my boroscope inside the tanks to see how bad they are. Fingers crossed I don’t have to take them out.


Easy fuel tank access behind the rear lights (SIII).
And do your fuel pump a favour and put inline filters.