XJ12 SII not running... climbing the walls

Hi all, completely new here so my apologies for requesting help straight away, but it is actually the main reason for signing up. For the last 6 months I have been trying to get my xj12 running again, after hibernation for about 2 years. I think I have read the entire internet, and screwed in and out every part of my jag but without any luck.

Here is what’s happening, when cold engine will run (only idle) for a couple of seconds and then stall. Starting it requires me to turn the throttle half way, it takes a while but than it starts but won’t rev above 1000RPM. turning the throttle any further does really make a difference. There has been one occurrence where after holding the throtle at 50%, it all of a sudden picked up and rev’'d up, after that it stalled and I was back where I started from.
I have measured all temperature sensors (at the ECU) and these are all within range, both when engine cold and hot. Replaced the maps sensor, the old one did not hold vacuum very well this one does, coil-resistance is within margin. (all resistance measured at the ECU btw, to make sure it not a wiring problem).The hall sensors work ok as well, tested this by using a magnet and I can hear the injectors clicking (which btw, I’ve cleaned and tested). Drained the fuel, replaced the fuel filter, added new fuel. Measured the fuel pressure, perfect 2.0bars, swapped the ECU, still same behaviour. Sparkplug are rather black but completely dry, so that would indicate a rich mixture, but can that prevent the engine from running? It’s not soaked? Plugs spark like there’s no tomorrow…

After cleaning the auxilary air valve, and checking this was working by holding it in warm and cold water, out of curiosity I tried starting with the air-tubes (the ones that lead to the manifolds) disconnected, so sucking air completely freely. The V12 started and ran perfectly smooth at idle +/-600RPM, after a couple of minutes the started climbing up to 750/800RPM and stabilized there. So idle was fine, but the second I touch the throttle it dies. Reconnected the tubes, started, idled for maybe 1 seconds and died again, disconnected the tubes, perfect idle. I removed the air filters (left the housing open), but this resulted in nothing. It really wants the breathe completely free.

I just don’t understand what the problem can be, looking at the sparkplug, and the fact that giving it a lot of extra air allows it to run (or at least idle), i tent to saying that it’s running too rich, but what could cause this? I though the only factors that influence the mixture are the temp sensors and the MAP sensor and these seem to be ok? To be on the safe side I disconnected the cold start injectors but this didn’t make any difference either.

Does anybody here have any clue what can be wrong, or what else I should/could check?

This is a cross post from jaguarforums.com, I’ve been helped by Grant Francis a lot, but unfortunately all his help still didn’t lead to a running engine so I’m hoping to find a bigger “audience” and more opinions here.
the link to the other post: https://www.jaguarforums.com/forum/xj6-xj12-series-i-ii-iii-16/xj12-sii-not-running-climbing-walls-222539/

Thank you!!

Certainly no expert on the V12 but 2 bar sounds low for injection however the fact that when you supply more air indicates that it is rich (plugs point there too) I would be looking at the Coolant Temperature Sensor as a likely culprit.

You mean the vacuum sensor inside the ECU ???

Are you sure the replacement ECU is in good working order ?
My gut feeling says ECU… had a similar situation.

Hope that helps.

Forgot to mention, this is SII, lucas d-jetronic. the vacuum sensor is mounted on top of the radiator-bridge thing.

ECU swap, I have two ECUs from a friend, both of them work in his car.

" I would be looking at the Coolant Temperature Sensor as a likely culprit."
did this, measured at ECU. resistance seems to match the temperature, but just to be sure I replaced it with a “normal” resistor and have even tried just bridging the connector (0Ohm) but didn’t make any difference…

Does the Lucas d-jetronic have the same Ignition Amplifier as the Digital P ?

I don’t think so, for HE it’s a small square black box right? mine is an aluminum box with heatsink, sitting between the two banks just behind the airco compressor.

Isn’t this an ignition Amp ? have you checked it ?

yes thats the ignition amp? that’s what you asked right? I haven’t checked this as the engine runs beautifull when supplying way to much air…

Sorry, I’m not familiar with the S2 set-up… just checking all possibilities.

Ok, fueling issue.
ECU - sensors- wiring - injectors… one of them has a problem
Where from is the ECU in the S2 getting it’s signal to fire the injectors ?

You do not mention the throttle switch/potmeter, Marcel - has it been tested/adjusted?

The other oddity is the response to AAV operations. Removing the AAV gives free air ingress, unrestricted by the AAV itself - that the engine then idles implies that it is not getting enough air through the AAV. That the idle increases as the engine warms up, with the AAV removed, is due to the engine loosening up. The purpose of the AAV is to compensate for cold engine drag, basically friction, which abates as engine warms up…

Two points The AAV functions also combines with the idle adjustment - the central point here is an engine not getting enough air cannot idle…and quits. The second point; the throttle switch/pot is one of the fuel controls - if it malfunctions the engine gets too much or too little fuel…and quits…

That the engine starts with throttle applied may imply either an air (more throttle required) problem, or a fuel problem (throttle switch hitting a ‘sweet spot’). In any case; the engine is not meant to be started with throttle input - it confuses the ECU, causing starting difficulties.

Basically, if the AAV/idle set malfunctions, the engine won’t start/idle - once started, one way or another, throttle inputs will override lack of AAV/idle air. But if the throttle switch also malfunctions; throttle switch/pot failure will cause fuelling anomalies with throttle movement…so…?

And I assume that throttle linkages has been properly set…

xj6 85 Sov Europe (UK/NZ)

xj6 85 Sov Europe (UK/NZ)

I think it’s the trigger unit in the dizzy, not 100% sure, but I don’t see anything else that could signal the ECU

“You do not mention the throttle switch/potmeter, Marcel - has it been tested/adjusted?”
the SII has no potmeter, it’s bases itself on the vacuum in the manifold using the MAP sensor…

“And I assume that throttle linkages has been properly set…”
yep, one of the many things I checked :frowning:

As Frank already said Marcel, normally this would mean that your AAV is no good.
The bulb gets “lazy” with time and it doesn’t open as much as it should.

I say, for now continue your checks with out it, you have an engine that can, at least, idle…

Now I think this is a different issue.
Does the S2 ECU have a vacuum input ?
Did you check if the hose has a leak ?
If the ECU sees no vacuum it thinks you are in WOT…

Seems like a very rich mixture for those plugs.

The gist of the problem(s) is still that the engine idles normally with the AAV removed, Marcel - but quits when throttle is then applied…right…?

Opening the throttle adds air along with the open AAV aperture - throttle position does not influence AAV air. That there is a problem around the AAV seems logical - the throttle response, or lack of it, seems a separate fault…

Obviously, my manuals do not cover your set-up; I thought all V12s had a device registering throttle position/movement directly - in addition to measuring manifold vacuum. Ie, on later models; a throttle potentiometer…

Manifold vacuum dictates the a mount of air actually entering the cylinders - and the ECU varies injection duration accordingly, to maintain constant mixture. Other inputs to the ECU are refinements to adjust for other relevant factors - to ensure proper engine response to all situations…

Have you actually measured vacuum, or its variations, on both banks?

Or indeed, using a spare spark plug, to verify that there is no loss of ignition? The only relationship between ignition and throttle movement is vacuum influence on ignition timing - which is somewhat complicated on the HE.

It is a bit far fetched; but as throttle is opened, manifold vacuum drops - increasing cylinder fill and pressure. Which may quench weak sparking - a long shot if ever I saw one…:slight_smile:

xj6 85 Sov Europe (UK/NZ)