Xk120 won’t start

I have been following a thread from 2019 ‘1954 xk120 fhc won’t start. How do I remove…’ which has been very helpful. Thanks Rob Riley and others. But I think my situation is a little different.
When I tried starting it shortly after turning it off for a day it was completely dead. After a little research everything connected to the ammeter was still live: cigar lighter, clock, terminal A on the regulator. It starts with a wire from solenoid battery terminal to the sw terminal on coil and pushing the large button on the solenoid. So I next tested the ignition switch removed from all wires and it performed correctly and the same with the starter push button.
Also have checked the wire from the small terminal on the solenoid to the starter push. Tested them all with a test light. But when I put them back in there is no power. I should have said I have the dash out laying flat on a small bench. I replaced the old ignition with a NOS switch since the old one was in pretty grim shape. I can read the wiring diagram in the manual but that is about extent of my electrical know how. Also checked all three ground cables; no paint or rust in the way.
Since I had a new solenoid I replaced the old one since I didn’t know how to test it.
Any help you can give me would be very appreciated. John

Deleted by Author

When you switch on the key, is there 12V at the SW side of the coil? Does the fuel pump clickety clack?
When you push the starter button on the dash, does the starter turn the engine over?
To test a solenoid, you can touch a small wire between the small center terminal and the large terminal going to the battery. It should click, and if the large starter cable is connected the starter will turn.

Rob, no fuel pump, no light or volts when I touch sw terminal. No starter when I hit starter button on dash. No starter when I run wire from battery terminal to center terminal on solenoid. Does this all tell us that something is still not right with the two switches or w/r wire ? Could problem be in the regulator since no other terminal on it has power? John

Let’s go though it one problem at a time.

So if you have bypassed the starter push button, then I would say the solenoid is dead. Fix that first.

This suggests the ignition switch is dead. After the starter push button is working again, try running a wire from terminal A1 to terminal A3 on the voltage regulator, and try to start it. This is a way of bypassing the ignition switch.

1 Like

John, the ground for the instruments and dash switches is the sheetmetal section of the instrument panel. Because you have the “dash laying out on a small bench,” it’s possible you’ve lost the ground. Connect a jumper wire from the sheetmetal section of the instrument panel to the car body to insure the switches are grounded for testing purposes.

1 Like

Mike, Thanks for the idea but it didn’t change any of my tests. John

Here is the ground socket screw Mike mentioned. There should be a black wire going to it from the wiring harness.

Rob, thanks for your patience. I’m trying to understand how two solenoids and two ignition switches could be bad . Both are new replacements and are not working in exactly the same way. The ignition switch is new old stock but it came without the barrel and key. So I added mine and it switches a test light on and off hooked directly to a battery. Is there anything I could have gotten wrong when I took out the center spindle on the switch and added my barrel and spindle? Any other ideas or do I order another solenoid?

Yes I have the black wire on the grounding screw which it looks like it comes from terminal E on the regulator.
Your student, John

I suppose you’ve checked the fuse between A3 and A4.
All screw terminal connections tight?
Can you check that you have 12V at terminals A & A1 with the key off, A3 & A4 with the key on?
Does the IGN light come on?
Do you have 12V on the white wire at the ignition switch and starter push button?

I’m beginning to think it may be at the voltage regulator.
On the inboard side there is a magnetic coil with a set of points that are normally closed. You could clean those points with sandpaper or a points file or a ladies nail file, just push down on the top to open the points and drag it through there.

Points closed:

Points open:

Isnt the fuel pump unfused ?

I would trace out the circuit diagram and look for where 12V comes from for the fuel pump

The solenoid can be tested in situ by applying 12V via a wire from the battery to the terminal that comes from the ignition switch, (be aware this will activate the starter motor)

If Rob suspects the VR, the I would follow his suggestions

for electrical fault finding these older cars are fairly simple to diagnose

Professor, we had some success! After cleaning the points the fuel pump, heater fan, ignition light came on with switch on. A1&A2 and A3&A4 also had volts initially then lost power. A still had power.
Cleaned points again and also took off VR to look at back and it started smoking-fried I guess. It was a new replacement. I think the old one was okay so I will put in and see what happens. The fan, fuel pump and ignition still work. I’ll get back to you. Hope you can get in some 4th festivities helping me and others. Big thanks from your student, John

Tony,thanks for your suggestions. As you can see from my reply to Rob’s next steps we made some progress but a big mishap on my part. I’ll put in the old regulator and see what happens. John

1 Like

Another possible failure mode of these regulators is corrosion at the rivet connections on the back.


The regulator can be cleaned in muriatic acid (toilet & pool cleaner), then rinsed off with water of course. Don’t breathe that stuff.
It worked great on the Lucas RJF50 regulator for my '38 SS saloon.

Professor Rob, as I was taking out the regulator I noticed that the screw holding the metal strip on the back was very loose. Tightened it up but no change. Now will replace the regulator and hope it’s good. John

Rob, I’ll try and give you the status on the questions you asked now that I put the old regulator.

  • I get power at the sw terminal
  • no power at ignition or white wire side of push
  • no power between battery terminal on solenoid and solenoid center terminal
  • heater fan, ignition light and fuel pump have power
  • voltage at A&A1 with key off and voltage at A3&A4 with key on
  • starter still turns over with large rubber push on solenoid
  • all terminals except D&F are live with key on
    Hope this helps you. Anything else to check? I did sand paper the one contact.
    Seems like you’re making progress. Thanks a lot, John

Very good summary.
We are making the assumption that your 120 DHC car is wired more or less as the FHC wiring diagram W94602.
Heater fan power comes from A4.
Fuel pump power comes from A3.
SW power comes from A3.
But power comes to A3 through a white wire from the ignition switch, which in turn gets power through a brown/blue wire from A1, which in turn gets power from A through the windings.
IGN light power is routed thus: from A3 through white wire to ign switch and then white wire to starter push and then white wire to IGN light and is grounded by a yellow wire through D back to the generator.
That’s a mystery, how could the IGN light work if there is no power at ignition switch or white wire side of push? Maybe a white wire is poorly connected, not passing much current?

In any case, let’s check the white/red wire from the starter push to the starter solenoid. Good and tight on both ends?
Do you have a jumper wire, so you could jumper the ignition switch and jumper the starter push and see what happens?

John, I’ve been reading here about your travails and feeling a bit of a sense of dêjà vu, last year having had to chase down electrical gremlins, interrupted by my RF90 control box (aka voltage regulator) going south in a dramatic way, in the process taking out the ammeter. The ammeter is actuated by a simple, 16 gauge loop of copper wire that also feeds battery power from the RF90 to everything except the cigar lighter and starter solonoid, which are on the same circuit. In other words, with that loop of copper in the gauge gone, only the cigar lighter and starter solonoid has power going to it. Nothing else works. It was a simple fix. So was restoring the original RF90 box using the guts out of an MGA control box. The key to it all was the RF90. My original was flakey, and the source of the gremlins. Once restored to new condition, and the ammeter repaired, I had clear sailing. The interesting part of the thread starts here, but you may want to go over the entire thing:

1 Like

Nick, you are right on, very frustrating but with great help from all you guys I know I’ll get through it. Your abilities are way beyond mine. Tried to understand all you did fo solve your problem. I’m sure I would have ordered new parts long before. John

Rob, I ‘m sure I’ve not answered all your thoughts but here are what I learned in trying to answer some. Hope it helps.

  • yes using FHC wiring diagram from manual(same as DHC)
  • only addition to power to sw is A3 gets power from ign switch via lighting switch
    *when I run a jumper wire between white wires at ign switch and white wires on starter button and push starter button with key on starter turns and car runs
  • when I run wire from w/r wire on starter push to ground post and push starter push car starts and runs
  • when I run jumper from white wire wire terminal on ign switch to center terminal on solenoid car starts and runs without pushing push button
  • with key on there is 12v to ignition switch to ground and same with starter push and there is continuity on white wires
    *. I have checked all screws at terminals
    Hope this gives you some ideas, John