[xk8] Driver's Power Seat


(MMM XK8) #1

Hello everyone,

I purchased a 2002 XK8 convertible on 8/14/06. When I drove the
car away, the power driver’s seat seemed to be working fine. Later
that night, I had someone else drive the car (while I was in it)
who moved the seat fully rearward. I believe he tried to keep it
moving back even though he didn’t realize the seat was already at
the end of its rearward travel. From then on, I haven’t been able
to adjust the seat. I get no sound when using the 1st control, and
noise (but no movement) when using the 2nd control. The lumbar is
functioning.

I don’t have a fuse diagram, and I don’t know if that would even be
a factor. Also, unless I’m doing something wrong, the power
headrests don’t seem to be functioning, on either seat.

Thanks in advance for your help…–
Martin Melucci
–Posted using Jag-lovers JagFORUM [forums.jag-lovers.org]–

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !


(gary breyer, 09 X358 LWB Sovereign, Liquid Silver/Warm Charcoal. Ex Ministerial car.) #2

In reply to a message from MMM XK8 sent Mon 21 Aug 2006:

Martin,

Maybe one or more of the connectors, under the seat, has been
dislodged?–
The original message included these comments:

I purchased a 2002 XK8 convertible on 8/14/06. When I drove the
car away, the power driver’s seat seemed to be working fine. Later
that night, I had someone else drive the car (while I was in it)
who moved the seat fully rearward. I believe he tried to keep it
moving back even though he didn’t realize the seat was already at
the end of its rearward travel. From then on, I haven’t been able
to adjust the seat. I get no sound when using the 1st control, and
noise (but no movement) when using the 2nd control. The lumbar is
functioning.
I don’t have a fuse diagram, and I don’t know if that would even be
a factor. Also, unless I’m doing something wrong, the power


Gary London,UK, 98 XJ8 4 www.jag-lovers.org/v.htm?1122951577
–Posted using Jag-lovers JagFORUM [forums.jag-lovers.org]–
–Support Jag-lovers - Donate at http://www.jag-lovers.org/donate04.php

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !


(Orsmo) #3

In reply to a message from MMM XK8 sent Mon 21 Aug 2006:

Having driver seat recline problem also.

Does anyone know how to tell if it’s the seat module or the
actual seat motor?

When I press the recline button, the relay in the seat
module clicks, but no movement.

Thanks in advance for any help on this.–
Orsmo
–Posted using Jag-lovers JagFORUM [forums.jag-lovers.org]–
–Support Jag-lovers - Donate at http://www.jag-lovers.org/donate04.php

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !


(jez) #4

Having driver seat recline problem also.

Does anyone know how to tell if it’s the seat module or the
actual seat motor?

When I press the recline button, the relay in the seat
module clicks, but no movement.

This suggests the control module is activating the relay but the motor isn’t
moving - either it’s not getting power or it’s jammed.

Cheers - Jez

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !


(Orsmo) #5

In reply to a message from MMM XK8 sent Mon 21 Aug 2006:

Update.

I switched the seat module from the passenger seat and it
now works. So need a module.

New question though. While removing the passenger seat
module, discovered it only has 2 wire connectors under the
seat, where the drivers has three. I miss one or is this
normal??–
Orsmo
–Posted using Jag-lovers JagFORUM [forums.jag-lovers.org]–
–Support Jag-lovers - Donate at http://www.jag-lovers.org/donate04.php

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !


(Charles_3000) #6

In reply to a message from Orsmo sent Thu 24 Aug 2006:

Seat management between driver and passenger is different
because of the memory function on the driver side. Maybe
this is what the third wire is used for.

brgds,

TC–
Charles_3000
–Posted using Jag-lovers JagFORUM [forums.jag-lovers.org]–
–Support Jag-lovers - Donate at http://www.jag-lovers.org/donate04.php

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !


(MMM XK8) #7

In reply to a message from gary breyer sent Tue 22 Aug 2006:

Thanks for the help. I got back from vacation a couple of days
ago.

I tried looking under the seat when I first had the problem, but
can’t really see anything under there. It seems like the seat got
stuck in a low position, not leaving much space.

Would a fuse possibly be the problem? The person who sold me the
car directed me to page 6-23 of the manual, but I seem to be
missing that page!–
The original message included these comments:

Martin,
Maybe one or more of the connectors, under the seat, has been
dislodged?


Martin Melucci
–Posted using Jag-lovers JagFORUM [forums.jag-lovers.org]–
–Support Jag-lovers - Donate at http://www.jag-lovers.org/donate04.php

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !


(Beastie) #8

In reply to a message from MMM XK8 sent Thu 31 Aug 2006:

Hi - I had a similar problem - there is a fuse that is in the
manual whihch one - the problem I had was fuse kept blowing because
of a wiring short under the seat. Took the seat out and apart and
checked all wiring before I found it - what a pain !–
Beastie
–Posted using Jag-lovers JagFORUM [forums.jag-lovers.org]–
–Support Jag-lovers - Donate at http://www.jag-lovers.org/donate04.php

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !


(awa) #9

In reply to a message from Beastie sent Thu 14 Sep 2006:

also had a problem with the drivers seat in our '99. sear worked
great and then it didn’t work at all. the problem was wiring.–
The original message included these comments:

checked all wiring before I found it - what a pain !


awa
–Posted using Jag-lovers JagFORUM [forums.jag-lovers.org]–
–Support Jag-lovers - Donate at http://www.jag-lovers.org/donate04.php

Visit the Jag Lovers homepage at http://www.jag-lovers.org for exciting services and resources including Photo Albums, Event Diary / Calendar, On Line Books and more !


(David) #10

Same symptoms as Martin: for 2003 XK8 coupe:
passenger seat back stuck leaning forward
I checked : fuses 8 and 1 on passenger side ok
switch moves seat forward and back no effect therefore no problem with wiring under seat or switch
No sound when using seat back switch
Loosened plug on back of seat module resulted in sound when using switch to adjust seat back but no movement.

Does this mean problem is control module is activating the relay and motor is jammed.

Also, passenger head rest make noise but won’t move
Could it also be jammed?