Yet ANOTHER central locking problem on my '89 XJ40

Ah yes, the good ole central locking system.

Everything operates normally except the doors won’t unlock with the remote. The door key opens and closes all the locks normally likewise the chrome knob on the driver’s door.

I pulled the lock motor in the drivers door (LHD) and separated it from the linkage. When the remote sends the door lock signal it slams the rod down with great gust. But when the remote sends the unlock signal … nothing !

That eliminated the linkage as a potential problem. So it’s either no unlock signal going to the door motor or the signal is being sent but the innards of the motor aren’t processing it.

Anyone dug into the door lock motor lately ? I’m guessing there may be some contact points that are the problem but If I want to get inside It appears I’ll have to cut it open.

Yes needs to be cut open, BTDT I ended up just getting a generic set of actuators and splicing them in.
I did cut one open but it was beyond repair.

Thanks Robin …

Do you happen to remember what’s in there other than the solenoid? Anything (contact points or micro switches) that could be causing a failure to work one way but not the other ?

From (failing) memory yes there’s a micro switch in there which could be causing the problem.

Not having a lot of patience i carefully pried it open.

No solenoid here ! Very complicated but straightforward little gizmo. Nothing obviously broken so I’m going to zero in on that little micro switch.

Grooveman I’m fairly sure I read somewhere there’s a polarity reversing switch inside at least one of the door lock mechanisms, but I can’t remember for sure whether it was inside an actuator or fitted in a place where the door key would also cause it to operate? Wherever it is, it’s job is to reverse the polarity to the coils inside the actuators each time they are used.

Casso … Right you are sir. It’s located in the driver’s door lock motor assembly.

1 Like

Grooveman great pictures, I’ve always been curious about what was inside those actuators !
The polarity switch looks like the prime suspect, if you manage to repair it are you going to glue it back together or drill through the existing mounting holes and use longer fixing screws ?

I always thought there was just a simple solenoid type electro mag coil contained within that black case.
Having now owned two xj4os, I’ve replaced two drivers side and two rear actuators and they are not cheap, and no longer easy to find. I’m glad I threw the old ones into my ’ that might be useful ’ junk box and not into the bin. What did you use to split the case apart ? I’m digging them out tomorrow and opening them up.

Casso …

Not that difficult to open. First I used a box cutter to trace around the joint between the two halves. I didn’t try to cut it open, just scored it all the way around. I then used a flat blade screwdriver starting at the corner where the wires come out and gently pried it open little by little.

Not being an engineer by training I do however take pride in being able to figure out how things work.
Although the drive mechanism of this little beauty has me scratching my head.


The item shown with the black arrow flips over and rides in the area show by the white arrow. But how it physically changes direction is beyond me. I can’t wait to get your feedback on this.

After troubleshooting the motor and microswitch everything seems to be in order. It appears that the fault is that the unit is not receiving the “open” signal from the controller under the dash. I’ll get a used replacement for that and see if it solves my problem.

Gentlemen: I have a 1994 so your mileage may vary, but this post may shed some light:

Hi grooveman, I’m guessing the motor drives the gearbox which moves the rod out, then when the rod is at it’s full extent it activates the polarity reverse switch so the next time the motor gets a signal to run it runs in the opposite direction thus turning the gearbox in reverse so the rod moves back in again.
Does that make sense ?
Can you give the motor a 12 V feed until the rod is fully extended then try it again to see if the motor runs in the opposite direction ? I think the signal remains constant and it’s only the motor’s directional rotation that determines whether the door locks or unlocks, so if it’s working in one direction I think your controller under the dash will be ok.

Ain’t that the way the antenna works too?

Yes, that’s exactly how it operates.

After taking the unit apart I temporarily removed both drive items shown by the white and black arrows below. I then plugged the unit back in and observed it’s operation. Every time you depress the microswitch the motor operates for about 2 seconds and changes direction every push. So that works properly.


What has me scratching my head is how the two tabs shown below interact when assembled to allow the plunger arm to move in and out. Very difficult to explain, you’d almost have to be holding the assembly to understand what I’m talking about.


The way my system works is there is only one button on the remote. Push once the doors lock, push again and the security system arms and the headlights come on for about 15 second. Push a third time and the doors unlock and the security system turns off. Everything works fine except nothing now happens on the third (unlock) push of the remote.

Update …

I just received my new (yes actually new old stock) door lock motor and after installing it … nothing changed, which I sadly expected.

I also ordered a used door lock control module which will be here in a few days so we’ll see if that solves the problem.

Grooveman, this may only be anecdotal but here goes anyway: my brother recently acquired a 1996 Chevy Blazer and he immediately had a shop perform some work on it including replacing a faulty power outside mirror. The power door locks - and the remote lock/unlock functions - were not working. After spending the better part of a weekend poring over wiring diagrams, disassembling half the dash, and running a new wire to bypass what we believed was a broken wire ‘somewhere’, we had the power locks working with the key, door lock knobs, and door switches. Hooray! Sadly, the remotes still were not working. Oh well, next weekend…fast forward, and during the following week my brother did some further digging and found the shop had failed to reconnect the connector to the ‘Remote Keyless Entry’ module and yes, the key switches, the lock plungers, and the armrest mounted lock switches all run through the RKE module. Once the connector was reconnected - and our newly-run supplementary wire was disconnected - all the locks worked like they were supposed to and the remotes were working. I recall you said your security system was dealer-installed so you nay not have wiring diagrams therefor but is it possible your central locking problem is really an issue with your security system?

Mike …

Good thought, when I change out the door lock control module I’ll double check all the connections.

There’s another wrinkle that I’ve been thinking about. I believe my original system used an IR (infrared) sensor.


That was disabled by the dealer and I removed it years ago to install my 3 button garage door opener in it’s place.

I’ve noticed there is a small black box with a short wire antenna under the left side of the dash that doesn’t look stock. I’m assuming this is an RF (radio frequency) the dealer substituted for the IR door lock/security receiver.

So the question will be does the RF receiver operate through the door lock module like the IR unit did or is it self contained and bypasses it ? When my part comes I’ll soon find out.

In my brother’s Blazer the signal flow is:
Door lock switches —> Power Door Lock module —> Remote Keyless Entry module —> Power door lock actuator in driver’s (front) door —> Rest of the doors
So once we (my brother) figured this out it became apparent why the power door locks weren’t working with the RKE module unplugged.

Grooveman - have you tried to follow the wiring connected to the small black antenna-bedecked box to see what it connects to? I suspect you are correct that it is the RF receiver for your security system. The receiver for the Remote Keyless Entry in my brother’s Blazer is mounted to the back (forward) side of the panel beneath the dash on the driver’s side.

Another all’s well that ends well …

Received my used door lock module from EBay (I love that place) the other day and when I took it out of the box it sounded like a castanet or pebbles in an empty can. Now that can’t be right ?

Fortunately it’s very easy to open up and I found that a large rectifier had come loose from the printed circuit board. I KNOW that can’t be right ! So some soldering and I was go to go. I also used a bit of hot glue to attach it to the capacitor next to it to stabilize it in the future.

Plugged it in and everything works again :smiley: Now to take the old one apart to see why it failed (best done over a glass of fine cabernet. I’ll have to check the vintage of the box it comes in. I think “Tuesday” was rated very high).