1994 3.2 XJ40 not starting after flat battery

Hello everyone,

i was hoping my first post here would not be a problem like this one but sadly it is.
But lets start from the beginning…
My name is justin, i’m from germany and i got this 1994 XJ40, XJ6 3.2 from paris, france.
‘imported’ to germany in 2016 the car sat for 6 years in an underground garage. i got the car from my neighbour and when i looked at it the first time i installed a battery, turned the key and it was running totally fine even after 6 years.

So i brought it over to my mechanic where it got a new
fuel filter, engine oil, transmission oil, differential oil, air filter etc.
It even passed mot without problems on the first try.

I’ve driven 1200km in 2 months now without any issues and parked a few weeks ago in my garage. The weather was bad and i was working a lot so the car hasn’t been driven for 4 weeks and when i got in last week the voltage gauge would barely leave the red line. I don’t know why i even tried it but of course turning the key did nothing. There was just a clack from the starter trying its best but that was it. I already suspected the battery to be bad when the gauge showed 10 volts after just 5 days where it took several tries to start the car.
So i disconnected the battery and connected it to a charger which showed 4.9v first and error after a few minutes. With another charger the battery would load up to 13V+ but lose its charge down to around 12,5v after few hours just standing on a table without anything connected to it.
One day i installed the original alpine ch-changer and wanted to test it so i got one of these massive batteries and the gauge showed around 12v. I didn’t try to start because i wasn’t expecting any problems at the time. i disconnected the huge battery and left the car sitting for another week.

This monday i wanted to go for ‘the last drive of the year’ because the weather was good. So i took another battery and put it in… 11v on the gauge. Car not starting.

Fuel pump is working i can hear it, the starter is clearly spinning the engine, theres fuel in the fuel rail and
it delivers spark. When trying to start the tachometer says 200rpm.
I connected the battery to a charger and it showed 12.9v but the gauge 11v.

We tried to jump start and the gauge said 14v as it always did but i still could not start the car. The engine was spinning faster but i don’t remember what the tachometer said but it clearly was faster.

Everytime i try to start i can clearly smell fuel but i see no leaks. It’s like the engine really wants to start but something does not allow it to fire. No VCM codes at all.
So I will clean the CPS tomorrow because its covered in dust and oil.

What i don’t understand is why it shows such a low voltage on 2 good batteries and i’ve read that the engine management does not allow the engine to fire with a low voltage but i can’t verify this information.

I would be grateful for any sort of help and i hope my english was good enough to explain the problem in a understandable way.
Best regards

Justin, first, welcome to Jag-lovers! Great bunch of folks on J-l as I am sure you will learn. Sorry to hear of your no-start issue. Here is a link to a VERY long thread (193 posts) chronicling Jag.Man’s journey chasing a no-start issue:

1994 Jaguar VDP No Spark - #185 by Jag.Man?

Post 185 (linked) sums up the resolution. Does your car have 7 relays on the right side of the firewall, with one of them having a white base? If so, that will be the Ignition On relay that could be suspect. You can swap that relay with the A/C relay (green base) as a test if you don’t have a spare.

Hi - what colour is the spark? nice strong blue or yellowish?

You need to check this, I’ve had an incident in the past where I could see a spark at the plug but it was very weak. The XJ40 engine can flood very easily very quickly. If you have been trying to start the car with a weak spark the engine may have flooded with fuel, I would remove and clean all the plugs, refit a known good battery and try to start the car. Battery drain when the car sits unused for a week or two is another well known problem that XJ40’s can suffer from, sometimes the car will turn over but the output from the battery drops off to the point that the other ignition components do not receive enough power to fire the engine.

Yellow spark points to high resistance …often the rotor is the suspect.


I have 6 relays. One of them was missing so i ordered a new one 2 months ago which is doing good.
The one with the white base is very oxidized both the base and the contacts of the relay so i’m going to give it a good clean asap. Swapping with the A/C relay did not change a lot the engine won’t fire but the volt gauge showed 12v instead of 11(?)… maybe a coincidence. So i plugged in my new relay but that didn’t help too.

Hello, it’s definitely a strong blue.

A short update:

Today i cleaned the CPS but that didn’t make a change
After that i removed all the spark plugs which look like new and are completely dry

Well, assuming the late model XJ40 security system is the same as the x300, my guess would be a security module that has lost the key code. And if the key codes don’t match, the car is immobilised.
The exact same thing happened to me. When the battery voltage slowly dies the security module can overwrite the key code stored in the module with garbage.
If this is the case you have two options:

  1. Have a Jaguar dealer reprogram the module. If you are unlucky the module needs replacing.
  2. Get a matching set of security module, keys and locks and replace the lot.

Where in Germany are you located. I am near Dortmund.


Hello and thanks for the reply.
I really do hope that this is not the problem with my car but if nothing else is going to solve the issue i’m going to the dealer. The next one is about 30km away.

I’m living near Trier.


XJ40 keys, even late production models are not coded, so it ain’t that.

If you have a strong blue spark/plugs dry and the car doesn’t fire up, you have either a fuel or an air delivery problem - more than likely a fuel delivery issue.

The oxygen sensor heater relay on the firewall, if defective will prevent the fuel pump from running. Can you hear it run and pressure up for a few seconds when you switch on the ignition? You have to hear it or it isn’t running.

That would be good news.

If only to rule it out it’s worth unplugging the feed to the in-tank pump and inspecting the insides of both halves of the plug. It’s quite easy to access the plug, it sits on the top of the tank and they have been known to arc inside and burn the terminals causing a ’ hit and miss ’ connection. That same fault happened to my 94 Sovereign and when I mentioned it to other JEC members two others reported they’d had the same fault occur on their cars.