'97 XK8 Convertible - Trunk Button is 'beeping' but won't open the trunk

Hello all…
New XK8 owner here, looking for some more help.

The fuel door open button works fine.
But, when I try to open the trunk from the button on the dash, it ‘beeps’, but doesn’t open the trunk?
I’m not using the valet key. (first thing I checked).
I don’t know if I should be able to hear the solenoid ‘click’, but all I’m hearing is a ‘beep’.
edit The trunk opens with the key.

Any thoughts?

Hey Michael,
Depending on year of manufacture, The boot (trunk) release, may be at the bottom of left side
low wall on the right. Just next to the fuel cover release, (same 2 sided button push switch on left).
Below all of that may be the bonnet (hood) release pull up handle. Don’t confuse these with your
left foot placement pad (snurck). You said your’s is a '97, right? Mines a 2001. So, it might not be as
I said, but close.
Good Luck,

The car is probably in VALET MODE and won’t open except with the key or remote FOB until the car recognizes that the boot lid has been opened.

Just because the lid is OPEN does not mean that the BOOT OPEN switch is working.

Are the boot lights ON or is the BOOT OPEN indicator in the INSTPK displayed with key on?

The only way to get the car out of VALET MODE is to have the car recognize the boot lid open.

1 Like

I will check tomorrow. I dont remember seeing a BOOT OPEN in the display.

I did see Valet Mode flash when I tried my 2nd key…

I have the bonnet off right now, to access the heads for PEM nut replacement so I can get the coil covers back on and watertight again. BONNET OPEN shows on the display.

What is the process to get it out of valet mode?

Both my keys have black Jaguar logos, by the way. They aren’t both valet keys, are they? I don’t remember which was supposed to be green, or if that was true for all years?

My valet keys both green.

Will double check when I get in tomorrow.
She’s up on the lift for the next couple of days.

Not a lot of Jag guys on my side of Puget Sound. :slight_smile: Or, if so I just haven’t found them yet.

Gig Harbor, Tacoma best for west side of sound. Seattle area, good ones in Monroe.
Have the latest list, will look through it if you like.
Bob on Stretch I. and Allyn.

What is the process to get it out of valet mode?

Just checked. Just open the boot with the remote seems to be the only way. Once that is deactivated, it should go back to being able to be opened by the dash switch. Green valet key will not manually open the boot. If Valet mode is activated by the Valet switch on the dash, using the boot open switch causes it to beep, as you are experiencing.

You can also take it out of Valet mode by manually opening the boot with the key.

Brought the car down, and re-checked my keys. Both have black Jaguar logos.

I opened the boot several times, using the key. Dash button still beeping.
Should I be looking for a break in the wire between the boot latch solenoid and that dash button?

I can’t get the remote I got with the car, to program so I can’t open the boot with that.
*tried the high beam, key on, release high beam, then 3 flashes, + press remote button 5 times.
I get no light in the shifter console after the high beam flashes.

@ Bob… Port Orchard for me. Gig Harbor waterfront was too much $$$. lol

The car will not configure remote FOBS in VALET MODE!!!

If the boot lights do NOT come on when the lid is up, then it will NOT come out of VALET MODE.

1 Like

Have you tried dismantling the fob and cleaning the carbon pads on the back of the buttons, and the PCB?
Mine was always flaky, door locking and unlocking very unreliable, boot so so and lights worked fine. Obviously the most used buttons at fault, gave it a clean and all work properly now.Use meths, denatured alcohol or similar.

Hey Michael,
What do you think of getting a Valet key (Green) made from a dealer at the parts counter?
I don’t think messing with the wiring is going to do you any good. I’d check with others before that.

Will check with them next week.
Been a crazy last few days.

Thanks all for the info on items to check.
Its got to be one of them. lol

I was able to get a few minutes to go out and look at this.

I pulled the microswitch off of the boot latch assembly. Interior boot lights immediately came on.
Checked the dash… “BOOT OPEN” was visible. Shut the boot without that microswitch re-installed.
“BOOT OPEN” still visible.

Took the microswitch up to my office and was able to get it apart. The spring underneath the little switch, was sitting sideways, and the top part of the actuator, was stuck underneath the opening.
After a few attempts, I was able to get it all back together, with the metal actuator sticking up through the top of the switch.
Put the microswitch back in. "BOOT OPEN’ light is now always showing (before it was not), whether the boot is open or shut. I thought this microswitch was only for the interior boot lights? I don’t see any other wires coming out of the boot latch assembly? How is the “BOOT OPEN” signal being sent?

Update to update
Problem solved. After a few hours of chasing wires trying to find voltages for the ‘Boot Open’ messaging…

The boot latch assembly was ‘loose’, and would slide up or down, almost 1/2".
I lowered it as far down as it would go, and shut the boot. “BOOT OPEN” was still present in the dash.
I pulled it up as far as I could, and re-tightened the bolts. Shut the boot and got no message that it was open.
Was able to open the trunk with the button on the dash, and I’m no longer in Valet Mode!
Haven’t tried to reset the FOB yet. Got the battery on the charger. Will try again tomorrow. +Fingers Crossed+

1 Like