FF34 and rough iddle after cleaning up the V12 valley : fixed - one blocked injector

I spent some time cleaning up the valley of my 6.0 93.5 coupe, changing gaskets, renewing vacuum hoses and cleaning and getting parts powder coated, and on reassembly , the idle is rough, and I get an FF34 error code.
the car seems a bit low on power, but I didn’t want to push it while something is wrong

work done :

  • replace all water rail gaskets and O-rings,
  • replace all AAV internal with John_John’s kit
  • got the cam cover powder coated, fit allumium half moons and replace banjo bolts + gaskets
  • renew the cam cover gasket
  • clean all injectors, change their filter and all O-rings
  • clean and refit the additional air rails, and change all the air hoses
  • change all the small vacuum hoses
  • clean manifolds and renew all vacuum plugs and manifold gaskets

I checked the following

  • all spark plugs and both coils are connected to the right plug, and cords are fully inserted,
  • all injectors are clicking : I thing one seems to be clicking slightly less strongly than the others
  • all vacuum hoses are back to their original spot

I cleared the code, tightened the manifold nut, and could move the car a few time without getting the FF34 error code, but it came back when I finally got the car back into the garage :cry:

FF34 error code is “injection bank A” problem, but I couldn’t find much about it
suggestions are

  • air leak in the manifold : I tried to tighten all nuts, none was loose, I couldn’t find any open vaccum port
  • bad ignition : all sparks were changed 3000km ago, so I didn’t took them out
  • bad or lazy O2 sensor : they’ve not been touched, may be one got some coolant or other fluid during the cleaning up
  • ignition amp : I may try and swap those, as I got 2 or 3 cut outs on the road before (rpm drop to 0, then engine restarts and rpm show again, which could be related to the said amp)

Iddle seems to stay a bit high, even with AAV screw full on, I I guess there could be still an air entry somewhere

all suggestion of testing welcome, to try and locate the problem

Is your engine/fuel injection system wiring harness the original over 26 years old item?

Presumably you had to disturb it and/or move/remove & refit it during your valley work?

If so, I wouldn’t be surprised if you eventually found one of the more brittle wires to be broken or have poor connections.

HTH.

Andy.

Code 34
36CU DTC FF34 AND FF36 FUEL INJECTORS (FI)

This DTC uses the HO2S signal. The feedback inegrator has been on the rich or lean clamp on one bank. Changes to the mixture have brought the fueling on that bank back in control.


If your car has catalytic converters, please do not run! You are risking a much bigger problem.

Here is the recommended diagnostic flowchart (apologies for the low quality)

If equipped with air injection, carefully trace the vacuum hose routings because incorrect routings can keep air injection on, which would lock oxygen sensors…ask how I know. Failed diverter valve can do same. Some later cars have an electric clutch on the air pump I understand, which might change diagnostic test. Disable temporarily by removing belt (on my ‘88 also drives a/c).

@Andy_Broadbent
thanks for the suggestion , Andy
my car is still on its original engine / injection harness, but it’s a low miler (75 000km, about 55 000 miles) and the wiring is still flexible
from what I gathered, the 6.0 is less prone to burning its wiring, may be because of a different material

I checked all injectors and they all click (one sounds slightly different, but still clicks)
I tested some ignition wires and all were sending the signal to the plugs
@sbobev :thanks Steve : I’ve got the same doc, where I found the diagnostic flowchart

my car is a Japanese version, so has dual catalyzers : I’d rather not kill them nor get a fire

@RGK20m3
as I changed all the small vacuum hoses, I could have mixed up somthing, even if I took great care to mimic the original set-up

here are some pictures I took while doing so :

the red arrow points to the air valve command (EAC 5040), which I tested before refiting (helds vacuum, and opens with depression on)

like this

I need to remember where goes the end of rubber bend “2” in the diagram
https://parts.jaguarlandroverclassic.com/parts/index/part/id/C03.910.91017.91017229.910172294227/brand/jaguar/

same area, with manifold out

and the other part (front side) is the hot start fuel system :

https://parts.jaguarlandroverclassic.com/parts/index/part/id/C03.910.91019.91019533.910195337276/brand/jaguar/

from the manifold vacuum take off, hoses goes in 2 directions
:

one goes to the pressure regulator, and the other the the valve :
(I’ve got a doubt when checking the pics against the parts schematics)

Is your Japanese model LHD or RHD?
Can you post pictures of a larger viewing area, I cannot quite make it from these close-ups?
From memory, neither the front nor the back vacuum delay valves should be plumbed under the intakes.


One thing you can also check - is there fuel in the vacuum line that connect to the fuel pressure regulator on the A-bank side?

my car is LHD
the left manifold (AAV side) is easy : it has

  • on the bottom, next the the butterfly : 2 blocked vacuum ports, and one connected to the center of the V, with the rigid pipe,
  • one (6 or 8mm) at the back, next to the AAV hose,
  • one small (4mm) at the front (plastic , not rubbery)

the right manifold has all the hoses and valves, and I took it off with them as a whole, only disconnecting the minimum of bends/ hoses


  • on the front, one blocked port
  • on the back, 4 ports, 1 big, 3 small, to several points, including the additional air valve (second area I can have misplaced a connection)

I connected the hose to the air valve to the port which is opened on the picture below, other side to the manifold (I may have reversed the entry and exit of the valve ?)

the bottom has 3 ports :

* one to the centre, with a rigid steel pipe

  • one for a 8mm hose, to the front
  • one to the fuel hot start valves and hoses (I only replaced the hoses with everything back in place, but may have mixed up)

I’ll try and get other pictures if / where needed

I found an old post of mine where you can see a description of what’s under the intakes and what is connected to engine vacuum of my 6.0L

As far as the vacuum line that goes to the FPR (with the delay provision), if memory serves right, the tube should be connected to the port which I indicated here:

I will double check, but in the meantime, you can run a test - just connect a strain vacuum line from the said port directly to the FPR and see if it makes any difference.

Also, very important - please verify that the diaphragm of the FPR (fuel pressure regulator) is not leaking fuel into the vacuum line.

Here is page from the JAG brochure. A-bank side, as I described in my 2013 post connects only to the SAV and the part-load engine breather in the eve. B-bank (driver) has only vacuum connection to the part-load engine breather

You probably have access to these documents, but for posterity:

AIR INJECTION:

HOT START:

thanks Steve : much appreciated

I’m working during the day so didn’t had time to check the FPR, but it was ok before I took if, then back on : I’ll have a look at it this weekend

re the vacuum hot start system : the vacuum port at the front is capped, and I’m sure it was not connected on my car
using any other vacuum port on the manifold should provide the same result , so one of the bottom ports should be ok, provided I didn’t mix up the sides of the delay valve

that 2 doubt areas are :

  • mixing the 2 ports controlling the additional air injection
  • mixing the 2 “bends” of the hot start fuel control

as the later shouldn’t do much on cold start, I’ll look at the potential inversion on the first one :

(swapping them may be the easiest way to check if the result is better the other way round)

OK, looks like we have to wait a bit for new developments.

I just re-read your original post. Spark plugs were not renewed. Cheap insurance - do it!
NGK BR7EF here in the US can be found anywhere for under $2/ea.

Also, the 36CU will be running in open loop until the engine reaches certain temperature. The O2-sensor will not be a factor until that point.
If the problem persists, disconnect the - you will get FF44 and FF45, but the engine should be running very well without them.

Last, make sure the large vacuum tube from the back of the A-bank manifold that turns and disappears somewhere along the firewall and then under the whole body to the boot HOLDS VACUUM.

Good luck.

as the car was running ok before I start, I reckon the spark plugs are ok (I didn’t took them out), but they’re indeed cheap (less than 3€ here), so renewing them is not a problem (except the delay to get them)

good point about the open loop : I 'll look for the O2 sensors connectors to test that

I checked the rear large hose : it holds vacuum (short test during 15 s, but could leave it longer if needed

is there a way to test the delay valve ?
the hoses around it seem to match the diagram you posted, the last unconnected point (circled) on the picture is connected to the manifold

I checked the FPR hose, which had no fuel in

looking at the picture and air injection system diagram you posted up : the solenoid vacuum valve entry from the delay valve is on the end, while the output to the air cut off valve is on the side
which seems to match the connections I’ve done (not sure it would make a difference, as it’s an open /close valve)

The solenoid should have a vent, possibly covered with a cap or filter; the nipple that connects to that vent with no power applied is the side that goes to the diverter valve in my experience.

Thanks Robert
I’ll try and get it off to have better look

I checked the air solenoid, and it seems to match the original fitments.

Then I cleared the code, and started again : idle is still rough, but the code didn’t came back (yet) : I’ll take the car for a drive , as it seems to be a bit better after a few starts / stops
I’ll report back how it goes

IMO, it is almost certain that the vacuum tubings and the two solenoids we discussed are not the root-cause for the rough idle.

How high is high (reading again your 1st posts, you indicate that the AAV was rebuilt and the screw is all the way in)?

Any chance you disturbed the throttle plates? Are they properly adjusted and synched?

the throttle plates are adjusted , and links are balanced so the plates open in sync (as much as I can check it)

idle is not crazy high, about 1000rpm, and I did loosen a bit the AAV screw during the last tests, after adjusting the throttle turret, to get it at 2mm from the stop

I need to check the idle from cold , then hot, as taking the engine cover off (or back on) needs to release the throttle cable