Fuel pumps suddenly no power, resolved

Just driving the S11 slowly through a car park this morning and the engine faltered and then died just as if it ran out of fuel. Turns out that there is no power to the change over switch in the dash. Managed to hook up a jump pack to hot wire one of the pumps to get home.
Theory is the inertial switch has tripped, anyone point me in the general direction where it is locted?

On SIII cars it’s at the passenger side (RH for LHD) between the door and the fascia.
Must be the same for the SII.

Thanks Aristides, I had a feeling that might be the location, just trying to minimise the kneeling down time :slight_smile:

Attached are two pictures of the inertia switch locations on two of my Left Hand Drive Series III XJ6s. The first picture shows that switch with its cover still on, circled in red, in my former 1984 XJ6 Vanden Plas. It is located just inside the hinge area of the right front passenger door.

The second picture shows the inertia switch, circled in red, with it’s cover removed in my 1987 XJ6 parts car.


Should read 1984. I think the plunger on top must be pushed down if it activated, it is obvious, and it just brakes power to the pumps and that would of course be ahead of the switch.

Oops. You are correct, “1994” should have read “1984”. I just edited it in the online version.


So I couldn’t find the isolator but fiddling around by the fuse block I thought ‘what the heck, lets try and see if they are working now’ sure enough turn the ignition on and select the pump thats still connected and theres the tick tick tick from the pump.
I a going to remove each fuse in turn to identify which is the culprit and make sure that I mark the relevant fuse on the panel.

My 86 SIII just conked out with same behavior but I have not had time to debug. But…I am confused on a few points in the post

First it says RESOLVED but I dont see a clear resolution stated

Also in first post it mentions no power to changeover. That would not cause a stall unless active tank was empty

Thanks and once I debug my issue I will post my findings

Robin’s problem was just a bad fuse connection.
Those glass fuses are famous for misbehaving…
I would suggest that you have a look first at the switch itself, see if it has power and if it switches as it should.

I can’t answer for Robin on the resolution to his problem. However, I encountered some random fuel pump failures in my Series III XJ6s and XJ12 over the past 19 years that I attribute to fuel tank debris clogging up the fuel pumps. After draining and cleaning the tanks and replacing the in tank fuel strainers I added two aftermarket fuel filters between the fuel tanks and the changeover valve to protect it and the fuel pump from in tank debris. After adding those filters several years ago I haven’t had another fuel pump failure. See the attached picture of those fuel filters in the spare tire well of my former 1984 XJ6 Vanden Plas. Those aftermarket fuel filters were easy to install and cheap insurance against fuel tank debris affecting the changeover valves and fuel pump. I got the idea from former list member Bruce Hugo who has since passed away.
BTW, in most cases I was able to free up the debris that clogged the fuel pumps simply by reversing the leads on the stuck fuel pumps back and forth a few times until the pumps ran again. This further confirmed my suspicions about the debris causing the fuel pumps to get stuck and fail.

I hope this helps you out.


Thanks all - my trunk looks just like yours. I rebuilt the whole fuel system when i got it in June 2019 and she ran like a champ until a week ago. That is why I was surprised it failed and can’t imagine debris is an issue. I cleaned and flushed tanks and replaced internal filters, added inline filters and brand new Denso pump.

So I am REALLY, REALLY curious what I find when it stops bloody raining here and my daughter stops scheduling things on the weekend so I can ignore the world and tend to my poor baby.

I know when I tried to start in a silent location (not the side of the highway !), I could not even hear the pump fire up like usual. So either I have no 12v to the pump or some debris did jam the whole works and it can’t even spin. All I know at the moment.


The fuel pump went silent on me more than a few times over the past 19 years of XJ6 and XJ12 ownership. If this happened to me again the first thing that I would do would be to access the fuel pump, remove both of the leads, and apply 12 VDC from my portable battery jumper to see if the fuel pump worked. If it didn’t work I would reverse the leads several times alternating running the pump in normal and reverse directions to see if I could dislodge whatever might be jamming the pump. This method worked for me a few times to free up stuck fuel pumps.

If the pump works fine the instant you apply power then I would troubleshoot elsewhere like the fuses, relays, and inertia switch. I’d say the majority of times my fuel pumps did not come on when they should have was supposed to was because of a stuck fuel pump and most times I was able to clear the debris by reversing the power.


Thanks Paul!! Ha ha - I envision another mystery switch on my dash that causes the pump lead polarity to be swapped. I can toggle it once a week to reverse flush the system… love it!

1 Like

The change over switch in this instance is the tank switch in the dash, with no power to this there is no power going to the FP on a S11 I have still to identify which fuse is the culprit as I have been helping Daughter and SiL with the roadside flower selling for valentines week

Obviously, I approve of the installation of the two inline fuel filters. However, I would recommend removing the in-tank strainers altogether. This is not a belt-and-suspenders thing; the inline fuel filters are quite reliable and won’t fail to keep crud out of the valves and pump all by themselves. The reason I recommend removing the in-tank strainers is to permit any crud in the tank to move along into the inline fuel filters and get sequestered there. If you ever need to replace those inline fuel filters you’ll be removing all the crud that ever found its way into the tank.

1 Like

Did you try cranking in gear (‘R’ or ‘D’), Randy - it’s easier to hear the pump without the cranking noise?

If the pump doesn’t run; the quick-test is to unplug the fuel relay and short between white and white/green. This bypasses some functions, and the pump should run with the ign ‘on’. And gets you going to wherever you want…

If this works the pump; you have an electric fault - relay, ign key or diode pack…to be pursued. With your clean-up and a new pump; a mechanically stalled pump is unlikely, so it is pertinent to check white wire for power with ign ‘on’…

xj6 85 Sov Europe (UK/NZ)

Quick update… got a few minutes to tinker on my problem and still a bit perplexed. Putting the shifter in R and cranking with a voltmeter across the pump terminals showed a good 12V. Also, the pump appeared to be running although making a couple odd noises I thought. I then cranked and to my surprise it started, whereas it had not at last visit.

But after about 30s, the idle got very, very lumpy/stumbly. A little gas on the pedal helped but still rough. It idled for about 2-3 minutes and then just flat out stalled. Started again and same behavior… ran rough for a short time and then just stalled. I was watching the voltmeter as she stumbled and stalled and solid 12v all of the time, so I don’t think I have any flaky electricals causing notchy pump performance.

Really seems like a fuel delivery issue. My helper (key cranker) had gone so I went back into R and cranked. This time I could not hear the pump. When she was running well a few weeks ago, I usually primed the rail using the crank in R and I could always hear a very distinct whirring of the pump as it ran.

So, I think I will throw money at the issue and just order a new pump and swap out. A fairly easy initial thing to try.


You’re on track! With 12V to the pump but intermittent fuel pump operation that must be your problem.

Reversing the pump should, by the way, only free up a jam as it’s a roller vane type. And easily jammed, too. Reverse flushing won’t work by nature of the whole system anyways. Good luck!

Which may not solve anything, Randy…

Apart from a defective pump, you may have either of following electric problems. *Ignition key powering the pump only in ‘crank’ - engine starts but runs out of fuel as the pump does not run with ign ‘on’. *The reed switch in the AFM fails to operate, or the diode pack has failed - both will run the pump in ‘crank’ but prevent the pump from running with ign ‘on’. Engine starts, but runs out of fuel after some time, and quits. *The relay may intermittently fail.

Bypass the relay; connect white to white/green on the relay base the pump should run with ign ‘on’. If not; check for power at the white relay wire - and/or at the white/green at the pump. Both should have power both in ‘crank’ and ‘on’ - a test lamp is preferable to just a voltage check. If no power; pursue the cause of loss.

If pump is powered but not running; replacing the pump is fair enough…

With power and pump running with the relay jumped - with the relay in place; remove air filter and prop open the AFM flap. The pump should run with ign ‘on’ if not; the reed switch or the diode pack has failed…

If jumpwiring the relay works the pumps and runs the engine - you can run with this setup - while you muse further actions…

xj6 85 Sov Europe (UK/NZ)