January 26 Upgrade

Am I the only one who thinks opening individual topics and going from one place to another on J-L just got slower?

I don’t see any cosmetic issues.

I just went to respond to a message and temporarily couldn’t. I felt flush like it was the end of the world. Don’t ever go offline for maintenance ever again Jag Lovers lol

1 Like

That is entirely possible, because the PostgreSQL 13 database engine is working hard in the background on housekeeping tasks after the upgrade. It’s currently pegging 8 CPUs close to 100%, and using around 16 GB of memory.

Once things calm down, performance should hopefully be back to normal.

Hi Gunnar,

just tried to reply and twice the draft just disappeared - wormhole to the parallel universe, Mark Zuckerberg’s hunger for data or Russian sabotage?

Thanks for your work!


That’s worrying. I’m hoping it’s caused by the background housekeeping, and not a bug in the new version of Discourse. We’ll have to keep an eye on this, especially once the housekeeping is done. Which looks like it could take a while (hours, maybe a day).


Well, replying to you went well - twice now!

Let’s hope it was just my clumsy fingers or some strange coincidence!

Keep the faith


I’ve had the same thing happen several times, sometimes when replying to a PM, if that matters. And few time while typing a reply I get a screen that says “the edit is going to another screen” or something like that and then what I was typing goes to message heaven. Just disappears.

Edit: Just had it happen again. Typing a new post and suddenly this appears.

I clicked on reload and what I was typing disappeared along with the composing block.

Were you using a desktop, a tablet, or a smartphone when this happened?

Desktop, Windows 10…

Edge? Or Internet Explorer?

Using Edge …

OK, good. Had to check … :wink:

So far I haven’t seen the same problem myself, using either the desktop or the mobile interface. So, this is a bit of a mystery at this point.

Could accidently striking a particular combination of keys cause it?

I had a draft of a post, a few minutes ago, and five times when I tried to submit it, I got a "429 error. "

I guess, although I’m not sure what that would be. Even if you accidentally hit Reload Page, the message draft should have been saved.

The database housekeeping tasks are still running, and the server load is quite high, so that could also be contributing.

I just got one of those as well now, when replying to John’s post. That one is easy to troubleshoot, though:

The HTTP 429 Too Many Requests response status code indicates the user has sent too many requests in a given amount of time (“rate limiting”). A Retry-After header might be included to this response indicating how long to wait before making a new request.

Now, some witty tongue might say that you and I are just being too … wordy, but I think it’s pretty clear this was caused by the database jobs. The server load is very high right now.

1 Like

It’s not a big deal Gunnar!

I figured it was just all part of what was going on in the background with the database upgrade. I just thought you might like to know it as a data point.

1 Like

Yes I had the same today, and it takes time to load sometimes so I copy my text to clipboard from time to time when it gets too long (always is, I know!)

But the “$@&! There was an engine in there!” Is always nice to see…

My message was only about 25 words, so not long.

I showed that to my kids the other day and they recognized it from 20 years ago when we lived in Denmark. Two of them have their own kids now!