Mark 2 Wipers won't stop


(Steven Bruce) #1

The wipers on my 1962 Mark 2 stopped working. The wiring coming out of the wiper motor looked pretty dog-eared, ( like 57 years old) so I sent the motor out to be rebuilt. I re-installed the motor - no motion. I then replaced the dash switch, and tried again - a little hint of motion, but non-functional. I spoke with the rebuilder, who said the cable in the housing leading into the car was probably all caked up with old grease and not moving well, and there was too much friction to move things. So, I removed the cable, lubed things up, and tried again. Now, the motor moves fine, at both the low and high speed settings, but starts to run as soon as the ignition is turned on, even with the wiper switch in the off position. I suspect this may have something to do with the park switch, but playing with that switch (next to the cable attachment to the motor), i.e. opening and closing the little contact, has no effect, the motor keeps running. Any ideas on how to get the motor to stop when the wiper switch is off?


(Robin O'Connor) #2

Not trying to be clever but are you sure the wires into the motor are hooked up correctly?


(Ian) #3

May be the replacment switch , have you tried the first one again ?


(KrissMotors) #4

The Mk2 wipers use a non-obvious 3-circuit wiring schematic:

Check all your connections between motor and switch to make sure that the terminals are wired correctly.
More details here.