New to me 1988 xjsc - can’t get the idle right

Hello everyone. I’m new to the forum and new to Jaguars and I’ve got an issue I can’t seem to sort out. So a quick rundown of what I’ve got going on. I recently picked up a 1988 XJ-SC v12, 41000 miles that was last registered in 2015 and hasn’t been run for at least as long. When I got it it started fairly easily with a fresh battery and was able to drive it home after putting new front brake calipers on to replace the old frozen ones. The car seemed to run fairly well but the first drive wasn’t long and being unfamiliar with the car I wasn’t in tune with what it should run like. So the plan was to go through and replace fuel hoses, coolant hoses, spark plugs and wires, distributor cap, vacuum lines, brake lines, rotors and pads, and refresh the ac. While I did that I cleaned up the engine. To get things looking nice I removed the intake manifolds and pretty much everything out of the valley to clean it all up. I put new intake manifold gaskets on. New fuel injector seals were installed when I replaced all of the fuel injection hoses. New o-rings were installed on the air injection tubes. I put new thermostats in and ended up replacing the water pump when I found it was leaking. I also rebuilt the AAV with a new wax bulb when I realized the old one wasn’t working properly. It’s an intimidating car for sure, but eventually everything was back together and it actually started. So, here is the dilemma- I can’t get the idle low enough. Once it was running again the idle wants to stay at around 1200. I found that if I disconnect the vacuum line from the rear of the right side intake manifold that goes to the vacuum advance system the idle would drop to around 900 rpm’s and if I then capped that fitting on the manifold the idle would lower slightly more to around 800-850 rpm’s. This seemed ok as far as the idle goes but I’d like to have the vacuum advance system hooked up and functioning as designed. And this was as low as I could get the idle, the bypass valve on the AAV is completely closed. Finally I started from the beginning to make sure everything was set appropriately. I checked the throttle valve clearance and set it to 0.002” and the throttle linkage is set appropriately. Then I checked for vacuum leaks everywhere and can’t find any. So then I plugged every vacuum line and inlet into the intake manifolds to see if I could get the idle below 700-800 rpm’s. I blocked off the AAV, capped all the inlets into the throttle bodies, capped all of the vacuum fitting on the front and rear of the intake manifolds and still no change. The last thing I capped was the vacuum line that goes from the back of the cross over pipe at the rear of the intake manifolds. This is the vacuum line that goes to the Absolute Manifold Pressure Sensor (AMPS) in the ECU? Finally a change! When I capped this fitting on that cross over pipe the idle dropped to around 400-500 rpm’s. My thought was that there must be a leak in the vacuum line that goes to the AMPS. But with the car off I put vacuum to that line and it holds vacuum. With the car running, and the cross over pipe fitting capped, when I put vacuum to that line the idle goes up. Now I’m really confused. Is this how the AMPS should be working? Should vacuum at idle sense by the AMPS make the idle rise? And why does the idle go down when I disconnect the vacuum advance system. I apologize for the lengthy post. I’m pretty sure I don’t have an intake leak and it seems like some component isn’t functioning properly but I’m not sure how to check the components. I’ve read through many forum posts regarding vacuum leaks and idle problems but just can’t quite zero in on the problem. I appreciate any advise. Hopefully you all can make sense of what I’ve tried to explain.

Check your Throttle Position Sensor voltages, details in the Book.
Also check that the throttle pedestal doesn’t keep the throttle open.

Maybe a faulty ECU?

Good luck and welcome to the forum.

Thanks for the reply. Since the problem doesn’t seem to be a vacuum leak I’ll start looking at other things. I’ll check the throttle position sensor.

Ryan

It’s taken a few days but finally found some time to do some more sleuthing on the jag.

I checked the voltage on the throttle position potentiometer. Initially it was a tad off but with a little adjustment it is now properly set. I also double checked the throttle linkages to make sure they were all adjusted properly. None of this changed how the car idles. It still wants to idle around 1200rpms.

Just to double check the integrity of the vacuum systems I went through and checked that various components held vacuum, as described in the Jaguar XJ-S Engine Performance manual ( https://jl-discourse-uploads.s3.dualstack.us-east-1.amazonaws.com/original/3X/e/e/eed72f1a32a5d70fd8e36170d244085d504a1666.pdf ). These things all hold vacuum.

So I feel like I’ve narrowed down the issue to a problem with either the vacuum advance or the ECU/manifold pressure sensor. If I disconnect the vacuum line for the vacuum advance from the rear of the right side intake manifold the idle will drop from 1200 to around 900. And then if I plug that port on the intake manifold the idle drops to around 750-800.

The other way to get the idle to drop is to disconnect the vacuum line for the ECU/MPS. Doing this drastically drops the idle and if I disconnect the line and plug that port on the cross pipe the idle drops down around 500. The other thing that happens is the exhaust starts to smell a bit rich, like fuel.

So would a faulty ECU or manifold pressure sensors cause a high idle? And if so what is the mechanism that causes the high idle? Does it change the timing, or fueling?

I’m almost at the point where I may buy a refurbished ECU to see if that makes a difference. If anyone is in the Portland Oregon area and has a known good ECU they would let me plug into my car let me know.

Ryan

Disconnecting vacuum advance is simply retarding the timing by about 10 degrees, so that lowers idle.

Disconnecting vacuum to ecu simply makes ecu run richer and confuses ecu, which seems to lower idle.

Usually when car refuses to idle lower, its a stuck open AAV.

You need to plug pcv valve, plug aav air intake, and cap vacuums except for vacuum advance and fuel pressure regulators. Your idle should drop to 400rpm or so. Slowly introduce vacuums and see how much each increases it.

Another quick test, make sure your fuel pressure regulator on B bank is working. Disconnecting vacuum (and plugging hose) should increase rpm with fuel pressure increase. If no change, your fpr is not working.

Another quick test, see what vacuum is being delivered at ecu. If it doesn’t match vacuum at air intake, then vacuum line to ecu is leaking, causing ecu to enrichen mix causing rpm to go up.

Also make sure your full throttle switches are working. They enrichen fuel and cause rpm to go up, if they’re triggered.

1 Like

Greg - thanks for your explanation and suggestions. So I went back and checked idle with all vacuum ports capped (aav, pcv, cruise control, transmission module, climate control, etc.). I left connected the vacuum advance, the fuel pressure regulators and the line to the ECU. In this configuration the car will start and idle at around 900 rpm for the first 45 seconds, then rises to 1200 or so.

I did initially do this test with the vacuum advance module connected directly to a vacuum port and bypassed the vacuum regulator and the dump valve and all of that subsystem. The car ran the same so I don’t think there are any leaks in that system.

I checked that there is manifold vacuum at the ECU so the vacuum line from the engine to the ECU is clear and it holds vacuum.

I believe the full throttle switch is functioning properly - when triggered at full throttle the switch is closed (zero resistance). When it is not triggered at idle the switch is open (no continuity)

I did check the B bank fuel pressure regulator and when I disconnect it from vacuum I don’t notice any changes in the idle or how the car runs. You suggested this would indicate a faulty regulator. Would a bad fuel pressure regulator cause the car to idle 400 rpm high?

Thanks for your help. I’d really like to try to figure this out without taking the car to a shop. But I also don’t want to just throw parts at it.

Vac advance capsule diaphragm split, causing vac leak?

I had this once.

Rob

Robert - I don’t think that’s it. The capsule will bond vacuum, kind of. My understanding of the vacuum advance capsule is that it kind of holds vacuum but it has a vent that will let the vacuum slowly bleed off. If I suck on the vacuum hose to the capsule I can feel vacuum on my tongue and then it slowly goes away. The other reason I don’t think the capsule is the cause of an excessive leak is because if I disconnect the vacuum line to the vacuum advance at the rear of the right side intake manifold the idle will drop, and that is without capping the port on the manifold. If I cap the port on the manifold the idle will drop a bit more but not as much as just disconnecting the vacuum advance line. It’s got me stumped

Another question Greg. Would it be very likely that the fuel pressure regulator was bad if it hold vacuum and there is no signs that it is leaking? And would fact that the car is idling so high be the reason I don’t notice a change when I disconnect the vacuum from the regulator? Sorry to ask so many questions .

So IF the Fuel Pressure Regulator was leaking, it would

  1. apply a higher pressure to the fuel injectors, causing a richer idle. When I pull my vacuum line and plug it, I go up maybe 100rpm?
  2. that vacuum line is now a vacuum leak
  3. that vacuum line could be sucking fuel, causing even a richer idle?

If it’s the original FPR, I would replace it. They are only about $75 I think (Bosch or WVE) and quite important to this car. The ECU has no idea what the actual fuel line pressure is, it just assumes what it is based on what the vacuum reading is.

It’s going to take a lot of trial and error to figure this out.

also, this seems backwards. The first 45 seconds, the extra air valve (on back of A bank air box) opens raising the idle. Then after 45 seconds it closes and the idle comes down. Perhaps this (and it’s complicated) system is hooked up wrong.

As a quick test, find the vacuum hose going to this extra air valve, and plug it up. It’s quite a big vacuum line that comes from bottom underneath of throttle body on A side.

On mine, it idles at about 1100 when cold, and then in 45 seconds settles down to 900 when cold. Eventually once warmed up, idle settles down to 750-800rpm.

Well this is interesting then. I’ve looked at this system several times. I thought I had it connected correctly but perhaps not. I can check that again.

I need to clarify one thing. When check for vacuum leaks, you suggested plugging all of the vacuum lines except the vacuum advance and the fpr’s. And the idle should be down around 400rpms. Is this with the ECU vacuum hooked up or do you also disconnect and plug the vacuum to the ECU? Because the idle will drop to around 400 with the ECU vacuum disconnected.

Since you verified the vacuum line to ECU is not leaking, then that would be with that line connected. You need the ECU to get the vacuum reading to run properly. It drops a lot with that line disconnected only because now the ecu is over fuelling, so much that it barely runs.

That 45 second timer is a strange connection. I made some mistakes on it once, apparently it always has 12V +. The 45 second relay trips the ground to turn it on.

Simply plugging up the vacuum line will confirm. It’s not totally needed, IMO. It’s mainly to help heat up the catalytic converters after starting, and to give a bit more RPM if the AC Compressor is turned on. I keep mine only because I like a high rpm for 45 seconds upon starting :slight_smile:

So I’ve rechecked the vacuum advance vacuum lines and I’m pretty certain they are plumbed correctly.

As far as the 45 second timer, I’ve ran through a couple of start up cycles and I think things are working as designed. For the first 45 seconds I can feel vacuum at the supplemental air valve. This would allow extra air into the manifold for the first 45 seconds. After 45 seconds it closes. This is the correct function yes? The other thing that happens for the first 45 seconds is the solenoid vacuum valve in the vacuum advance system is closed. After 45 seconds it opens and then the vacuum advance capsule gets vacuum and that is when the idle jumps up 300-400 rpm’s.

Is it possible the timing is set way too far in advance and that is what’s causing the high idle and the reason it settles down close to 800-900 when I remove vacuum from the vacuum advance?

Ahh, i forgot about that contraption. I disconnected mine. The ONLY reason they did that was to retard the timing for 45 seconds so the catalytic converters heat up faster. If yours is 88 like mine, we have heaters on our O2s, so don’t even need that.

But it sounds like your supplemental air valve is working correctly.

Yes, too much advance could cause RPM to go up. But if it was that far advanced, I would think you’d hear pinging when giving it gas? Have you checked timing with a timing light?

I would replace FPR regardless, if it’s original. It’s 36 years old. They don’t last that long. I’d then verify that your timing is right.

Oh, and I can’t remember if we verified this or not, but did you set your throttle stops to 0.002"? This is very important, and could easily add 400 rpm. They are practically closed at idle.

Another possibility, and this is hard to be for sure, your intake manifold gaskets could be leaking. This would be my last guess after everything else checks off fine.

Greg - thanks again for all of your time and your help.
I did check the manifold for leaks at the gaskets. I’ve had the manifolds off as well as most everything out of the v on top of the engine. I wanted to clean all of that up. It has new manifold gaskets (the individual inlet kind), new injector seals, new fuel lines. I checked for manifold leaks and air leaks around the injector seals by spraying starting fluid around each one. I don’t think I have leaks there. And I’ve also set the throttle butterfly valve clearance as well as set the linkage. And I’ve got new rubber bushings on the throttle linkage.

I also did set the timing with a light. I believe it was right around 16 - 18 degrees at 3000 rpm? It’s hard to see under the car so it’s possible that this is off but I haven’t really moved the distributor base so it’s hard to image how it could have gotten very far off. And I have driven the car with it like this and have never noticed any pinging.

Perhaps a new fpr is what I need to do next. I also considered putting a fuel pressure gauge in line so I’d always know what the pressure is.

It’s a bit of a guessing game from our perspective…you will eventually figure it out. These XJSs unfortunately aren’t as simple as an old carburetored engine, but not as smart and helpful as a newer engine.

I would read as much as you can from The Book and these forums, you’ll be the one who finally figures it out. I went thru similar process when i first got mine. Almost gave up several times, but these V12s are a giant puzzle to solve. In the end, worth it.

Definitely a big puzzle. I do like the v12. Quite a car. I’ll keep plugging away and I’ll try to remember to post what I do. I get frustrated when people post about a specific problem and then they don’t really ever post how it was resolved or what they did in the end. I know we all get distracted but I’ll try to follow through.

I’m pretty sure I don’t have a vacuum or air leak. I think the next thing is to check the fuel pressure and eliminate that as an issue. Then I’ll double check the timing and last maybe think about a new ecu.

Thanks again Greg.