Noooo it does not start anymore

I used my xj40 2 weeks ago. it was starting perfectly as usual. and a drive for 20km without any problem. Then i parked it and as it was cold i disconnected the battery for precaution. today as i want to drive it, i reconnected the battery and try to start but it failed. the starter motor was a little tired so i thought it was just a low battery, but after trying first with my jumpstart and then with cables to my other car the xj refused to start.
I charged completely the battery and now the starter motor revs perfecly and very fast, but there in no sign of ignition. i ear the click of the fuel pump relay . What can i check? all dashboard lights are ok the car is in park the … it’s like there is no fuel or no sparks… i don’t know…
maybe a blown fuse? of what else?

Andrea …

Three things to check …

  1. When cranking the engine does the tachometer show any rpm (something like around 200)? If not your crankshaft position sensor (CPS) has failed.

  2. Replace the distributor cap and rotor … It’s such a common failure you should always carry a spare set.

  3. Do you hear the fuel pump run for a second or two every time you cycle the ignition off and on without actually engaging the starter? If not, your fuel pump may be failing.

1 Like

i cannot see any rpm raising while i cranked the engine , but also i cannot ear the fuel pump…tomorrow i will recharge the battery try again and make a video… where is the fuel pump located maybe i just not ear it…

This means your crankshaft position sensor has failed -or it’s connector needs cleaning. Usually it’s the CPS.

can you suggest where i can buy it at an affordable price?

Here are some discussions on the subject:

https://forums.jag-lovers.com/search?expanded=true&q=%23xj40%20in%3Atitle%20crankshaft%20position

Was a 1992 car an intank pump or external pump car? If in tank might be hard to hear it run?

Should be intank.

The original poster did not actually say what year of car he has so really it could be either intank or external.

I still think the failed ignition rotor is the more likely cause.

His profile states ‘92 4.0 so I am assuming thats the car he is talking about.

Well I was occupied by work so I did not tried to start the XJ again, yes it’s a 1992 4.0 .
I tried again today with a fresh charge. The cps is ok as I saw 200 rpm while cranking the engine, so it can be the fuel pump or rotor . The fuel pump relay click but I cannot ear any noise from the pump… maybe it’s stuck? How can I check it ? The problem is the XJ is in a public park underground and the rescue truck is too high to enter inside to pick my car!

You can try these possible things - no guarantees but sometimes …

  1. Swap the oxygen sensor heater relay with another similar relay

  2. In the passenger side footwell fuse box, unplug and replug the connectors.

Also you should be able to use a phillips screwdriver stuck into the end of a HT lead while someone cranks the car to see if you have spark. Just be careful to not shock yourself while doing this.

Andrea …

I know just replacing the distributor cap and rotor seems like an old wives remedy but believe it or not on this car it’s right at the top of potential causes of a “no start”.

Take Steven’s advice and check for a spark coming from the ignition coil going into the distributor. If that checks out now pull out one of the spark plug leads and check again. If you don’t have a spark now it’s the distributor / rotor that’s at fault.

There should be a really healthy spark so make sure you do’t shock yourself during the tests. I always wear a pair of thick gloves when I do this.

If it passes these tests I’d start looking at fuel pressure at the fuel rail next.

You need to check if you have a spark at the plugs. Next time you go to the car park take a spare spark plug with you, pull a HT lead from the most convenient spark plug and connect the spare plug to it, crank the engine with the plug earthed onto the engine block.
If you have a bright blue spark then it’s a fuel problem. If you don’t see a spark change the cap and rotor arm.
Check the plug that supplies the fuel pump, it’s situated on top of the fuel tank, pull it open and look at the spade terminals inside, they have been known to get hot and melt the plastic causing a bad connection, the same thing happened to my 93 Sovereign.

excuse me where i can have access to the tank , from the boot?

Yes the tank is in the boot. This following will only apply IF you have an 'in tank ’ fuel pump, the power lead / connection for the pump is on top of the tank. You need to pull the spongy black foam sound deadener out of the way to access it. Find the wiring on the top of the tank and locate the plug, separate the two halves of the plug and inspect inside it, on my car one of the spade connectors was burnt away and the plastic melted, other members have reported finding the same problem too.

Andrea …

Before you go digging around in the trunk getting to the fuel pump connections have you check for ignition spark ???

Unfortunately since the fuel pump on your '92 is located in the fuel tank if it needs to be replaced the tank has to come out. Not that easy a job because there are two retaining clips under the car that secure the fuel lines to the bottom of the tank and they are a pain to get to. Also when removing and refitting the tank the filler spout is a pain to deal with. Bottom line fingers crossed it’s not the fuel pump.

If Jaguar had any decency when they moved the pump into the fuel tank they would have designed some type of access panel through the rear package tray.