Strange test drive today

Today my adult son wanted to drive the Jag since it he hasn’t driven it since I first acquired and before I did any of the refurbishment of it over the past year. Initially, I underestimated how warm the engine was after a short drive down the street and when showing him how to feather the choke off, it went to a very low idle (under 600 rpm) and stalled. I had him put 1/2 choke on an it started right back up and we had an enjoyable drive together and as we drove we were able to close the choke completely.

When the car was in the driveway, I asked him to assist me in checking that all the lights worked since it is dues for its state inspection. Everything except the headlights worked great. Is suspect a loose wire and/or blown fuse and that will take further investigation tomorrow. I had him leave the car in the driveway, since I didn’t trust him to pull the car into the garage next to my wife’s car.

About a half hour later I went out to start it and pull it into the garage. When I turned the key, without using the choke or touching the accelerator, the engine fired right up but went up to 3000 rpm’s in a second. I immediately reached down to grab the accelerator thinking it might be caught on the carpet, but it wasn’t. I then turned the key off and the engine stopped.

I then popped open the bonnet thinking that the accelerator linkage might be snagged or needed lubricated, but it too was not bound up nor pulling on the carb linkage. I then went over to the carbs thinking that the pistons or butterfly valves might be stuck. After removing the plenum, I could see that the pistons were shut and by playing with the linkage, I could see that the butterfly valves were closed and not stuck in any fashion.

By way of background, on Friday I took the car out for a long test drive, warm enough to turn the choke off, but when I would come to a stop sign or traffic light, it would drop to 500 rpm and then stall. When I got home, I adjusted the carb mixture screw open another 1/2 turn, bring it to a total of three full turns from closed. After the incident today, I closed the mixture screw back the 1/2 turn I had adjusted and this time when I started the car it immediately jumped to 1500 rpm with no accelerator or choke usage.

Rather than play with the car in the sun outside, I was able to get it back into the garage without touching the accelerator, because when I did, it seem to rev very quickly and very high. About two months ago, I reinserted the spring in the pedal housing because I didn’t think the accelerator was rebounding fast enough when I let off the pedal. But this issue has me totally confused. Thoughts?

This isn’t really likely but. . . .Has the car been converted to triple SUs? Sometimes the linkage under the front carb would hand up on the upper frame rail if a motor mount had collapsed or the engine wasn’t properly centered on the engine mounts.

3000 rpm is very high

The Strombergs have the throttle bypass on overrun and if they stick open, this could cause high idle, but I don’t think 3000 rpm. Have you rebuilt them or blocked them off?

If it were my car, I would take the carbs off and check them. There might be something keeping the throttle(s) open. And it does not take much opening to get to 3000 rpm with no load

69 OTS without Strombergs

It was triple SU’s when I acquired it, so yes.

Engine mounts seem ok to my eye, but I’ll get under the car tomorrow. From what I can see and feel, all three carbs are free and the linkage responds to moving it as if I were accelerating and then backs off immediately. But I have noticed recently that when I let off the gas when shifting that sometimes the rpm’s would stay high or maybe slip a notch higher, but then I shift and off we go. Today was an exaggerated example of what I’ve seen on a smaller level.

Easy enough to check. Visually check the clearance between the frame rail and the moving parts of the linkage. and visually examine the frame rail under the linkage for evidence of interference; scrapes, scratches, etc. .

Assuming you are familiar with the fast idle/choke linkage joining the 3 carbs. The little cams that actuate the fast idle when you pull the choke cable can climb out of their tracks and make the fast idle stick. I would check the operation of your choke linkage.

I’m assuming you have the three springs on the throttle shaft. hooked up? The front two hook onto brackets attached to the carbs and I hook the other one onto the block. They do an excellent job of returning everything to idle. PB Blast every linkage and pivot point that you can see and that should help.

It’s a longshot, but check your throttle linkage where it passes by the center safety latch for the bonnet. Mine was dragging on the latch and caused weird idle problems. It took me a while to figure out why the idle was only a problem with the bonnet closed…

Take off the domes and sight the jets with the key on. Watch for puddling. You may have a leaky diaphragm or sinking float.

1 Like

Thankfully, this wasn’t the issue. I did a complete visual inspection and see no signs of interference with the frame rails.

That is correct, all three spring were/are connected…more to come on this topic.

Thankfully, this wasn’t the issue either, but it did have me concerned as I recently replaced the spring latch on the bonnet as the old one was bent and not catching properly, but this wasn’t the issue.

Thanks for this tip too Michael. I opened up each carb dome and looked for signs of puddling, but since the carbs were recently rebuilt (by a professional) there was zero sign of any issue here. I also had the nitrile floats installed to prevent a float issue.

Kris, it was this last part of your suggestion that caught my attention. All of the carb linkages are new since when this car was converted to triple SU’s the PO made a sloppy weld to try to create the linkage to operate all three carbs, when I removed the carb for rebuilding I noticed that it had issues with clean rotation, I bit the bullet and bought all new Burlen linkage. However, when I reconnected the springs that attach to the brackets that extend down towards the frame rail/engine block, I mounted two of them correctly and one of them pulling in the wrong direction. As a result, two of the three springs were attempting to close the butterfly valves when I let off the accelerator, and one of them was trying to pull it open. It was a dumb oversight on my part, but now corrected.

Thanks to all for ideas to chase down that resulted in me trying everything and finding the culprit.

Now I need to figure our why the headlights aren’t working. All fuses check out as working and all wiring is plugged into the new switch and the switch tests properly for switching on and off. More detective work is necessary before I can take the car in for the state inspection.

1 Like

Check for power in and out of any relays that may be in line as well as grounds. I suspect a dirty connection somewhere and should be easy to trace

1 Like

Just got done studying my handy dandy wiring diagram, which lead me to remove each fuse and test for continuity - CHECK. Then test for power at the switch panel for the headlights and side lights - CHECK. Which them lead me to the Dipper switch and lo and behold a wire had come unplugged from the Dipper switch. Plugged the wire in and voila headlights work!!!


Ain’t these cars fun? :grin:

1 Like

A laugh every day… (or a bad word(s). :joy:


Bob… I feel your pain, only for me it’s the horns. power to the relay (new), relay clicks when the horn button is pressed, 12 volts out of the relay, no noise… bought new horns, still no noise… beating my head on the wall, still no noise, but it did feel better when I stopped… LOL

Don, when I had my horn problem it was a multi-level problem. The first issue was my horn button, which on a Series 2 is on the turn signal stalk. Not only was the stalk button not working, the PO had cut the wires to the horn under the dash and wired in a push button that he attached to the home made bracket he used to hold the ignition key switch.

After that was repaired/replaced, I discovered that the relay was barely working, so after filing the points, and the horns still barely working, I purchased a new relay, still the horns sounded like a sick cow.

So I removed the horns from under the car and tested them on my bench with a 12 volt transformer that I have for testing. One didn’t work at all and the other was the sick cow. So I purchased new ones installed them and they barely worked. After much fiddling, I discovered that they each had bad ground wires. I removed the old ground wires and created new ones with ring terminals that I affixed to nearby bolts on the picture frame. Amazingly, after countless hours I had two new ground wires, a new relay, a new turn signal stalk button and very loud operable horns.

Since you have a Series 1, is your horn button on the center of the steering wheel? Have you tested that switch?

Hi Bob, I have tested everything I can think of… new relay, I can hear it click when I push the horn button, checked voltage at the relay from fuse 3 and fuse 6… bought new hella horns and tried to make them work by connecting to the car battery… nothing… battery is charged up enough to start the car… not sure where I need to go next… without a horn, no safety inspection, no license… no driving… and I am getting older everyday, and I need to get out and drive the lovely beast… but I’m not dead yet so I will continue to look…

Don you are welcome to bring the horns down to my garage and we can test them on my 12 volt transformer. Do they have a polarity? Given that the new horns won’t worked when jumpered to the + and - terminal of the battery, that is weird. Hard to believe you received two bad horns at the same time.

Do I recall that you replaced the horn relay?

I suspect the grounds to the horns. You might have a picture frame that’s isolated from ground.