Very strange ignition problem - really need some help!

After three odd years I have my fully restored S2 2+2 ready for the road, but I have this very strange ignition problem to deal with.

Engine warm and at idle I slowly and steadily increase the RPM. At around 2000 (guess) I hear a slight miss, as the RPM increases the miss is a bit more noticeable. Around 3000-4000 the engine looses all power and starts to crap out I back off the throttle and it recovers.

I could write a Thesis on what I have done to trouble shoot this, suffice to say it is not fuel related. I’ve tried a new coil and Pertronix with no joy.

Important point to note is that the tac did work when breaking in the motor, now it does not. Well, every so often it sort of works then dies again. I have confirmed power to it.

Before I do any more trouble shooting, I need to get the tac working so I can see where the RPM’s are when the motor dies.


  • Could the motor crapping out be related to the non working tac, or the other way around?

  • Any suggestions how to dive in to the non working tac? I’m “okay” with wiring, but not great

  • I’ve read that Pertronix and E type tacs do not like each other, any comments/suggestions?

Thanks all, I could really use our help on this one!

Looking at the schematic of the tac. There are three wires

Via a connector/pig tail gizmo there is:

A Green from a fuse in
A White from a fuse in
A White out from the tac that goes to the coil

What do you think if I pull the connector apart, and jumper the two wires coil side to by pass the tac to see if the problem goes away? I’m wondering if maybe something in the guts of the tac is limiting the RPM’s?


Rotor or cap?..

I would try a direct hot wire from battery to coil to see if problem persists. Checked engine ground? Ignition timing properly advancing? New plug wires as recommended by pertronix? A friend put potatoes in your exhaust?

Pat on the Ser II cars the tach wire isn’t actually a tach wire. It does directly from the ign switch to the + side of the coil, through the coil, through the points to ground. Enroute it has a small loop of wire that goes through a bracket on the back of the tach which is an inductor (is this the right term) that reads the number of electrical pulses going through as the points open and close. If the tach doesn’t work it’s either an internal failure which has nil to do with stopping the car from running, or there is a problem with power going through the wire and being read. Your problem may be the Pertronix - memory is fuzzy, as I recall it’s wired differently than on a points car. I have diagrams but they are at home. Not back till the 6th of Mar. Maybe somebody knows. Try searching the data base here for this question. Pretty sure it’s not the first time it’s been asked.

1 Like

Do you have repro Champion plug caps fitted?

Pat there is a lot of info re pertronix and tachos on this forum.The series2 tachos may have the wire loop on the back of the tacho or inside.When fitting a pertronox dis on my 69 2+2 i was able to get the tacho reading by removing the loop in the wiring.On my tacho the loop was internal.You cant get into trouble going into the tacho.This has not worked for everyone.Also remove the ballast resistor beside the coil which i presume has the correct resistance for the pertronix dizzy.if not this may be your problem

40 years ago I had a series 2 E type. I remember the tacho stopped working and I went to an instrument repair shop who removed the tacho. Result was engine would not start. The tech made a bridge in the circuit and I drove around for a week with this in while the tacho was repaired. So Yes, the tacho can and does affect the ignition.

Pat, you say it starts out with a slight miss, then looses all power. You do not say it misses terribly at that speed. Good ideas above, but, as you describe it, it does not really sound to me like ignition cutting out, that would be more abrupt, IMO. It almost sounds to me like it is running out of fuel, or even more, just plain being choked off. This is an S2- do you have the original manifold with secondary throttle plates? If so, I wonder if one of your secondary throttle plate linkages is fouled and not opening one or both of the secondary throttle plates. That possibly would cause your symptoms???
Good luck.

Anyone think a Colortune might help trouble shoot the issue ? Since it is a glass top spark plug you can see the spark and flame in a cylinder. Might help confirm if you have good spark and if so a good idea about the mixture level in that cylinder. Just a thought.

I have Pertronix in my '68 and Tach has worked fine for many years now after my initial internal repair. I know there have been bad batches of those CHAMPION spark plug end caps and with ignition rotors. The last time it was running rough I found the metal arm on the rotor was loose. I put in an old one with a firmly attached arm and it solved my problem.

68 E-type FHC

Oh my, such great thoughts/ideas thanks. In reply to all your questions:

  • At warm up and the first 1500 Rev increase car is smooth, then a slight miss until I reach the 4000 (est) mark where it suddenly looses all power and dies, unless I back off the throttle. No serious miss at high RPM
  • Yes I have the repro Champion plug caps and new copper wires with NGK resister plugs
  • No ballast resister
  • I tossed the Strombergs and put on fully restored SU HD8’s (carbs are perfect, but heck you never know right). Due to the SU’s going on no secondary throttle plates are installed so it’s not them.
  • Timing is spot on and tested (by someone who knows what they are doing :slight_smile: I’m not too good at this stuff.
  • Dizzy vacuum advance works fine

I appreciate all your help all

Have you tried a replacement coil.

Sure have, and a new set of Pertronics, and cap, and rotor, advancing timing to the max advanced.


When you changed to SUs, did you change the distributor from the version designed for the Stromberg setup? If not, you may have a distributor with 40 degrees of mechanical advance at 4000 rpm. If you’ve set it up with 10 degrees static advance, you will have 50 degrees mechanical advance at 4000 rpm, which is way too much. Perhaps you can give us details of the ignition system (distributor model, vacuum advance or vacuum retard or no vacuum capsule, coil resistance, Pertronix etc) so we can understand what you are working with. I suspect that may result in an “Aha” moment…


1 Like

Interesting idea David, thanks. My car was a project car where half the stuff was missing including the dizzy so lots of unknowns.
The distributor is a 22D - is this the correct one? I’ve no idea…
It is Vacuum advanced the functions
Coil is 30 (Is a flamethrower coil needed for the Pertronics)

Can you remove the Petronix and try points? No restrictions in the fuel lines? I can feel your frustration, I chased a similar problem for over a year and it turned out to have been right in front of me the whole time.

Not sure if a Petronix still uses a condenser/capacitor, but my Healy did this exact same thing as the Cap broke down with rev’s. A replacement ordered from M@@S went bad in days. Had an old one laying around, fixed.



I take it from your posts that we shouldn’t assume that your current configuration has ever worked properly, so we aren’t necessarily looking for something that has changed recently. Also, your setup is not stock for your car, so again, assumptions are dangerous. First step should be identify what you’ve got. You need to find the model of distributor you have installed. This will be a 5 digit number (such as 41322 for example) which will be stamped on the body of the distributor. 22D is just an indication of the distributor family, and doesn’t provide the information we need. Once we know which distributor you have, we need to verify the mechanical advance is working - your symptoms might suggest the advance weights are stuck. We can do a quick test to verify the mechanical advance is working. Are you sure the vacuum capsule is an advance module, and not a retard module? In 1970 Series 2s, a retard module was fitted from the factory. Then the coil. What do you mean by the “coil is 30”? Do you mean the primary resistance is 3.0 ohms? Are you using points and condensor in your distributor, or (as seems likely) a Pertronix pickup? If you are using a Pertronix, which model? Pertronix advise against using copper plug leads, so that could certainly be an issue. Once we know what you’ve got, we should simplify the setup as much as possible (e.g. disconnect and plug the vacuum connection to the dizzy), and then carry out a systematic series of tests. That should get you there. If we don’t do that, one of the multiple “shots in the dark” (try this, try that…) may work, but you may go round in circles for ever. Just my 2c…

1 Like

Pat is this happening under load? May I suggest you turn the mixture screws down a turn and see what happens. Sounds a bit like a lean condition. What needles are in the carbs?

I would swap out all the spark plugs. It’s possible to get a bad new one and it’s an easy fix if that’s the problem.