XJR 95' no spark or fuel

Hello, jag-lovers!

Since buying my XJR 1995 I’ve been having an intermittent no-start issue. I concluded it was immobilized and made this forum post

After not being able to solve the immobilizer issue after much troubleshooting I decided to spend a lot of money on a reprogrammed ecu where the immobilizer function was disabled. The seller told me that as long as I got the car cranking, (which I currently get by probing ground to the pin in the bpm that makes CEL light up) it would start up with this ecu since it would not need a signal from the security module to start fueling.

Sadly this was not the case. I still have the same symptoms, No fuel (no 5-second prime when turning the key) and no spark (I have tried with starter gas and checked visually for a spark.). The fuel pump and relay works, and the spark plugs are all new. All ignition relays work.

I am now wondering if I have multiple faults, not just the immobilizer. I have already tried bypassing the inertia switch and swapped the cps to a new one. The tacho still does not go up when cranking which from what I read means the cps is not working, since I definitely have a working sensor could it be something else?

Worth noting is that I also have the gearbox caution light in the dash and my OBD2 reader shows me code p1791 which I think has to do with throttle position.

Very thankful for any help. The Jag is just collecting dust now which is a shame.

Best regards, August.

My trouble code list says P1791 is “Ignition supply malfunction.”
It is also important to ensure that your battery is fully charged. A low battery can cause all sorts of problems and fault codes.

Where is the car located? I’m in NH USA and have special computer for this car. We fixed a throttle opening issue for someone else by looking at live data using this tool called a PDU


That is interesting, my scanner says “TP (Electric) Circuit Malfunction”. My guess was throttle position.
The battery is new and I also have a smart charger connected to it at all times so the battery should not be the issue.

The car is in Sweden so it’s a bit far from NH :sweat_smile: