Fuel sending unit not working properly

installed new unit after coating tank. the unit worked just fine on a static test before installing. Now on a full tank it only reads about 1/2 and may rise to about 3/4. presently the tank is almost empty–according to gauge—. what can be done to correct problem.
ps. new 100 amp alt at idle/135 amp driving…amp gauge working, no more dead battery. Michael. 85 xjs

First short the sender wires to prove gauge goes to FULL, to prove sender trouble. Assuming sender trouble, you will have to remove to see if float MT and or trouble with wiper arm et cetera. Sometimes a quality additive and the rapid filling of a tank can help/ degum- but that is unlikely in your case as I assume sender was on your bench recently. Older cars take a cheap Ford type brass float. Mine takes the bike pedal type.

it was new on install with a plastic float. al. wires hooked up before install. raised and lowered arm, gauge in dash responded accoringly

Did you purchase and install the correct sender for your model car? The coupes and convertibles have different senders because the tanks are shaped differently. Do you have a coupe or a convertible? What was the part number of the sender you purchased? There was another string of posts a few months ago where the wrong sender was installed and didn’t read correctly and sounds like the problem you are having. Search the archives for “fuel sender” and you will find those posts.


I have a coup–85-- don’t know part number, bee a while. bought from a trusted dealer

This will be very expensive and time-consuming repair.

  1. Take sender out
  2. Bent the rod down appox. 15degrees
  3. Put it back
  4. Repeat “calibration” if required.

Your aim is to be close to full indication, with reserve light still working when near empty
Alternatively - leave it as it is, you will preserve your tank from corrosion and always have an extra gallons when missing motorway exit…

I thought about “adjusting the rod” but ho. even thought attaching more floats to the float itself… tank is almost empty will try your suggestion

bent “rod” several times, no response. still the same reading almost empty. removed unit–works outside tank–re-installed–not working…jumped ground to red/green–read full. gas in tank just below the access port. Michael. 85 xjs

Just clarifying: you removed the sending unit, plugged the connectors together as it would be when sending unit is installed, and put a jumper to ground?

And it works outside the tank, but with the same conditions, does not work when mounted into the tank? And you’ve jumpered grounds when in the tank to?

To me, that indicates that the arm is hitting something and is not moving up when fuel is added.

I had an issue like that…when my tank collapsed after a Rochester valve failure.

You can add air, and it won’t take much to pop it back in place…maybe 5psi, not much more. If you overdo it, you’ll break a seal and will be replacing that tank.

yep, jumped the ground to the green/red wire and the gas gauge worked… What could it be hitting. tried bending the rod back toward the sender. would not go in position. re-bent the rod forward it went into the tank…maybe its the wrong sending unit???

Do you have an old one you took out to compare to?

If not, compare the arm to photos of ones for your car and look for differences.

As I mentioned a while back in this thread you might have gotten a sending unit for a convertible and tried to install it in your coupe. They are different because the tanks are shaped differently.

Attached is a picture of the sending unit electrical connections in our 1990 XJ-S convertible. Does your sender look like this? I have read that the terminals on the coupe look different to prevent mixing them up, but I am not positive of that.
Please post a picture of your sending unit.


did this come through

thesis from an 85 xjs

Yes, your picture came through OK. That does not appear to be a fuel sender from a convertible.
There appears to be a “B” in black maker on the pin with the Brown Pink wire on it and a “P” written near the pin with the Black ground wire on it. Is it possible that you connected the wires to the wrong pins on the sender? Perhaps if you swapped those wires the sender might work properly?


The black wire is going to the terminal that is permanently ground (at that doesn’t vary, so let’s not go there).

The other two conductors go to terminals insulated from ground.

What does the wiring schematic say goes to ground?

black is ground , goes to upper left terminal…other 2 are insulated to the mechanism. shorting the black to the red/green causes the gauge to read full…switching wires, does not do anything…rong sending unit???

That’s what I was thinking it would be as black, plain black, is almost always ground.

Black with a white tracer conductor … and all bets are off as that is frequently not ground.

Wrong sending unit? If it works properly outside the tank but not in the tank, seems like wrong arm (i.e., wrong sending unit or assembled with wrong arm) or something wrong in the tank (partially collapsed?)

Did you search for a photo of the correct sending unit and compare it and the arm to yours?

According to Figure 19.1 of the S57 MY 90 Electrical Guide for our 1990 XJ-S convertible there are three wires going to the sending unit, Black (B), Light Green/Orange (LGO), and Brown/Pink (NK). Shorting the LGO to B should result in full quantity indication. Shorting the NK to B should result in your Low Fuel caution light on the dash to illuminate. I had an inoperative Low Fuel caution light for a while. When I removed the (original?) sender and tested it the Low Fuel function did not work but the quantity function did work. When I tested a new sender that I purchased before installation it caused the Low Fuel caution light to come on. Our convertible now has a functioning Low Fuel caution light and a fuel quantity gauge that works properly again.
I suppose that earlier cars, later cars, or coupes might work differently, but this is how a 1990 XJ-S convertible works.